Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot block video autoplay (tried ALL available methods)

  • 7 replies
  • 3 have this problem
  • 11 views
  • Last reply by jungley

more options

I have set the following settings in about:config:

media.autoplay.enabled = false plugins.click_to_play = true

This is my complete list of installed PLUGINS:

Microsoft Office 2013 Adobe Acrobat Java Deployment Toolkit Java(TM) Platform Silverlight Plug-in (disabled) OpenH264 Video Codec (disabled) VLC Web Plugin (disabled)

This is the list of installed add-ons:

-Flashblock 1.5.18 (active, and set to block HTML5, Silverlight as well) -StopTube 0.2.1 (active)

Even with all of this set, video advertisements still autoplay AND are lacking any controls to stop playing. (Some combination of the above are blocking the video portion, but the video audio is still auto playing.)

Here is an example of the video I am trying to block. Scroll down the page, and after a short delay it will embed itself and start playing:

http://thedailybanter.com/2015/01/so-few-fcks-so-little-time/

I FEEL VIOLATED.

All Replies (7)

more options

Pictures attached.

more options

See this page of user reviews for Flashblock for some possible solutions. https://addons.mozilla.org/en-US/firefox/addon/flashblock/reviews/?page=2

more options

In the comments page some people recommended using AdBlock instead, I found that AdBlock was able to block the video.

However, that is really a separate issue, as I wasn't specifically looking for a way to block ads but rather a way to prevent the browser from autoplaying videos (whether they be ads or not).

This is a browser setting. I have set "media.autoplay.enabled = false" and yet autoplay still occurs, therefore this seems like a pretty serious bug in Firefox to me. Nobody wants videos to autoplay, it should never even be a default setting.

Modified by jungley

more options

It's not as simple as a "setting" in Firefox 35. I was having that issue with Firefox 28 for about the last two weeks - and I have never used Flashblock to stop "autoplay". I use NoScript options to "Forbid" Embeddings like Flash and to provide a button to allow me to view videos what I want to.

There was a transparent image added over the video frame, so Flashblock can't "see" the video to block it. You need to "remove" that transparent image so that Flashblock can block the video.

See these postings on that page.

"Remove it Permanently" AddOn does the trick! Flashblock works - use "remove this permanently GREAT FIX FOR FLASHBLOCK AND YOUTUBE PROBLEM, THANKS! - "nuke anything enhanced" fix is simple and WORKS GREAT

My suggestion is to use this extension. https://addons.mozilla.org/en-US/firefox/addon/remove-it-permanently/

more options

Perhaps this is not the right place to ask, but I don't understand why you don't think it can be "as simple" as a setting.

If the video requires Flash plugin to play, and Firefox has "plugins.click_to_play = true" then it should be impossible for the Plugin code to be activated before a mouse click. There is no Javascript command to move the mouse and force the user to click, so it should be impossible to circumvent this without some form of remote code execution breach.

If it's an HTML5 video, then the video is decoded and played by the browser itself -- not a third party plugin. That means Firefox software has complete control on whether or not to play a video.

There is no reason why putting a video underneath another element should allow it to bypass Firefox's internal system calls for how to resolve interpreting the HTML5 "video" tag.

Plain and simple, this means that the config flags for "plugins.click_to_play" and "media.autoplay.enabled" are not implemented correctly...

Modified by jungley

more options

media.autoplay.enabled only works for the video and audio tag and the built-in HTML5 media player and not when a plugin is used. To prevent a plugin from playing you would have to disable that plugin.

more options

cor-el, please see the list of installed plugins in my screenshot from the original posting