Eheka Pytyvõha

Emboyke pytyvõha apovai. Ndorojeruremo’ãi ehenói térã eñe’ẽmondóvo pumbyrýpe ha emoherakuãvo marandu nemba’etéva. Emombe’u tembiapo imarãkuaáva ko “Marandu iñañáva” rupive.

Learn More

New Tab: no cursor in the address bar

  • 5 Mbohovái
  • 2 oguereko ko apañuãi
  • 25 Hecha
  • Mbohovái ipaháva jeremy76

more options

I frequently open new tabs by right-clicking the current tab and choosing "New Tab" from the context menu. Naturally, I want to start typing a URL or search term.

But the focus/cursor/caret is nowhere and typing does nothing. I have to click on the address bar, and then I can type.

I'm not using New Tab Override and I have Firefox's new tab set to a blank page.

I tried disabling all my add-ons, but I still had the problem.

I tried setting new tab to the Firefox home page and for a short while I got a cursor in the address bar. But the problem returned after a few hours

Any clues on what might be wrong? Firefox version 120.0.1 (64-bit) on MacOS Ventura 13.5.1. Thanks!

(A similar problem is described here: https://support.mozilla.org/en-US/questions/1420220 -- but in my case this is not a container tab.)

I frequently open new tabs by right-clicking the current tab and choosing "New Tab" from the context menu. Naturally, I want to start typing a URL or search term. But the focus/cursor/caret is nowhere and typing does nothing. I have to click on the address bar, and then I can type. I'm not using New Tab Override and I have Firefox's new tab set to a blank page. I tried disabling all my add-ons, but I still had the problem. I tried setting new tab to the Firefox home page and for a short while I got a cursor in the address bar. But the problem returned after a few hours Any clues on what might be wrong? Firefox version 120.0.1 (64-bit) on MacOS Ventura 13.5.1. Thanks! (A similar problem is described here: https://support.mozilla.org/en-US/questions/1420220 -- but in my case this is '''not''' a container tab.)

Ñemoĩporã poravopyre

I found the answer. I had accessibility.typeaheadfind set to true in about:config.

Emoñe’ẽ ko mbohavái ejeregua reheve 👍 0

Opaite Mbohovái (5)

more options

There are keyboard shortcuts to set focus to the address bar.

You can instead click the '+' icon or double-click or middle-click empty space on the Tab bar.

¿Imba’eporãva?

more options

jeremy76 said

I have Firefox's new tab set to a blank page.

Instead of using "Blank Page" for your new tab page which has this problem, change it back to "Firefox Home (Default)" and customize it to hide as much as possible. If that is not enough, you can hide the rest with userContent.css:

@-moz-document url(about:home), url(about:newtab) {
  body {
    display: none !important;
  }
}

¿Imba’eporãva?

more options

Ñemoĩporã poravopyre

I found the answer. I had accessibility.typeaheadfind set to true in about:config.

¿Imba’eporãva?

more options

I can still reproduce your issue with accessibility.typeaheadfind set to false. Is your new tab page still set to "Blank Page"?

¿Imba’eporãva?

more options

Thanks @zeroknight.

Actually I changed it back to "Firefox Home (Default)". FWIW the problem has not reappeared.

¿Imba’eporãva?

Eporandumína

Nde eikéke nde mba’etepe embohovái hag̃ua ñe’ẽmondo. Ikatúpa, emoñepyrũ peteĩ porandu, ndereguerekói gueteriramo nemba’ete.