Eheka Pytyvõha

Emboyke pytyvõha apovai. Ndorojeruremo’ãi ehenói térã eñe’ẽmondóvo pumbyrýpe ha emoherakuãvo marandu nemba’etéva. Emombe’u tembiapo imarãkuaáva ko “Marandu iñañáva” rupive.

Learn More

Mouse unresponsive to elements in the browser and on webpages

  • 16 Mbohovái
  • 0 oguereko ko apañuãi
  • 9 Hecha
  • Mbohovái ipaháva Rhys

more options

In Firefox, the mouse becomes partially unresponsive to elements in the browser and on web pages. This happens after 15-30 minutes after starting up the browser. Common symptoms include:

- Unable to drag and drop elements properly, including text after highlighting it. - Sometimes, the mouse continues to hold elements while dragging. Pressing ESC temporarily fixes this. - Dropdown menus on websites do not drop down when hoovering over them - Other items on websites don't display items when hoovering over them

I have tried:

- Different mouses, including my laptop's trackpad - A Firefox fork, namely Waterfox, but it still occurs - Limited testing with other browsers. No problem occurs - Limited testing on desktop. No problem occurs - Entering Troubleshooting Mode on Firefox - Clearing cookies and cache - Reinstall Firefox (including installing from command line instead of the snap store) - Updated Firefox - Refreshed Firefox - About:Processes doesn't show anything using more than 10-15% of CPU at any one time - Limited testing with a new Firefox profile. No problem occurs - Disabled WebGL and Hardware Acceleration.

Temporary fix: Restarting Firefox, but the problem re-occurs shortly after use.

Using Ubuntu.

Any help would be greatly appreciated.

In Firefox, the mouse becomes partially unresponsive to elements in the browser and on web pages. This happens after 15-30 minutes after starting up the browser. Common symptoms include: - Unable to drag and drop elements properly, including text after highlighting it. - Sometimes, the mouse continues to hold elements while dragging. Pressing ESC temporarily fixes this. - Dropdown menus on websites do not drop down when hoovering over them - Other items on websites don't display items when hoovering over them I have tried: - Different mouses, including my laptop's trackpad - A Firefox fork, namely Waterfox, but it still occurs - Limited testing with other browsers. No problem occurs - Limited testing on desktop. No problem occurs - Entering Troubleshooting Mode on Firefox - Clearing cookies and cache - Reinstall Firefox (including installing from command line instead of the snap store) - Updated Firefox - Refreshed Firefox - About:Processes doesn't show anything using more than 10-15% of CPU at any one time - Limited testing with a new Firefox profile. No problem occurs - Disabled WebGL and Hardware Acceleration. Temporary fix: Restarting Firefox, but the problem re-occurs shortly after use. Using Ubuntu. Any help would be greatly appreciated.

Opaite Mbohovái (16)

more options

Start Ubuntu in Wayland and set the environment variable MOZ_ENABLE_WAYLAND=1.

Try a different package, if you are using the default snap package, try flatpak or a manual install.

¿Imba’eporãva?

more options

Does this still happen with a new profile after using it for a longer time since you wrote: Limited testing with a new Firefox profile. No problem occurs

¿Imba’eporãva?

more options

zeroknight said

Start Ubuntu in Wayland and set the environment variable MOZ_ENABLE_WAYLAND=1. Try a different package, if you are using the default snap package, try flatpak or a manual install.

No luck with Wayland and have already tried a different package.

¿Imba’eporãva?

more options

cor-el said

Does this still happen with a new profile after using it for a longer time since you wrote: Limited testing with a new Firefox profile. No problem occurs

I did about a 15-20 minutes of testing, and the issue didn't occur. It happens completely random, so sometimes the bug doesn't occur for hours. Other times, it repeatedly happens every 15-30 minutes.

¿Imba’eporãva?

more options

Go to about:config in the address bar and create ui.primaryPointerCapabilities (Number) with value 6 to indicate you are using a mouse with hover capability.

¿Imba’eporãva?

more options

zeroknight said

Go to about:config in the address bar and create ui.primaryPointerCapabilities (Number) with value 6 to indicate you are using a mouse with hover capability.

Have tweaked this setting - will update you in a day or two!

¿Imba’eporãva?

more options

zeroknight said

Go to about:config in the address bar and create ui.primaryPointerCapabilities (Number) with value 6 to indicate you are using a mouse with hover capability.

Hi - unfortunately the issue still persists after changing this setting and testing for a couple of days. Any additional help would be greatly appreciated.

¿Imba’eporãva?

more options

What is the "Window Protocol" value listed in about:support? What version of Ubuntu?

¿Imba’eporãva?

more options

zeroknight said

What is the "Window Protocol" value listed in about:support? What version of Ubuntu?

Window Protocol isn't set to anything. I.e it asks for Boolean, Number or String.

Ubuntu 22.04.3 LTS

¿Imba’eporãva?

more options

It sounds like you are looking in about:config instead of about:support. Another way to access it is in Menu > Help > More Troubleshooting Information.

¿Imba’eporãva?

more options

zeroknight said

It sounds like you are looking in about:config instead of about:support. Another way to access it is in Menu > Help > More Troubleshooting Information.

Sorry, misread! Window Protocol is xwayland.

¿Imba’eporãva?

more options

When you apply MOZ_ENABLE_WAYLAND=1, the Window Protocol should change to "wayland" (without the x).

¿Imba’eporãva?

more options
How do I change that variable?

zeroknight said

When you apply MOZ_ENABLE_WAYLAND=1, the Window Protocol should change to "wayland" (without the x).

How do I change that variable?

¿Imba’eporãva?

more options

It's an environment variable, so you can export it or use it on the command line:

MOZ_ENABLE_WAYLAND=1 firefox

¿Imba’eporãva?

more options

zeroknight said

It's an environment variable, so you can export it or use it on the command line: MOZ_ENABLE_WAYLAND=1 firefox

I get this on the command line: Not loading module "atk-bridge": The functionality is provided by GTK natively. Please try to not load it.

It then opens a fresh Firefox window and Window Protocol remains as xwayland.

¿Imba’eporãva?

more options

Any additional help getting this sorted would be greatly appreciated

¿Imba’eporãva?

Eporandumína

Nde eikéke nde mba’etepe embohovái hag̃ua ñe’ẽmondo. Ikatúpa, emoñepyrũ peteĩ porandu, ndereguerekói gueteriramo nemba’ete.