On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Eheka Pytyvõha

Emboyke pytyvõha apovai. Ndorojeruremo’ãi ehenói térã eñe’ẽmondóvo pumbyrýpe ha emoherakuãvo marandu nemba’etéva. Emombe’u tembiapo imarãkuaáva ko “Marandu iñañáva” rupive.

Learn More

browser.fixup.alternate.enabled false does not work anymore in 54.0.1 Linux; URL "name:port/path" is always redirected to "www.name.com/path"

  • Mbohavai’ỹre
  • 1 oguereko ko apañuãi
  • 3 Hecha
more options

Disabling browser fixup using browser.fixup.alternate.enabled false does not work.

I have a local, short hostname <name> in /etc/hosts, /etc/nsswitch.conf has "hosts: files dns" but <name> is not in DNS. Therefore, nslookup <name> fails, but ping <name> resolves and pings the host successfully.

The problem: Firefox always replaces the URL "name:port/path" with "www.name.com/path" (which is wrong anyway as it omits the port).

Workaround: Creating and using an alias "name.local" in /etc/hosts works; "name.local:port/path" displays the correct page. So does using the IP address ;-)

Desired solution: I need a way to reliably disable browser fixup to avoid sending information to "www.name.com".

An acceptable solution (for me, not for security-aware people) would be if firefox first tried to resolve "name" (using standard name resolution "gethostbyname*", not just DNS!) and only tried the fixup if there was no IP address found for "name". All the documentation says that fixup would only be tried if "name" cannot be resolved, but the fact the "name.local" works, but "name" is "fixed-up" disproves that.

Disabling browser fixup using browser.fixup.alternate.enabled false does not work. I have a local, short hostname <name> in /etc/hosts, /etc/nsswitch.conf has "hosts: files dns" but <name> is not in DNS. Therefore, nslookup <name> fails, but ping <name> resolves and pings the host successfully. The problem: Firefox always replaces the URL "name:port/path" with "www.name.com/path" (which is wrong anyway as it omits the port). Workaround: Creating and using an alias "name.local" in /etc/hosts works; "name.local:port/path" displays the correct page. So does using the IP address ;-) Desired solution: I need a way to reliably disable browser fixup to avoid sending information to "www.name.com". An acceptable solution (for me, not for security-aware people) would be if firefox first tried to resolve "name" (using standard name resolution "gethostbyname*", not just DNS!) and only tried the fixup if there was no IP address found for "name". All the documentation says that fixup would only be tried if "name" cannot be resolved, but the fact the "name.local" works, but "name" is "fixed-up" disproves that.