Eheka Pytyvõha

Emboyke pytyvõha apovai. Ndorojeruremo’ãi ehenói térã eñe’ẽmondóvo pumbyrýpe ha emoherakuãvo marandu nemba’etéva. Emombe’u tembiapo imarãkuaáva ko “Marandu iñañáva” rupive.

Learn More

Firefox suggesting bookmarks in address bar, even when only "History" is selected in settings

  • 4 Mbohovái
  • 2 oguereko ko apañuãi
  • 64 Hecha
  • Mbohovái ipaháva jheel

more options

I have cleared history completely. Selected "History" in the suggest in address bar option, and restarted firefox. My history is cleared, but now when i type 'h', hpshoppingindia.com automatically shows up in the address bar. When I type 'a', asus.com automatically shows up in the address bar. These two websites are bookmarked. But I have not asked firefox to suggest bookmarks in the address bar? (take a look at the attached image). If I delete asus.com and hp.com from bookmarks, typing 'a' or 'h' doesn't auto-populate the addrerss bar with asus.com or the Hewlett packard website. But if bookmark them again, typing h or a brings them up in the address bar.

Strangely, this is not true for all bookmarks. I have lots of bookmarks, but the problem is present in only 3 of them (so far), hp, asus, and this page : http://en.savefrom.net/ (typing e brings this address in the address bar, on a blue background, image attached. The same happens with hp and asus, they come up in the address bar with a blue background if i type a or h).

Why's this happening?

Firefox 31.7.0 ESR/ Windows 8.1 Pro (64).

I have cleared history completely. Selected "History" in the suggest in address bar option, and restarted firefox. My history is cleared, but now when i type 'h', hpshoppingindia.com automatically shows up in the address bar. When I type 'a', asus.com automatically shows up in the address bar. These two websites are bookmarked. But I have not asked firefox to suggest bookmarks in the address bar? (take a look at the attached image). If I delete asus.com and hp.com from bookmarks, typing 'a' or 'h' doesn't auto-populate the addrerss bar with asus.com or the Hewlett packard website. But if bookmark them again, typing h or a brings them up in the address bar. Strangely, this is not true for all bookmarks. I have lots of bookmarks, but the problem is present in only 3 of them (so far), hp, asus, and this page : http://en.savefrom.net/ (typing e brings this address in the address bar, on a blue background, image attached. The same happens with hp and asus, they come up in the address bar with a blue background if i type a or h). Why's this happening? Firefox 31.7.0 ESR/ Windows 8.1 Pro (64).
Mba’erechaha japyhypyre oñondivegua

Moambuepyre jheel rupive

Ñemoĩporã poravopyre

I fixed it :)

This is what i did:

STEP 1> Type about:config in the address bar. (click to proceed on the "this will void warranty" message).

STEP 2> Search for 'url'.

STEP 3> locate "browser.urlbar.autoFill", it has a Boolean value 1 (true) set to it by default, double click on it to set it to 0 (false). Restart firefox. Issue resolved.

I really think this option should be included in the standard settings menu.

Keeping this option "disabled" by default wouldn't hurt much either, It does no good. History and Bookmarks will show up under the address bar (depending on what option you select in settings) even with this option disabled, it just won't autocomplete the address (on a blue background).

With this option set to false, the annoying problem of bookmark entries showing up even when only history is selected has been resolved.

See attached images for clarification.

Happy happy happy :)

Emoñe’ẽ ko mbohavái ejeregua reheve 👍 0

Opaite Mbohovái (4)

more options

That would normally only happen if you have visited a bookmarked website.

Did you check the history to see if you can locate those visits?


Another possibility could be a problem with the places.sqlite file.

more options

cor-el, thanks for replying. there's something wrong with my firefox i think. it's suggesting history even when i have asked it to suggest "bookmarks" only! i visited this website www.duckduckgo.com for the first time ever, restarted firefox, and typed 'd', duckduckgo shows up in the address bar. It's not bookmarked, and i have asked firefox to show bookmarks only (screenshots attached). And en.savefrom.net is showing up from bookmarks, even if i ask firefox to show history only. en.savefrom.net is not present in history (i just cleared history again, and clicking on the small downward arrow beside the address bar does not show any history present). Ran the places maintenance add-on you linked, it says database is sane, and a bunch of other things, but the problem persists. Anything else I can try? (other than re-installing firefox. I have so many bookmarks and addons, i don't want to have to install everything again)..


Places Maintenance messages: > Integrity check + The database is sane > Reindex + The database has been reindexed > Orphans expiration + Database cleaned up > Coherence check + The database is coherent > Vacuum Initial database size is 10240 KiB + The database has been vacuumed Final database size is 10240 KiB > Statistics Database size is 10240 KiB user_version is 23 page_size is 32768 cache_size is -2048 journal_mode is wal synchronous is 1 History can store a maximum of 104858 unique pages Table moz_places has 32 records Table moz_historyvisits has 5 records Table moz_inputhistory has 0 records Table moz_hosts has 17 records Table moz_bookmarks has 37 records Table moz_bookmarks_roots has 5 records Table moz_keywords has 0 records Table sqlite_sequence has 0 records Table moz_favicons has 19 records Table moz_anno_attributes has 8 records Table moz_annos has 11 records Table moz_items_annos has 33 records Table sqlite_stat1 has 14 records Index sqlite_autoindex_moz_inputhistory_1 Index sqlite_autoindex_moz_hosts_1 Index sqlite_autoindex_moz_bookmarks_roots_1 Index sqlite_autoindex_moz_keywords_1 Index sqlite_autoindex_moz_favicons_1 Index sqlite_autoindex_moz_anno_attributes_1 Index moz_places_faviconindex Index moz_places_hostindex Index moz_places_visitcount Index moz_places_frecencyindex Index moz_places_lastvisitdateindex Index moz_historyvisits_placedateindex Index moz_historyvisits_fromindex Index moz_historyvisits_dateindex Index moz_bookmarks_itemindex Index moz_bookmarks_parentindex Index moz_bookmarks_itemlastmodifiedindex Index moz_places_url_uniqueindex Index moz_places_guid_uniqueindex Index moz_bookmarks_guid_uniqueindex Index moz_annos_placeattributeindex Index moz_items_annos_itemattributeindex.


Thanks...

Moambuepyre jheel rupive

more options

UPDATE: I have another user account on the computer. Logged in with that acount, firefox uses different settings and add-ons here. But yet, the problem is present in this account as well (this is the administrator account).

I used the "Reset firefox" option in this other account (i don't care about the add-ons here, don't use admin for web browsing)- firefox lost all add-on's even the skin, and restarted with the stock ugly skin.

But yet, the problem is still present even after the reset. Bookmarked a website www.snapdeal.com, cleared history, set firefox to show history only in the address bar, restarted firefox, typed s in the address bar, snapdeal.com shows up! Deleted snapdeal bookmark, it doesn't show up. Bookmarked snapdeal.com again, it shows up again if i type s.

Please take a look at the attached picture, I'm not sure if I'm making myself clear?

Will someone be kind enough to log-in to my computer with team viewer and check this out? It'll be awesome if someone can fix this for me... Even reset firefox didn't work :(

more options

Ñemoĩporã poravopyre

I fixed it :)

This is what i did:

STEP 1> Type about:config in the address bar. (click to proceed on the "this will void warranty" message).

STEP 2> Search for 'url'.

STEP 3> locate "browser.urlbar.autoFill", it has a Boolean value 1 (true) set to it by default, double click on it to set it to 0 (false). Restart firefox. Issue resolved.

I really think this option should be included in the standard settings menu.

Keeping this option "disabled" by default wouldn't hurt much either, It does no good. History and Bookmarks will show up under the address bar (depending on what option you select in settings) even with this option disabled, it just won't autocomplete the address (on a blue background).

With this option set to false, the annoying problem of bookmark entries showing up even when only history is selected has been resolved.

See attached images for clarification.

Happy happy happy :)

Moambuepyre jheel rupive