Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Whenever I try to open a download page, the message showing 'outdated plug in java (TM) SE 7 U is enabled on this site'. I updated the plug in, but no result.

  • 3 replies
  • 3 have this problem
  • 2 views
  • Last reply by philipp

more options

Whenever I try to open a download page, the message showing 'outdated plug in java (TM) SE 7 U is enabled on this site'. I updated the plug in, but no result. After that the options come, 'block plug in' and 'continue allowing'. please help.

Whenever I try to open a download page, the message showing 'outdated plug in java (TM) SE 7 U is enabled on this site'. I updated the plug in, but no result. After that the options come, 'block plug in' and 'continue allowing'. please help.

All Replies (3)

more options

hello Soumya84, from now on firefox will block every version of the java plugin per default - this step was taken because of oracle's bad security record in the past (sitting on unfixed vulnerabilities for months).

you can enable it on a per-demand basis though: How to allow Java on trusted sites

more options

Thanks for your reply, Philipp. But this ain't solving my problem yet. Actually by clicking on the plug-in icon, there are two buttons showing, one is 'Block plug-in' and another is 'Continue allowing'. I clicked on 'Continue allowing', but nothing worked. A preview has been attached. Now How can I solve this?

more options

what version of java is displayed when you go to https://www.mozilla.org/plugincheck/ (it should currently be java 7 update 45 - if not try to download it again from java.com).

if java plugin content isn't playing despite you have allowed it from the icon in the address bar please also make sure, that you're not using an addon like noscript, adblock or others that might also block such content & you may need to accept all security-related messages that come from the java plugin itself...

Modified by philipp