Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

website won't let me leave loaded page

  • 12 replies
  • 9 have this problem
  • 88 views
  • Last reply by punkrocklaw

more options

"http://doodleboxdesign.co.uk/fonts/1/#videoplay" this page took control of your browser=when I was directed to it from another webpage.

The above site would not let me close the tab it loaded in. When I used control,alt,delete to close firefox v22.0 and reopened firefox the above page reopened in a tab.

Chosen solution

You can delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox profile folder to prevent a previous session from starting.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).


Set the Integer pref browser.sessionstore.max_resumed_crashes to 0 on the about:config page to get the about:sessionrestore page immediately with the first start after a crash has occurred or the Task Manager was used to close Firefox.

That way you see if the previous session didn't close properly or crashed and will allow you to deselect the tab(s) that you do not want to reopen, but will allow to reopen other tabs.

See:

Read this answer in context 👍 2

All Replies (12)

more options

Chosen Solution

You can delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox profile folder to prevent a previous session from starting.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).


Set the Integer pref browser.sessionstore.max_resumed_crashes to 0 on the about:config page to get the about:sessionrestore page immediately with the first start after a crash has occurred or the Task Manager was used to close Firefox.

That way you see if the previous session didn't close properly or crashed and will allow you to deselect the tab(s) that you do not want to reopen, but will allow to reopen other tabs.

See:

more options

Thanks cor-el

more options

I would really hope there would be a more elegant solution to this problem.

It's not really acceptable that a page can just refuse to let you close the tab without you having to dig into the guts of your browser settings to make alterations to your core configuration.

You should just be able to override the warning, or have a prompt after the warning loops X number of times or something.

This has happened to me a few times lately and it's getting a little tiresome to have to jump through hoops to get around it. Intentionally killing the browser, monkeying with sessions etc.

more options

I had a problem like that once. Other than closing Firefox, I found another way. The box asks do you want to leave? I click yes, and the web page reloads the same page again. What I found was, put the mouse over the close window / tab X, use the keyboard to select yes, and press the X before the program can reload the page.

more options

The easy way is to disable Javascript and close the tab as you would have done normally :D

more options

And just how do you propose to do that? Given that you can't close it while the browser is open initially, because the dialog loops, which prevents any interaction with the browser other than that dialog. Or if you kill the browser and reopen it, the tabs reload again (if the tab isn't the tab that gets focus on being loaded, you can potentially disable javascript before that tab loads again, but this still requires killing the browser... which is a very poor way to handle it.)

more options

Ok, just use this page as an example:

http://police-stop.chargingcenter.be/
De linkified, may still paste. This is pseudo ransomware. It does make Firefox appear locked. ~J99

Don't worry, it's a fake website asking for your credit card.

My idea is that the website keeps asking if you wan't to leave. If you click don't leave you can stay in the page and disable javascript, then close the tab.

To disable javascript i used "Web Developer 1.2.5" but i don't think it would have been different doing it from the options.

Try it on the website i posted

Modified by John99

more options

Ah, when I tried doing it before it wouldn't actually disable the javascript until the page reloaded, but trying to reload the page would trigger the dialog, preventing you from getting to the point where it was disabled.

more options

The site

  • http://police-stop.chargingcenter.be/

should be reported as malware and impersonating police etc sites.

I will delinkify that so it is not clickable, as it could problematic to those clicking on it.

Also see thread WARNING FBI LOCKED BROWSER!!! /questions/981475

Just holding down the return key so it auto repeats gets out of that. The example given takes about 100 clicks to exit.

more options

Maybe the page originally posted about has changed

I am not seeing a problem with that at the moment.

If the issue is use of onebeforeunload then a recently fixed bug should help from Firefox 29 onwards.

  • *Bug 636374 - Don't show multiple dialogs when a page has multiple frames with onbeforeunload

Not sure anything is to be done about the interception of control keys when JS is enabled

  • Bug 953147 - Ransomware locks Firefox tab, uses onbeforeunload and catchControlKeys
more options
more options

I'm a little late to the game here, but the best way I've found to get rid of these tabs is just to disable javascript. These pages use javascript to throw up those "Are you sure you want to leave this page?" popup messages and reload the page.

Just type about:config in the address bar (I usually have to open a new window to do this because I can't even leave the hijacked tab), and search for javascript.enabled. Double-click it to toggle it to false. Then just go back to your hijacked tab and close it. Just make sure to go back and enable javascript when you're done.