Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmarks & Home Page default to USA not to UK

  • 6 replies
  • 1 has this problem
  • 3 views
  • Last reply by philipp

more options

I tried to change my Home Page to The Guardian the UK newspaper. It has 3 settings UK,US and AU. Everytime I try to set it to UK, it accepts it, but then on restarting my computer the Home Page is the Guardian US NOT UK. In addition the bookmark I have for the Guardian which was set to UK is now suddenly opening up as a US setting instead of the previous UK. I do live in the USA, but I am unable to understand or fix this problem of setting to the UK which had NOT been a problem till this week. Any ideas anyone?

I tried to change my Home Page to The Guardian the UK newspaper. It has 3 settings UK,US and AU. Everytime I try to set it to UK, it accepts it, but then on restarting my computer the Home Page is the Guardian US NOT UK. In addition the bookmark I have for the Guardian which was set to UK is now suddenly opening up as a US setting instead of the previous UK. I do live in the USA, but I am unable to understand or fix this problem of setting to the UK which had NOT been a problem till this week. Any ideas anyone?

All Replies (6)

more options

I tried all three alternatives and it works....

Try Firefox Safe Mode to see if the problem goes away - maybe some add-on gets in the way unasked. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

what site have you set as your homepage? www.guardiannews.com seems to point to the US edition, www.guardian.co.uk to the UK one...

more options

Such details may be stored in a cookie, so make sure that you keep such a cookie.

  • Create an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep such a cookie, especially for secure websites and if cookies expire when Firefox is closed.

Make sure that you do not run Firefox in Private Browsing mode.

Do not use Clear Recent History to clear the "Site Preferences" and the "Cookies" as this doesn't take exceptions into account, but removes all specified data.

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

more options

Yes of course I set it to http://www.guardian.co.uk/. Having set it. It still defaults to http://www.guardiannews.com/ Which of course is my original problem.

more options

Many thanks smo. It has the same problem in safe mode too, so I'm going through the troubleshoot extensions. Interestingly having played with the safe mode, my bookmark has returned to http://www.guardian.co.uk/. Thanks again. Cor-el, Many thanks. Going to look at those suggestions. I had run Firefox in Private Browsing Mode so that might well have started the problem. I will let everyone know once I've found a solution.

more options

ok, i've tested it myself now by accessing it with an us-based ip-address & the site is indeed redirecting you to the US version in this case. when you choose the UK version afterwards, a session cookie gets set with specifies which version you want to use. each time you close the browser, the cookie gets deleted and the same issue begins again...

so basically it's an issue on how the site is implementing the location based redirect. this has to be solved by the guardian on their server side, so please contact and ask them to store your selection in a cookie which doesn't expire at the end of each session.