Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I only allow SPECIFIC webpages the ability to refresh or redirect?

  • 5 replies
  • 15 have this problem
  • Last reply by fionatwolee

more options

Is there some way to have FIrefox only allow specific webpages the ability to reload or refresh a page? I already know of the

Tools -> Advanced -> Warn me when webpages attempt to refresh or reload the page

option. I am looking for the ability to only allow specific webpages, not ALL webpages.

All Replies (5)

more options

You can click the Allow button to allow a redirect or a refresh. That works pretty well.

more options

I do the allow button for the specific page, but I'm using a webpage that is constantly updated with new data, and needs to be continuously refreshed. As a result, simply clicking it once to allow that update is not feasible.

I'm looking for a 'white list' of sorts that allows specific webpages the ability to refresh/redirect as needed. I could have sworn there was a feature for this in a previous version, but it is no longer available.

more options
more options

Without additional information on the addon, as the documentation provided is sorely lacking, this addon doesn't help much.

Now if Firefox itself had a built-in whitelist / blacklist of pages allowed to redirect/refresh automatically, I'd be all for it.

Appreciate the thought cor-el, but it doesn't help.

more options

If you are clicking on email credit links from safelists or list builders an easy way to avoid the page redirect problem is to right click on the credit link and select open in a new tab Then you can just click the red cross on the tab to close it after you're done.

Right clicking sometimes works when you are visiting a website and click on an external link. An example of this would be if you click on a link on the home page of your ISP that would take you to another website. If you do get an allow redirect button close it then go back and right click the link and select "open in a new tab". Sorry for the lengthy reply but I hope it helps you. fionatwolee.

Modified by fionatwolee