Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook not opening correctly in Firefox 17.0.1 in Windows 8

  • 14 replies
  • 32 have this problem
  • Last reply by Gwytherinn

more options

Since i have installed Firefox on Windows 8 in my PC, i am not able to open Face book web site, this is the only web site which is found to be having issues with Firefox rest is ok, nowdays i am using chrome for my FB needs but would like for firefox to correct this issue. i am unable to view any thing when opening the website. On the bellow link you can find out the snapshot of my Firefox with FB open, this page does not load further and looks like this way only. kindly help.

All Replies (14)

more options

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

more options

Sorry believe now it has nothing to do with clearing cookie cache which I have done many times in past few days using CCleaner. Been noticing problems ever since updating to latest Java SE 7 U5 If you check in FF Tools > Add-Ons > Plugins you will notice the new version of Java has compatibility/security issues. And noticed yesterday FF had disabled Java completely without me knowing about it. So tried IE browser and all was fine in there with FB site.

more options

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

more options

Tried your Safe Mode approach, no good. Did you read my post re; Java and Firefox stability and security issues since updating to latest version? So it has nothing to do with cookies, or other extensions, think my next move is to install Google Chrome and see if that has any problems.

more options

Java is essential to browsing, so it would do no good at all disabling this?

more options

Firefox java issue is there..
its already filed in bug.
the problem will be solved soon...

but i'm not facing any problem when accessing Facebook...

more options

Did you changed network pref in about:config

are you accessing via proxy server?

more options

No issues with network connection, and not being rude but not changing anything in about:config until that bug is fixed because FB has not been loading ever since FF had disabled Java because of that bug. Using Chrome until its fixed....

more options

Have been doing some more digging and found that Facebook must be having server problems, so this along with the Java issue would not be helping. Facebook is undergoing advertised upgrades. Thanks for your help bro, peace!

more options


more options

Be careful with using external programs to clear personal Firefox data as this can lead to profile corruption.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

You can try to reset (power off/on) the router.

more options

I thoroughly test third party programs before endorsing and CCleaner is an awesome cleaning program, impossible for it to corrupt Firefox files. It merely clears cache of temp internet files, cookies. It is a perfect tool to clean rubbish after a week or so of browsing depending on personal use.

Have done more research and rather than format my PC will be patient and hope the Facebook script bug sorts itself out because now convinced this is a combined problem with latest Java plugin, regardless of what browser you use.

more options

Since changing network settings to OpenDNS, Facebook opens much quicker and sweeter than ever before. Manually set DNS to in PC, not in Router.

After setting preferred DNS, then ran CMD and entered ipconfig /flushdns. Cleaned!

My apologies for stating before it has nothing to do with Network, but this is a bit different than what was suggested, thanks.

more options

Is there a more permanent solution to this? I first noticed it happening with Facebook, but it happens with any site I visit regularly. The first visit after clearing the cache is fine, but on the second or third visit I am back to no CSS and a number of graphical irregularities that make browsing impossible. If I went to clear the cache every time this happened I'd be doing it every 5 minutes. I use ctrl-f5 as a temporary solution, but the issue is rather frustrating. I already tried creating a new profile as well, but that didn't clear things up.

Modified by Gwytherinn