Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I type a website, the autocomplete doesn't let me type in the correct site

  • No replies
  • 4 have this problem
  • 1 view
more options

When I try to type in "maps.google.com" in the url field, the autocomplete returns http://www.amazon.com as I type the first letter, "m." I then proceed to type the second letter, but the 'h' from 'http' stays on, so now it's 'ha.' I can't backspace to delete it. I basically can't type in maps.google.com because I have amazon.com as a autocomplete site. How do I fix this?