Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

track pad pinch open and close not working with Firefox 4

  • 9 replies
  • 126 have this problem
  • 1 view
  • Last reply by DianeVan

more options

the pinch open and close feature to adjust size on my Mac track pad does not work

Chosen solution

The first part is the name of the pref and the second part the command that you can use as the new value of the pref. The prefs have an empty string value and you can double click the pref to modify the value with a copy and paste.

browser.gesture.pinch.in -> cmd_fullZoomReduce
browser.gesture.pinch.in.shift -> cmd_fullZoomReset
browser.gesture.pinch.out -> cmd_fullZoomEnlarge
browser.gesture.pinch.out.shift -> cmd_fullZoomReset
Read this answer in context 👍 21

All Replies (9)

more options

Some mouse gestures have been removed in Firefox 4.

You can restore the zoom feature by changing the values of the related prefs on the about:config page.

browser.gesture.pinch.in cmd_fullZoomReduce
browser.gesture.pinch.in.shift cmd_fullZoomReset
browser.gesture.pinch.out cmd_fullZoomEnlarge
browser.gesture.pinch.out.shift cmd_fullZoomReset

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

more options

hi. i opened the about config page and found these selections, but i wasn't sure if i am supposed add the rest of the command, or add a new command, not really sure what to change and what to change it to. would you please send more explicit instructions?....

will there be an update for firefox that will resolve this issue?

more options

Chosen Solution

The first part is the name of the pref and the second part the command that you can use as the new value of the pref. The prefs have an empty string value and you can double click the pref to modify the value with a copy and paste.

browser.gesture.pinch.in -> cmd_fullZoomReduce
browser.gesture.pinch.in.shift -> cmd_fullZoomReset
browser.gesture.pinch.out -> cmd_fullZoomEnlarge
browser.gesture.pinch.out.shift -> cmd_fullZoomReset
more options

thank you.

more options

You're welcome

more options

Thanks for this detailed information. I was disappointed when my trackpad gestures were not working in the new FF. I am very happy it was so easy to fix. Thank you.

more options

You can try to change this pref as well (reported by some to make it work better)

browser.gesture.pinch.latched -> false</b?
</pre>

more options

Hmm... unfortunately I have made the suggested modifications, restarted Firefox, and the gestures still do not work. Any suggestions?

UPDATE: Just saw your new comment re the change to LATCHED. Did that, and now it works. Thank you again.

Modified by Inspired121

more options

OK so that fixed it sort of. Now it's blocky in its enlarging and not smooth like the rest of the programs.

AND three finger swipe to go to bottom or top doesn't work at all.

On flickr I get messages about scripts not working

I want to go back to previous version of Firefox please - HOW?

Failing that I'll just have to use Safari, but I hate it.