Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmark Padding in New Firefox Versions 2

more options

It is sad, I think, that Mozilla/Firefox is willing to close/archive a thread that is not really solved or has reared its ugly head again in versions since the release of 93 (we are now at 97.0.2). I came to this site and registered because I am still having this issue as of 3/6/2022...arg!

I have tried the 3 recommended solutions, with no affect:

I have, as one article suggested, cleared my cache and cookies, started and restarted Firefox; the only thing I have not tried is removing it from my computer and using Chrome (I'm told it is a better browser anyway) as some responders have eluded to.

I hope that responders like "jscher2000, Kymber" will continue the champion this issue until Mozilla gets it "Really" fixed.

Thanks for listening, Wayne

BTW, heres what my dropdowns look like today 3/6/2022 6:17 PM Arizona time.

It is sad, I think, that Mozilla/Firefox is willing to close/archive a thread that is not really solved or has reared its ugly head again in versions since the release of 93 (we are now at 97.0.2). I came to this site and registered because I am still having this issue as of 3/6/2022...arg! I have tried the 3 recommended solutions, with no affect: * [https://support.mozilla.org/en-US/kb/compact-mode-workaround-firefox Compact mode workaround in Firefox] * [https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars Customize Firefox controls, buttons and toolbars] * Create the userChrome.css style sheet - no go. I have, as one article suggested, cleared my cache and cookies, started and restarted Firefox; the only thing I have not tried is removing it from my computer and using Chrome (I'm told it is a better browser anyway) as some responders have eluded to. I hope that responders like "jscher2000, Kymber" will continue the champion this issue until Mozilla gets it "'''Really'''" fixed. Thanks for listening, Wayne BTW, heres what my dropdowns look like today 3/6/2022 6:17 PM Arizona time.
Attached screenshots

Chosen solution

Wayne,

One thing, make sure in about:config that the following preference is set to true:

toolkit.legacyUserProfileCustomizations.stylesheets

Otherwise, it won't load the userChrome.css stuff. It's default value is false. If I toggle it back to false, I loose all my customizations.

Read this answer in context 👍 0

All Replies (10)

more options

I doubt that Mozilla is going to reverse course. Even compact mode is not supported and only helps with bookmark drop-downs. I have used code in userChrome.css since FF89. It had to be altered once because of a change in FF92. It should have worked for you so there must be some error in its implementation. What exactly did you do?

Helpful?

more options

I followed these instructions... Firefox users can modify the user interface of the browser using custom style rules. This involves setting up a userChrome.css file. If this is your first time, make sure to set aside 10 quiet minutes to work through it.

(For anyone who already has a userChrome.css file set up, you just need to add the rule under (A) to your file.)

(A) Select and copy the following style rule code

/*** Tighten up drop-down/context/popup menu spacing (updated 9/8/2021) ***/

menupopup:not(.in-menulist) > menuitem, menupopup:not(.in-menulist) > menu {

 padding-block: 2px !important;
 min-height: unset !important; /* v92.0 - for padding below 4px */

}

root {
 --arrowpanel-menuitem-padding: 4px 8px !important;

}

Helpful?

more options

I used the following in my userChrome.css to lessen the gap in the Bookmarks Menu:

  menupopup > menuitem, menupopup > menu {
    padding-block: 3px !important;
  }

Well, I guess the above affects all the menu drop-downs as well: File, Edit, View, History and so on which is fine with me.

Modified by MarkRH

Helpful?

more options

MarkRH, There must be something else to the style sheet solution that the poster of the possible solution left out. I have tried the style sheet snipit above and yours. I tried adding it to the file and as a stand alone sheet. The same result...padded menus.

I guess what I really have a hard time understanding is Mozilla/Firsfox's reluctance to fix this? At least give the user the option to turn it on/off.

Thanks, Wayne

Helpful?

more options

@waynelfuller. I used the same code as you except that I changed 4px 8px to 0px 2px.

Helpful?

more options

Chosen Solution

Wayne,

One thing, make sure in about:config that the following preference is set to true:

toolkit.legacyUserProfileCustomizations.stylesheets

Otherwise, it won't load the userChrome.css stuff. It's default value is false. If I toggle it back to false, I loose all my customizations.

Helpful?

more options

MarkRH,

Thanks, that did the trick. The tutorial that I used had the instructions in 2 links. The part about setting the style sheet variable to True was at the bottom of the second one. Guess I just didn't read far enough. The first tutorial made it seen that setting up the style sheet was all that needed to be done.

Thanks again, Wayne

Helpful?

more options

Yay! Glad you got it working.

Helpful?

more options

here's how I finally fixed my double-spaced bookmarks :

go to - about:config search - "browser.compactmode.show" - change to TRUE , then close that window go to - Customize Toolbar at the bottom of that page, there a box called Density. Click that, you'll see "compact (not supported)" Apparently, it IS supported because I chose that. (it looked like it ignored my choice) After I closed Customize Toolbar, the bookmarks were compact spaced again. Exactly how I need them.

Helpful?

more options

dennj; Thanks for your response. Yes, I was able to get it to work. It's still a shame though that this is a "Work Around," since apparently, despite what they say, Mozilla doesn't really care what the user community wants.

Thanks, Wayne

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.