Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

web site link does not work in Firefox OSX

  • 4 replies
  • 1 has this problem
  • 23 views
  • Last reply by user874488

more options

A web site has a link to a Store Locator. The link does not work in FF for OSX but works for FF iOS and Safari. If I open the link in Safari, then copy and paste the URL the into FF OSX, the page opens. I have disabled all of my add-ons in FF OSX and even opened the initial web site page in Safe Mode but the link does not work. I disabled as many privacy / security features in FF OSX that I could find, but still no good result. Initial page URL: https://www.mitre10.co.nz/shop/goldair-single-dimmer-vertical-h-118mm-w-74mm-white/p/247737. Store Locator page URL: https://www.mitre10.co.nz/store-locator?branchId=C3D

Chosen solution

Is Geo location enabled if you check this pref about:config page?

You can also check the Location permission in "Tools -> Page Info -> Permissions" and in "Options/Preferences -> Privacy & Security -> Permissions".

Read this answer in context 👍 0

All Replies (4)

more options

Does it work as well if you right-click the link and click "Copy Link Location" and open that link? Can you use other choices in the right-click context menu like open link in a new tab?


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Thanks for the reply. However, the suggestions stated above did not resolve the issue. I am wondering if it has to do with Locations. I have another Mac computer with exactly the same FF version, same add-ons and plugins. When I use that computer and I click on the link, a pop-up appears asking me to allow FF to use my location. I clicked Allow and the link worked. The URL also appeared in the Location Permissions. This is not what happens on the initial computer. How can I get the Locations preference to work?

more options

Chosen Solution

Is Geo location enabled if you check this pref about:config page?

You can also check the Location permission in "Tools -> Page Info -> Permissions" and in "Options/Preferences -> Privacy & Security -> Permissions".

more options

yes, changing geo.enabled to true has started the Allow pop-up and it is saving that permission. Thank you very much for your time on this problem