Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I preview ALL pdf files opened within Firefox?

  • 5 replies
  • 6 have this problem
  • 43 views
  • Last reply by user293

more options

I am having difficulty previewing PDF files using Firefox. My OS is Ubuntu 14.04 and I am running Firefox 38.0, Firefox for Ubuntu canonical - 1.0. I am having an issue that sometimes when I select PDF files, instead of previewing the file, I get a pop-up window to download the file, or view it in an external viewer. I want to always preview PDF files in Firefox with the option to download it to my files if I right click or select download in the top bar of the preview. I may be experiencing this (https://support.mozilla.org/en-US/questions/1045118) same problem but I kept getting an error when selecting "I have this problem, too".

The problem occurs whenever I try to open a PDF file from my Zotero library. These files already reside on my files, so downloading it does not make sense. Typically, I just want a quick preview to see what file it is, then if I want to read and annotate the file I select to open it in an external viewer. The behavior changed recently, probably because of an update. I tried going into the Preferences -> Applications setting then searched for "pdf" and noticed there are actually two different "Content Type" listed, "PDF document" and "Portable Document Format (PDF)". In the action menu for the latter, there is an option for "Preview in Firefox" but for "PDF document" there is no such option, only "Always ask" or "Save File" but when it asks, it only gives me an option to download it so both are useless when the file is already on my computer. I uploaded a screenshot of this so hopefully that helps.

If I cannot get this to work, I will see if Chrome/Chromium will allow me to preview pdf's. I really do not want to use a different browser for Zotero.

I am having difficulty previewing PDF files using Firefox. My OS is Ubuntu 14.04 and I am running Firefox 38.0, Firefox for Ubuntu canonical - 1.0. I am having an issue that sometimes when I select PDF files, instead of previewing the file, I get a pop-up window to download the file, or view it in an external viewer. I want to always preview PDF files in Firefox with the option to download it to my files if I right click or select download in the top bar of the preview. I may be experiencing this (https://support.mozilla.org/en-US/questions/1045118) same problem but I kept getting an error when selecting "I have this problem, too". The problem occurs whenever I try to open a PDF file from my Zotero library. These files already reside on my files, so downloading it does not make sense. Typically, I just want a quick preview to see what file it is, then if I want to read and annotate the file I select to open it in an external viewer. The behavior changed recently, probably because of an update. I tried going into the Preferences -> Applications setting then searched for "pdf" and noticed there are actually two different "Content Type" listed, "PDF document" and "Portable Document Format (PDF)". In the action menu for the latter, there is an option for "Preview in Firefox" but for "PDF document" there is no such option, only "Always ask" or "Save File" but when it asks, it only gives me an option to download it so both are useless when the file is already on my computer. I uploaded a screenshot of this so hopefully that helps. If I cannot get this to work, I will see if Chrome/Chromium will allow me to preview pdf's. I really do not want to use a different browser for Zotero.

Chosen solution

Since the file system cannot send a content-type header to Firefox, the standard preference -- Portable Document Format (PDF) -- might not apply.

The file that stores your file handling preferences is difficult to edit, so the usual suggestion is to remove it and let Firefox build a new one and see whether that works any better. If you want to try that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit {not sure where this is on Linux}

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old.

Start Firefox back up again. If you check your Application preferences, do you notice anything new/different for PDF files?

If there's no improvement and you prefer to undo the change, you can exit Firefox, delete the new mimeTypes.rdf and rename mimeTypes.old back to mimeTypes.rdf.

Read this answer in context 👍 3

All Replies (5)

more options

Chosen Solution

Since the file system cannot send a content-type header to Firefox, the standard preference -- Portable Document Format (PDF) -- might not apply.

The file that stores your file handling preferences is difficult to edit, so the usual suggestion is to remove it and let Firefox build a new one and see whether that works any better. If you want to try that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit {not sure where this is on Linux}

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old.

Start Firefox back up again. If you check your Application preferences, do you notice anything new/different for PDF files?

If there's no improvement and you prefer to undo the change, you can exit Firefox, delete the new mimeTypes.rdf and rename mimeTypes.old back to mimeTypes.rdf.

more options

@jscher2000 after removing the mimeTypes.rdf file, there is only one "content type" result when searching under preferences > applications, "Portable Document Format (PDF)" and I am able to select "Preview in Firefox" as the default behavior. Now my files in Zotero actually preview. Thank you! Hopefully this help others as well.

more options

Can you please mark jscher2000's reply as the chosen solution? Thanks!

more options

user293, I thought I did? In my view it shows as the chosen solution. What else is needed?

more options

stvn66 said

user293, I thought I did? In my view it shows as the chosen solution. What else is needed?

Odd, now it is showing as the chosen solution, so you don't have to do anything else. It wasn't before.