Ceisteanna leis an gclib seo á dtaispeáint: Taispeáin gach ceist

Firefox 91.11.0esr build on Solaris 11.4 SPARC crashes: libpci missing

Firefox 91.11.0esr compiled successfully from the github solaris userland repo on a Sun T4-1 in Solaris 11.4 SPARC. But when starting it, it opens the "choose a user" di… (tuilleadh eolais)

Firefox 91.11.0esr compiled successfully from the github solaris userland repo on a Sun T4-1 in Solaris 11.4 SPARC. But when starting it, it opens the "choose a user" dialog box and then dumps core:

michele@hemlock:/scratch/clone/components/desktop/firefox/build/sparcv9/dist/bin$ ./firefox Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: libpci missing (t=3.87565) [GFX1-]: glxtest: libpci missing Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: libpci missing (t=2.38683) [GFX1-]: glxtest: libpci missing Exiting due to channel error. Exiting due to channel error. Segmentation Fault (core dumped)

There is in fact no libpci for Solaris 11.4 SPARC. Is there some mozconfig var like "WITHOUT-PCI" or something I can set? Or some other solution? There are sources for libpci on github but only Solaris 386 is supported there.

Oracle distributes version 91.3.0 with Solaris 11.4 SPARC, so it should be possible to make a working version - I just don't know how they did it (and they're not talking :-)

Asked by Michele31416 2 mhí ó shin

Last reply by Michele31416 2 mhí ó shin