Ceisteanna leis an gclib seo á dtaispeáint: Taispeáin gach ceist

[Linux] [Developer Edition] Browser transparent (content missing)

After I have started the computer and have opened the Firefox Developer Edition, there is no website content visible - everything is transparent. Links are clickable and … (tuilleadh eolais)

After I have started the computer and have opened the Firefox Developer Edition, there is no website content visible - everything is transparent. Links are clickable and context menu opens up, but the content is just transparent (screenshot attached).

When I close & repone the firefox, then usually on 5th to 10th attempt everything starts working until next reboot.

Firefox(Default edition v94.0) is working just fine with no problems on same machine.

When I first noticed this, version was 95.0b3. Now I'm on 95.0b12.

OS is Xubuntu 21.10 and hardware is HP ZBook Power G8 - i5-11400H, Nvida Quadro T600.

I've already tried: 1) opening on safe mode, 2) reinstalling using Ubuntu's "umake" commant line tool, 3) reinstalled by downloading it from https://download.mozilla.org/?product=firefox-devedition-latest-ssl&os=linux64&lang=en-US and copying the files, 4) opening computer using both Nvida's and Intel's built-in gpu

but nothing have worked so far - still the issue persists.


Is there anything else I should try?

Thanks!

Asked by k22rma 1 seachtain ó shin

Last reply by jonzn4SUSE 4 lá ó shin

Low FPS + other problems with WebGL (games etc) only after signing into Sync

A lot of webGL apps are very low framerate (and lie about their framecounts), for example: https://webglsamples.org/blob/blob.html This runs smoothly at 60 fps in chromiu… (tuilleadh eolais)

A lot of webGL apps are very low framerate (and lie about their framecounts), for example: https://webglsamples.org/blob/blob.html This runs smoothly at 60 fps in chromium, but in firefox it behaves badly. The fps counter flickers as either 53 or 80, but in reality it is maybe 15fps or lower and very stuttery. The resolution, number of blobs, or size of the window does not change anything.

  • If I enter Troubleshooting Mode, it all returns to working order. The FPS is fixed

I have tried disabling ALL extensions, changing to the default theme, disabling hardware acceleration, deleting cache+cookies+history

I installed firefox developer edition and checked it there, and it was at 60 fps, until I logged into Sync, when it then dropped.


I use KDE manjaro linux and have hardware that is definitely good enough to run the content at high framerates normally (everything works perfect in chromium)

Asked by saganomical 6 lá ó shin

Last reply by cor-el 3 lá ó shin

Firefox not MultiThreaded

I expect that each page / tab in firefox is placed in its own thread. However, I experience that when one page gets stuck .. javascript is caught in a wait loop .. that… (tuilleadh eolais)

I expect that each page / tab in firefox is placed in its own thread.

However, I experience that when one page gets stuck .. javascript is caught in a wait loop .. that this affects other pages.

Is there something in FireFox that I can change to insure that each page is in it's own thread, and doesn't affect another page's performance?

Asked by mfuhrman 5 lá ó shin

Last reply by cor-el 5 lá ó shin

  • Cartlannaithe

Search with ctrl-k no longer works when keyword.enabled = false

For quite some time now I've had keyword.enabled set to false in my about:config because I don't like having the address bar try to autocomplete or turn things into searc… (tuilleadh eolais)

For quite some time now I've had keyword.enabled set to false in my about:config because I don't like having the address bar try to autocomplete or turn things into search, when I do a ctrl-l.

I do like that I am still able to use ctrl-k to do a search when I need to. This would place a ? at the start of the field and whatever I type gets sent to search.

In a recent upgrade, ctrl-k still places the ? at the start of the address bar but doesn't send things to search. Instead, it now behaves as if I did a ctrl-l and typed in a bad URL.

I'm on Firefox 80 (on Fedora 32) but I can't be exactly sure which upgrade brought this change in behavior.

Is there a way to get the old behavior back? ctrl-l to enter a URL, ctrl-k to search.

Asked by Ed 1 bhliain ó shin

Last reply by Mike Kaply 6 mhí ó shin

  • Cartlannaithe

Disable the stupid feature with browser closing by ctrl+q

Hi! Does anybody know how to disable browser closing by ctrl+q shortcut? It is too close to ctrl+w and sometimes I close the whole browser instead of one tab. Moreover it… (tuilleadh eolais)

Hi! Does anybody know how to disable browser closing by ctrl+q shortcut? It is too close to ctrl+w and sometimes I close the whole browser instead of one tab. Moreover it is really useless and stupid feature since I have alt+f4. Why I need another shortcut which do the same stuff? And why developers ignore this issue which was reported on several forums? I tried install extension which disable it but it doesn't work for me.

Asked by jenamax 1 bhliain ó shin

Last reply by cor-el 3 mhí ó shin

  • Cartlannaithe

Firefox "Save as" file list: Why are folders no longer at top?

I recently changed from Ubuntu Gnome to KDE Plasma. Now, when I'm running Firefox (v83) and click "Save as" to save a file from a web page, Firefox gives me a file list w… (tuilleadh eolais)

I recently changed from Ubuntu Gnome to KDE Plasma. Now, when I'm running Firefox (v83) and click "Save as" to save a file from a web page, Firefox gives me a file list with directories mixed in alphabetically, rather than at the top. This is new behavior to me; I don't know if it's new with v83 (I was previously running v82), or if it's a KDE implementation issue.

Either way, I HATE having to scroll down through page after page of files and folders to find my destination folder. Since the dialog box also incorporates full-row select, I can't even click in the file list and type the first letter of my destination folder.

Please tell me there is a way to change this behavior and have Firefox's "Save as" dialog sort the files with directories at the top!

Thanks.

Asked by ExFido 1 bhliain ó shin

Last reply by Balázs Meskó 12 mí ó shin

  • Cartlannaithe

Shortcut Creation for Ubuntu 20.04.1

I have switched from Windows 10 to Ubuntu 20.04.1 and am having trouble creating website shortcuts now. With Windows I used the following method [Support - Create a des… (tuilleadh eolais)

I have switched from Windows 10 to Ubuntu 20.04.1 and am having trouble creating website shortcuts now. With Windows I used the following method

From my research it looks this is supposed to work with Ubuntu as well? It is not working for me, is this possible?

Asked by Justin Reina 1 bhliain ó shin

Last reply by anilvijay5100 7 mí ó shin

  • Cartlannaithe

Reinstalled Ubuntu and now my bookmarks and extensions are gone

I had to reinstall Ubuntu 20.04 because I removed vital Python 2 and 3 and it broke. Before doing this I was logged into my Firefox profile and should have had my bookmar… (tuilleadh eolais)

I had to reinstall Ubuntu 20.04 because I removed vital Python 2 and 3 and it broke. Before doing this I was logged into my Firefox profile and should have had my bookmarks and extensions synced. I do not see any reason why this would not be the case. However, after my reinstall of Ubuntu and logging into Firefox profile all of my bookmarks and extensions are gone. I tried checking around Firefox and it only shows bookmarks and extensions from after my reinstall. I have not performed a backup since I reinstalled Ubuntu, but those bookmarks are there. So I don't understand why I can't find my old bookmarks and extensions from before my Ubuntu issue, because I was logged into my Firefox account. My Firefox account information should have been saved to my account not my computer anyway. Please help me I had a lot of important bookmarks on there, but can't remember all of them.

Asked by Scott 1 bhliain ó shin

Last reply by Nabeel 8 mí ó shin

  • Cartlannaithe

feature request - rollback recent update with search engine selection after starting typing using the address bar

With respect to this paragraph in this article: https://support.mozilla.org/en-US/kb/search-firefox-address-bar?as=u#w_use-a-different-search The recent updates are worse… (tuilleadh eolais)

With respect to this paragraph in this article: https://support.mozilla.org/en-US/kb/search-firefox-address-bar?as=u#w_use-a-different-search

The recent updates are worsening the usability.

Before the update, I used to do the following steps in order to search anything using an alternative search engine:

  1. press CTRL + L to focus the address bar
  2. type my search query
  3. press ALT + ↓ until the desired search engine is selected
  4. press ENTER to submit the query

Now, after the update, an additional step has been introduced

  1. press CTRL + L to focus the address bar
  2. type my search query
  3. press ALT + ↓ until the desired search engine is selected
  4. press ENTER to confirm the selection of the search engine
  5. press ENTER to submit the query

Yeah, it's just a single keypress more, but multiply it by a couple of hundreds times a day I need to do that, and you will get why I'm taking the time to report it.

Please get rid of step 4

Asked by leonixyz 1 bhliain ó shin

Last reply by cor-el 12 mí ó shin

  • Cartlannaithe

How/where do I change the DuckDuckGo url to the html page?

Hello, I use NoScript with the Firefox Nightly channel and default search to DuckDuckGo. Where is the setting for the DuckDuckGo url so that I can direct it to the html p… (tuilleadh eolais)

Hello,

I use NoScript with the Firefox Nightly channel and default search to DuckDuckGo. Where is the setting for the DuckDuckGo url so that I can direct it to the html page directly rather than wasting all the time and bandwidth of the search, the "You don't have javascript" filler redirect page, then finally the scriptless html page. The standard DuckDuckGo search address is as follows:

https://duckduckgo.com/?t=ffab&q=help+me

When you have javascript disabled, after all the redirects load, you end up at the address below:

https://html.duckduckgo.com/html/?q=help+me

My laptop is a tad on the old side, so the desktop environment taxes the system pretty heavily. I would therefore like to ask it to do less work for a search.

iTnHaAdNvKcSe, Eric

Asked by eashleyfl 12 mí ó shin

Last reply by jscher2000 12 mí ó shin

  • Cartlannaithe

Delayed start of Firefox browser....

When I click on the icon to start the browser it takes 2 minutes and 36 seconds for Firefox to connect to the Internet and display the page it is set for. I have attached… (tuilleadh eolais)

When I click on the icon to start the browser it takes 2 minutes and 36 seconds for Firefox to connect to the Internet and display the page it is set for. I have attached info from the crash report here if it helps and if not then please advise what info may help in determining the cause for this delayed start:

13:28:04.257 Error while loading 'jar:file:///usr/lib/firefox/browser/omni.ja!/chrome/browser/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND) Extension.jsm:600
    readJSON resource://gre/modules/Extension.jsm:600
    onStopRequest resource://gre/modules/NetUtil.jsm:128

13:28:04.573 [Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIAppStartup.secondsSinceLastOSRestart]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: resource:///modules/BrowserGlue.jsm :: _collectStartupConditionsTelemetry :: line 1756"  data: no] BrowserGlue.jsm:1756:9
    _collectStartupConditionsTelemetry resource:///modules/BrowserGlue.jsm:1756
    BG__onFirstWindowLoaded resource:///modules/BrowserGlue.jsm:1883
    BG_observe resource:///modules/BrowserGlue.jsm:1020
    _delayedStartup chrome://browser/content/browser.js:2181
    _delayedStartup self-hosted:1161

13:28:06.474 TypeError: date is undefined TelemetryUtils.jsm:161:1

13:28:06.815 Cc['@mozilla.org/toolkit/glean;1'] is undefined BrowserGlue.jsm:2632
    task resource:///modules/BrowserGlue.jsm:2632
    _scheduleStartupIdleTasks resource:///modules/BrowserGlue.jsm:2666

13:28:07.113 Content Security Policy: The page’s settings blocked the loading of a resource at eval (“script-src”). background.js:23202:15

13:28:08.054 Error: Can't find profile directory. 2 XULStore.jsm:66:15
    load resource://gre/modules/XULStore.jsm:66
    XULStore resource://gre/modules/XULStore.jsm:24

13:30:38.386 Error: Can't find profile directory. 2 XULStore.jsm:66:15
    load resource://gre/modules/XULStore.jsm:66
    XULStore resource://gre/modules/XULStore.jsm:24

13:31:15.343 Unchecked lastError value: Error: Missing host permission for the tab background.js:103907
    [433]</< moz-extension://02d14063-d6fc-4f5a-a198-cb6bff1aaecb/public/js/background.js:103907

13:31:15.343 Unchecked lastError value: Error: Missing host permission for the tab background.js:103914
    [433]</< moz-extension://02d14063-d6fc-4f5a-a198-cb6bff1aaecb/public/js/background.js:103914

13:31:15.344 Unchecked lastError value: Error: Missing host permission for the tab background.js:103322

    injectDOMSignal moz-extension://02d14063-d6fc-4f5a-a198-cb6bff1aaecb/public/js/background.js:103322

13:31:15.344 Unchecked lastError value: Error: Missing host permission for the tab background.js:103329

    injectDOMSignal moz-extension://02d14063-d6fc-4f5a-a198-cb6bff1aaecb/public/js/background.js:103329

13:31:24.773 Unchecked lastError value: Error: Missing host permission for the tab background.js:103907

    [433]</< moz-extension://02d14063-d6fc-4f5a-a198-cb6bff1aaecb/public/js/background.js:103907
13:31:24.774 Unchecked lastError value: Error: Missing host permission for the tab background.js:103914

    [433]</< moz-extension://02d14063-d6fc-4f5a-a198-cb6bff1aaecb/public/js/background.js:103914
13:31:24.774 Unchecked lastError value: Error: Missing host permission for the tab background.js:103322

    injectDOMSignal moz-extension://02d14063-d6fc-4f5a-a198-cb6bff1aaecb/public/js/background.js:103322

13:31:24.774 Unchecked lastError value: Error: Missing host permission for the tab background.js:103329

    injectDOMSignal moz-extension://02d14063-d6fc-4f5a-a198-cb6bff1aaecb/public/js/background.js:103329

13:31:25.074 TypeError: b is undefined products-min.75d406edb591.js:1:62
    compareVersions https://static-media-prod-cdn.itsre-sumo.mozilla.net/static/build/products-min.75d406edb591.js:1
    <anonymous> https://static-media-prod-cdn.itsre-sumo.mozilla.net/static/build/products-min.75d406edb591.js:1
    listener https://static-media-prod-cdn.itsre-sumo.mozilla.net/static/build/common-min.dcc8bd44d711.js:1
    sendPageEvent resource:///modules/UITourChild.jsm:120
    receiveMessage resource:///modules/UITourChild.jsm:101

13:31:41.739 Content Security Policy: The page’s settings blocked the loading of a resource at data:application/javascript;base64,KCgpI… (“script-src”).

13:31:56.600 Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdn.speedcurve.com/js/lux.js?id=108906238. (Reason: CORS request did not succeed).

13:31:56.804 Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdn.speedcurve.com/js/lux.js?id=108906238. (Reason: CORS request did not succeed).

13:33:09.352 Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdn.speedcurve.com/js/lux.js?id=108906238. (Reason: CORS request did not succeed).

13:34:43.407 Key key_application of menuitem Application could not be found menu.js:292
    accelText chrome://global/content/elements/menu.js:292
    _computeAccelTextFromKeyIfNeeded chrome://global/content/elements/menu.js:299
    render chrome://global/content/elements/menu.js:326
    connectedCallback chrome://global/content/elements/menu.js:342
    addAllToolsToMenu resource://devtools/client/framework/browser-menus.js:220
    addMenus resource://devtools/client/framework/browser-menus.js:303
    _registerBrowserWindow resource://devtools/client/framework/devtools-browser.js:468
    <anonymous> resource://devtools/client/framework/devtools-browser.js:820
    load resource://devtools/shared/base-loader.js:160
    _require resource://devtools/shared/base-loader.js:346
    requireHook resource://devtools/shared/Loader.jsm:103
    require resource://devtools/shared/base-loader.js:300
    initDevTools resource:///modules/DevToolsStartup.jsm:943
    onPopupShowing resource:///modules/DevToolsStartup.jsm:709

Asked by cyberoptiq 12 mí ó shin

Last reply by cor-el 12 mí ó shin

  • Cartlannaithe

Enable third Party cookies for Microsoft teams

Hello, I use Microsoft Teams daily and I recently switched to firefox. Everything is great so far except that when I try to login to teams I'm stuck in an endless loop an… (tuilleadh eolais)

Hello, I use Microsoft Teams daily and I recently switched to firefox. Everything is great so far except that when I try to login to teams I'm stuck in an endless loop and never succeed to login. I searched and found that it is a cookies issue and I should allow the following cookies:

   [*.]microsoft.com
   [*.]microsoftonline.com
   [*.]teams.skype.com
   [*.]teams.microsoft.com
   [*.]sfbassets.com
   [*.]skypeforbusiness.com

However, this format does not work with firefox and I tried placing a normal URL of each like : https://microsoft.com but it didn't work. So what is the format equivalent in firefox to these to whitelist these cookies

Asked by DizzyRope 12 mí ó shin

Last reply by jonzn4SUSE 12 mí ó shin

  • Cartlannaithe

Odd Display Problem

When using Firefox and reading from a popular and very well known online UK news site I am finding some odd things being display half way down the page. This is been occu… (tuilleadh eolais)

When using Firefox and reading from a popular and very well known online UK news site I am finding some odd things being display half way down the page. This is been occurring for months and is pretty annoying.

I am using a Toshiba Laptop running Linux and my system is up to date.

Is this likely to be a browser issue or a Linux problem? More importantly, how do I go about getting the problem resolved?

TIA.

Asked by gstrickland 12 mí ó shin

Last reply by jonzn4SUSE 11 mí ó shin