Ceisteanna leis an gclib seo á dtaispeáint: Taispeáin gach ceist
  • Réitithe
  • Cartlannaithe

Pop-up message: "this page is asking you to confirm that you want to leave - data you have entered may not be saved"

It happens often: I am typing into a text input form on a website, and the pop-up (see attachment) appears for no apparent reason. In other words, I did not deliberately … (tuilleadh eolais)

It happens often: I am typing into a text input form on a website, and the pop-up (see attachment) appears for no apparent reason. In other words, I did not deliberately try to abandon my text entries, but for some reason the browser believes I have. Perhaps this is down to the overuse of shortcuts and touchpad "gestures" in my Macbook? I don't know why it happens, but it does. My question only concerns what happens AFTER the pop-up appears.

The pop-up has two buttons: "Stay on page", and the DEFAULT "Leave Page".

I have lost hours of work (text entry) because the DEFAULT is to "Leave Page". Again, this may be "physically" due to the twitchy Apple products I use, but it could be avoided if the DEFAULT were set to "Stay on page".

That is my first question: How do I change the DEFAULT to "Stay on page"?

I am told that this pop-up is the product of JavaScript running in my browser. That's all well and good, but it's not clear to me whose script this is.

My second question: What is the SOURCE of the JavaScript producing the pop-up; i.e. is this sourced by Mozilla, or is it sourced by the website creators?

Asked by tmp003 1 bhliain ó shin

Answered by jscher2000 - Support Volunteer 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Glitchy/distorted text occasionally displays on websites

Recently (~2 days ago) I would be scrolling down a website and the text would glitch out into black/white/colorful squares. Now it happens randomly and I don't know what … (tuilleadh eolais)

Recently (~2 days ago) I would be scrolling down a website and the text would glitch out into black/white/colorful squares. Now it happens randomly and I don't know what causes it. The glitch would follow as I scroll, and I could refresh the page or highlight portions of the text to get rid of the distortion. I have tried quitting out of Firefox, booting it in safe mode, and uninstall-reinstalling it. None of that has helped. Attached are screenshots of the glitch. It seems to be getting more frequent (?)

I did some system scans/diagnostics to check that it wasn't a hardware issue, and there's no problem on microsoft edge or other applications like discord/steam, so it seems to be a Firefox issue.

Asked by swang8868 1 bhliain ó shin

Answered by FredMcD 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Printing Problems with Firefox

I have a new HP printer and I am using Firefox from a Windows 10 PC. I am plagued with Paper Mismatch errors when printing emails from Firefox. After a lot of trouble sho… (tuilleadh eolais)

I have a new HP printer and I am using Firefox from a Windows 10 PC. I am plagued with Paper Mismatch errors when printing emails from Firefox. After a lot of trouble shooting, I have found that this problem seems to be confined to Firefox, as it does not happen when using other browsers, e.g. MS Edge. I have tried resetting all Firefox printer settings and the problem still happens when opening Firefox in Safe Mode.

The print job stops with the error message Paper Size Mismatch after the 1st page, and printing will not continue or even move on to the next job until the error is cancelled from the printer's control panel. This means I have to be working next to the printer and cannot print remotely.

In the printing dialogue box under Printing Preferences, the paper size shows Letter, whereas I am using A4 in the printer, and this is the mismatch causing the problem. I can change the paper size in Printing Preferences from Letter to A4, but I have to do this for every job seperately as the paper size setting always reverts to Letter. This is totally impracticable.

Regretably, I will have to stop using Firefox unless there is a solution. Can anyone help me to change the paper size setting to always default to A4, please? Thanks in anticipation.

Asked by CSH 1 bhliain ó shin

Answered by jscher2000 - Support Volunteer 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Opening attachments in Gmail

I'm using Gmail in Firefox 80.0.1. When there is a Word or .pdf attachment on a gmail message, clicking on the attachment opens the dialogue box attached below. Despite… (tuilleadh eolais)

I'm using Gmail in Firefox 80.0.1. When there is a Word or .pdf attachment on a gmail message, clicking on the attachment opens the dialogue box attached below. Despite checking the box, "Do this automatically for files like this from now on," the box continue to pop up with the next attachment on another email. Is there a way to make it "automatic?"

Asked by rsuchyta1 1 bhliain ó shin

Answered by jscher2000 - Support Volunteer 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

shortcut for close other/right tabs

Hi, I have updated to the latest version and I found out that the close other/right tabs with right click on the tab has been folded,so I need wait for it to show then I`… (tuilleadh eolais)

Hi, I have updated to the latest version and I found out that the close other/right tabs with right click on the tab has been folded,so I need wait for it to show then I`m able to click close other/right tabs which is inconvenient for me. Is there any way to config the shortcut keys, like ctrl+shift+T will recovery the last tab. Thank you!

Asked by hellowd 1 bhliain ó shin

Answered by cor-el 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

"Plugins will be installed shortly" but never actually install (Widevine + H264)

Hi, Problem as described in the title. I've read some similar questions and answers, but nothing ever helped. I already tried the following steps (none of them helped): -… (tuilleadh eolais)

Hi,

Problem as described in the title. I've read some similar questions and answers, but nothing ever helped.

I already tried the following steps (none of them helped): - Checking for updates - Toggling DRM on/off - Uninstall Firefox completely (delete profiles, too and so on) - Changing some DRM or Plugin related config in about:config like media.peerconnection.video.h264 (and of course reverting it after that) - Looking for XHR requests when toggling DRM on/off or visting a site with DRM content. I couldn't figure out what I'm actually looking for, though... - Switching off Firewall/Antivirus or the TLS filtering (Eset) for a moment - Looking for suspicious requests in some router protocols or dashboards or whatever

Thanks in advance!

Asked by Volatilize 1 bhliain ó shin

Answered by bvandyk 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

No Little Images on Google Images

All of a sudden, starting a few days ago, when Google Images showed the results of a search, it no longer displayed little pictures with them. Here are some additional f… (tuilleadh eolais)

All of a sudden, starting a few days ago, when Google Images showed the results of a search, it no longer displayed little pictures with them.

Here are some additional facts:

(1) The missing pictures are still there; you just can't see them. By that, I mean that if you use the mouse to hover over where the picture really is, the cursor changes its form to let you know that it is now over something clickable. And, indeed, if you click there, the program opens a window with the image in question in it.

(2) As far as I can tell, this is happening only with Google Images. For example, YouTube is still correctly displaying the little images for its suggested videos.

(3) I first encountered this behavior on my XP machine, so I thought it might be an XP-related problem. But then I went to my newer machine and discovered that exactly the same thing was happening under Windows 10.

(4) Then I thought it might be a Google Images problem. But then I went to Google Images using other browsers, on both my old machine and my new one, and Google Images worked perfectly normally with those two browsers.

(5) So that meant that it must be some sort of Firefox problem. I waited for it to be fixed by Mozilla, but it wasn't. Then I searched both the Web and the Mozilla "knowledge base" to see what other people were saying about this problem. There wasn't a word about it in either place.

(6) Therefore, I can only conclude that it is a My House problem. But even that doesn't seem to me to make any sense. Here's why:

  • (a) My two computers are running totally different versions of Firefox -- 52.9.0 (32-bit) "ESR" on the old machine [Mozilla won't let anybody running XP have a more recent version], and 80.0.1 (64-bit) on the new one.
  • (b) The machines cannot talk to each other. (They are not networked.)
  • (c) One might guess that some update arrived at both machines and that, regardless of operating systems, that update doesn't handle Google Images properly. But here are three problems with that theory:
    • (i) The Firefox application on the old machine receives no updates any more. The folks at Mozilla have been clear about that. (And it's confirmed by looking at the creation and modification dates on the files in its directory.)
    • (ii) On the new machine, Firefox tells me when it has an update that it wants to install. It had not done so shortly before this new behavior arose.
    • (iii) If the latest, updated version of Firefox 80.0.1 (the version on my new machine) suddenly cannot handle Google Images if the program is being run under Windows 10, I wouldn't be the only person who had been hit by this problem: there would be some comments about it on the Web or in the "knowledge base"

I am totally flummoxed. I've tried clearing the cache, turning off popup-blocking, opening Firefox in its Safe Mode, etc. Nothing helps.

edited for formatting -Andrew

Asked by icarp1 1 bhliain ó shin

Answered by jscher2000 - Support Volunteer 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

100% Disk and 4GB ram usage with one page open?

Hi guys, and thanks for your support, ahead of time. I have googled everything I can to figure this out and have minimized the memory several times in the settings. Yet… (tuilleadh eolais)

Hi guys, and thanks for your support, ahead of time.

I have googled everything I can to figure this out and have minimized the memory several times in the settings. Yet, time and time again... especially with Facebook open as the page, I get 100% Disk usage and 4GB ram.

How in the world does one page utilize this much resource? How do I fix it?

Asked by kturis.nav 1 bhliain ó shin

Answered by cor-el 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Google search

I have designated that opening a new tab opens Google. I would like the cursor to be in the search box on the page not in the address box. I'm sure this is new behavior… (tuilleadh eolais)

I have designated that opening a new tab opens Google. I would like the cursor to be in the search box on the page not in the address box. I'm sure this is new behavior for Firefox. It's annoying to start typing and then realize i'm in the address box typing in the middle of the address. How can I change it?

Asked by meonly 1 bhliain ó shin

Answered by cor-el 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Major Lag switching between windows on Ubuntu (New issue that appeared after updating to FF 80)

Firefox has been severely lagging--specifically when switching between windows. For example, I could have one window running nice and fast, but then when I switch to anot… (tuilleadh eolais)

Firefox has been severely lagging--specifically when switching between windows. For example, I could have one window running nice and fast, but then when I switch to another Firefox window, it is unresponsive for up to 10 seconds. That means no opening tabs, no scrolling, no loading pages, until it becomes responsive again. And this happens just about every time I switch from one Firefox window to another. It's a big problem because multiple windows are an inherent part of my workflow, so I can't wait 10 seconds every time I have to do something in another window.

Here's a very important piece of information: The problem does not happen in Safe Mode. However, Safe Mode is the only way to fix it. I've tried disabling hardware acceleration, disabling all extensions, refreshing FF (creating a new profile), reinstalling it, and the problem always comes back whenever I'm not in safe mode.

I've spent a lot of time on my own trying to solve this, with no luck. Of course, I'd be happy to post any troubleshooting information you may need to help me. Thank you!

Asked by ben.t21 1 bhliain ó shin

Answered by ben.t21 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Can't clear old site data

A web site I used was updated but Firefox stillshows the old information. I went to the web site in MS edge and it shows the new data. I have cleared the cache and cookie… (tuilleadh eolais)

A web site I used was updated but Firefox stillshows the old information. I went to the web site in MS edge and it shows the new data. I have cleared the cache and cookies multiple times and even resarted the computer but still show the old site inforamation.

Asked by Paul Gritt 1 bhliain ó shin

Answered by cor-el 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Spell check sometimes not working or is very delayed

Spell check has long been a problem for me. It sometimes works, but most of the time it is not working, or is delayed by several minutes. The option to do spell checkin… (tuilleadh eolais)

Spell check has long been a problem for me. It sometimes works, but most of the time it is not working, or is delayed by several minutes. The option to do spell checking is on. And the fact that it sometimes works indicates that the dictionary is present. This problems has been present for several releases. I am currently on 80.0.1

I know that before computers were common, a typist really strove to be accurate. But now you go for speed, and not accuracy at all. So, my messages tend to have a lot of errors. I cringe when I think of how many messages I typed before I realized that spell check was only occasionally working.

My work-around is to type what I need into my word processor, and then copy/paste into the web site where I want the text.

Asked by jdunfee12 1 bhliain ó shin

Answered by jdunfee12 1 bhliain ó shin

  • Cartlannaithe

Images not showing on website social media plugin - except in safe mode - help?

We are using a social media plugin to display the last 4 facebook posts on our own site Kallen Web Design site and on many other websites we have created. The plugin is … (tuilleadh eolais)

We are using a social media plugin to display the last 4 facebook posts on our own site Kallen Web Design site and on many other websites we have created. The plugin is https://www.powr.io/plugins/social-feed/. Until Firefox 80.0 came out, it always displayed fine. Now with version 80.0.0 and 80.0.1, the posts display but the images do not display.

When I start firefox in safe mode, the images display. In regular mode, with all add-in's disabled, and enhanced protection turned off, and facebook container turned off, they still do not display. I'm stumped. Can anyone figure out what is going on?

Asked by firefox964 1 bhliain ó shin

Last reply by firefox964 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Search bar behavior doesn't respect browser.search.openintab when clicked

What I want to do Open new tab when searching from search bar What I tried Go to about:config, set browser.search.openintab to true Version Firefox 80.0.1 (64bit) on W… (tuilleadh eolais)

What I want to do

Open new tab when searching from search bar

What I tried

Go to about:config, set browser.search.openintab to true

Version

Firefox 80.0.1 (64bit) on Windows 10

Steps to reproduce

  1. In about:config set browser.search.openintab to true.
  2. Open https://mozilla.org/ (Any non-search engine page will do.)
  3. Enter search query in the search bar
  4. Click the arrow in the search bar

Expected behavior

Open a new tab, searching with the query.

Actual behavior

Opens the search result page on the current tab.

Asked by naokiri 1 bhliain ó shin

Answered by jscher2000 - Support Volunteer 1 bhliain ó shin

  • Faoi Ghlas
  • Cartlannaithe

google search hijacked by yahoo search

has anyone figured out how to fix the yahoo search engine hijacking google search engine? yes, i've worked with an antivirus pkg as well as a screen share; yes i've run s… (tuilleadh eolais)

has anyone figured out how to fix the yahoo search engine hijacking google search engine? yes, i've worked with an antivirus pkg as well as a screen share; yes i've run scans; yes my search engine is set to 'google.' the other search engine options have not been hijacked, only google. my add-ons and extensions were apparently completely taken away by the AV guy during the screen share. i have nowhere to turn. help!!!

Asked by maureen s 1 bhliain ó shin

Last reply by philipp 1 bhliain ó shin

  • Cartlannaithe

Firefox not working at my electric company webite.

FF 80.0.1 (64) ADP Privacy Badger This is the first time that I noticed I am no longer using the 32 bit version. Have the terrible kinks been worked on/fixed? The strang… (tuilleadh eolais)

FF 80.0.1 (64) ADP Privacy Badger

This is the first time that I noticed I am no longer using the 32 bit version. Have the terrible kinks been worked on/fixed?

The strangest thing. Could not login to pay my bill at electric company. NO visible place to login. Went to site using IE and although slow, I could login and pay. Disabled ABP and PB.

What’s up?

Thank you.

Asked by CiaoBella1 1 bhliain ó shin

Last reply by FredMcD 1 bhliain ó shin

  • Cartlannaithe

I need to move the FF profile from a laptop to another but FF's been unresponsive for almost a week

I need to transfer my FF profile from a Sony to Lenovo. The hardest challenge should be moving from a Win 7 to a Win 10, but I'm not really worried about that. The huge p… (tuilleadh eolais)

I need to transfer my FF profile from a Sony to Lenovo. The hardest challenge should be moving from a Win 7 to a Win 10, but I'm not really worried about that. The huge problem is that for almost a week FF stopped pushing web notifications of any sort of any of the platforms I've authorized. Important (?) note: randomly a couple days ago the notifications started working for no reason, I wasn't doing anything in specific, just working. I took screenshots to see if the debugging - runtime: about:debugging#/runtime/this-firefox#serviceworkers and saw changes here and there but nothing that could shed light as to why this happened. Example: if the notifications working were all running or stopped but saying fetching or not fetching.. there weren't coincidences that IO could find anyway. I shut down the laptop, the next day the notifications were gone again and have been gone ever since. I think yesterday or the day before I downloaded FF again and ran it, but I don't think that did anything. I didn't uninstall it, I wasn't sure if doing so could worsen the problem in such a way I wasn't gonna be able to open FF at all. I know nothing about computers, any suggestion would be appreciated. I don't dare to move nor transfer anything to the new laptop afraid to keep having the same problem or worse in there too, not to mention I'm not familiar with it so I might have an ever harder time finding a work-around that could make something that doesn't work, work. My doubt is: whatever it is that is causing this defect, if I transfer this profile to the new laptop, will it continue to happen in there as well? Is it possible it's something wrong within the profile itself and if so what can I do to transfer all this data to the new laptop? I really need his profile. Is there anything I can do to know where this problem is coming from? Am I causing the problem unwillingly, but most importantly, will this keep happening in the Lenovo? Is there any way to troubleshoot this specific issue to make sure wtv it is, won't be transferred within the profile to the new laptop so it won't fail in there as well? Please let me know if you need more information, any tips would be appreciated

Asked by intr0uble 1 bhliain ó shin

Last reply by intr0uble 1 bhliain ó shin