Ceisteanna leis an gclib seo á dtaispeáint: Taispeáin gach ceist
  • Réitithe

Add-on development - ajaxStop

Hi, I developed a simple Add-on, based on jQuery. Unfortzunately, it seems "ajaxStop()" does consistently not work as expected (at all). Any tips on what to consider to g… (tuilleadh eolais)

Hi, I developed a simple Add-on, based on jQuery. Unfortzunately, it seems "ajaxStop()" does consistently not work as expected (at all). Any tips on what to consider to get ajaxStop to succesfully trigger my registered eventhandlers? Thanks

PS off topic: the "developer" area of Mozilla is quite painful to handle and reach. I'm always pushed/forwarded back over here. Also the sophisticated 2way-auth seems a bit overkill for posting on a forum .

Asked by chRIS 4 lá ó shin

Answered by FredMcD 4 lá ó shin

Firefox caching shopping cart incorrectly

Hi, I am having an issue with a website I am developing, which I am only seeing in Firefox. To reproduce please try the following: 1. Go to https://mymummyteacher.com/sto… (tuilleadh eolais)

Hi,

I am having an issue with a website I am developing, which I am only seeing in Firefox. To reproduce please try the following:

1. Go to https://mymummyteacher.com/store and add a product to the cart. 2. Close the tab / browser 3. Go back to https://mymummyteacher.com/store and add a product to the cart. The single product that has been just added is shown, however the Subtotal and Total are showing as if the previously added product is still in there too.

If I do a hard reload (hold down shift), all the other products then appear. So I think this is an issue with caching. I am not seeing it on other browsers. Is this a bug, or is there something I can do to stop it happening?

Thanks

Asked by mike475 1 seachtain ó shin

Last reply by FredMcD 1 seachtain ó shin

Plugins & Profile directory

I have tried on windows and on linux, and the same thing happens for both. I don't get the plugins i should have. I want to try and enable java, but its not even appearin… (tuilleadh eolais)

I have tried on windows and on linux, and the same thing happens for both. I don't get the plugins i should have. I want to try and enable java, but its not even appearing in the first place. My profile directory is all messed up as well. I don't have a pluginreg.dat, my extensions.sqlite is an extensions.json. I have been reading all the forums but they mention stuff about the files in the profile, but I don't have those files.

Asked by caedenperelliharris 1 seachtain ó shin

Last reply by FredMcD 1 seachtain ó shin

Use Default Login for Websites where Multiple Logins are Saved

Not sure if this is an option somewhere and I'm just missing it, but if not it sure needs to be. As an IT manager for my company I use employee logins constantly in the s… (tuilleadh eolais)

Not sure if this is an option somewhere and I'm just missing it, but if not it sure needs to be. As an IT manager for my company I use employee logins constantly in the same websites, but I use my own login the most.

Is there a way to set a default login to auto-fill for specific websites? IE SalesForce - I have all my user's logins saved on my machine but I login as myself the most and my name starts with Z, so no matter what it will never be the first/default login.

Thoughts?

Asked by zgadson1 2 sheachtain ó shin

problems with profiles switching system

hi every one i need to install multiple firefox apps and i have installed 80 numbers of it in my pc in different folders and some of bokmarks and saved logins in these di… (tuilleadh eolais)

hi every one i need to install multiple firefox apps and i have installed 80 numbers of it in my pc in different folders and some of bokmarks and saved logins in these different installations should be same so mostly i go to "%APPDATA%\Mozilla\Firefox\Profiles\" and copy details of one of them who was setted up before and paste it into files of other installations so when i open others every thing was setted up i have done it when i was expanding number of my mozillas from 20 to 80 and every thing worked fine but right now i was trying to expand the number from 80 to 160 and every thing was fine. i ahve installed 80 more and copy/pasted files from the app data of an old one to new ones and opened few of them and all was good but after rebooting my system every time i try to open a fire fox a small window opens with the name of "firefox - choose user profile" and there are bunch of options as default default-release1/ default-release67 most of these files are new installed apps and just some of them are old ones my first problem with it is that even when i chose one of numbers who is linked with a old firefox its not opening as its apps (i have pinned all of them with different icons to the task bar so i know they are opened as new profiles not as the old app itself) my second problem is that i cant access other profiles who are missing and i cant bypass this little menu so is there any one to help me?? i will be doomed if i want to uninstall all of them and reinstall and relogin all sites in each 80 apps i just wnat to bypass all these mini windows and open the normal mozillas like before p.s: im using version 89.0.1 of mozilla as most of them but some of them are 89.0 and some are 88.0 PLS help if u know any way to make it done.

Asked by boland32141 2 sheachtain ó shin

Need some dev help with Okta

Hi all, I am the backend developer for a website that our company hosts. I want to have Firefox be fully supported in our site but we are having an issue when we try to r… (tuilleadh eolais)

Hi all, I am the backend developer for a website that our company hosts. I want to have Firefox be fully supported in our site but we are having an issue when we try to redirect from our home page to our SSO okta page.

The error in the console is that it can't find the route to our login endpoint. When I looked into it a bit further I saw that we were getting a 504 gateway timeout while trying to run that section of code.

I know the route exists and works because we have no problems when using Chrome based browsers, and Firefox loads just fine while in private mode.

Any help is appreciated. I will furnish code snippets if needed. I'm just not quite sure how to proceed with figuring out what's going on.

The site is https and we have CORS enabled for it in our Okta server

Any help is appreciated. Please let me know if I haven't provided enough information.

Thanks, Brian O

Asked by brihno 1 mhí ó shin

  • Réitithe

php based web site no longer displays correctly in Firefox but is OK in other browsers

I have a home website that was written using php well over 10 years ago. Except for family updates, it has changed little and displayed correctly using firefox and other… (tuilleadh eolais)

I have a home website that was written using php well over 10 years ago. Except for family updates, it has changed little and displayed correctly using firefox and other browsers. Firefox is my preferred browser. A couple of months ago, it stopped displaying correctly in firefox but continues to display correctly w/o issues in Edge, and other browsers.

I note it displays in a basic form in firefox, links to other pages and content are shown and operable, but not displayed (correctly) as it does in Edge and others. I am on the latest version of Win Pro 10.

I posted the problem the end of August and received a number of suggestions. I went through the steps suggested (using troubleshoot amongst other suggestions) and none of the suggestions resolved the issue. My suspicion is that something in a relatively recent update of firefox has issues with my php based code. I do not use a "web tool" but write the source myself. I started writing websites with html decades ago and got the bug to use php years back.

If anyone has the interest (or curiosity) to look at the website in firefox and edge and my source code and see if they see the issue I would be glad provide the link to my website.

Asked by kenw4 2 mhí ó shin

Answered by jscher2000 2 mhí ó shin

plugin do firefox quebra a segurança configurada do pdf, permitindo a impressão

Tenho uma rede com mais de 500 computadores, publico documentos em pdf com bloqueamento de impressão na intranet, o firefox tem o plugin de pdf nativo e esse plugin quebr… (tuilleadh eolais)

Tenho uma rede com mais de 500 computadores, publico documentos em pdf com bloqueamento de impressão na intranet, o firefox tem o plugin de pdf nativo e esse plugin quebra a segurança configurada do pdf, que no caso foi bloqueada a impressão e no firefox qualquer usuário consegue imprimir. Gostaria de saber como faço para desabilitar o plugin nativo pdf do firefox para todos os usuarios e que não consigam mais ter acesso em mudar a configuração, igual como fazemos com as configurações de proxy, onde fica desabilidado para o usuário a alteração

Asked by claudia.pereira 2 mhí ó shin

Last reply by cor-el 2 mhí ó shin

Log In Problem

I am running a sports blog and want to appear on every single browser, but the problem is that the Firefox browser creates some log inissues when I want to go to the back… (tuilleadh eolais)

I am running a sports blog and want to appear on every single browser, but the problem is that the Firefox browser creates some log inissues when I want to go to the backend of my this is my site website. Please anyone out there can help me?

Asked by khanumarpk80 2 mhí ó shin

Last reply by Seburo 2 mhí ó shin

My cache is making firefox not load pages

I am having an issue every 5 minutes where firefox will not load any pages it essential makes me stuck on the page. I have to than clear my cache for it to work again onl… (tuilleadh eolais)

I am having an issue every 5 minutes where firefox will not load any pages it essential makes me stuck on the page. I have to than clear my cache for it to work again only to have the issue again a couple of minutes later. I have refreshed firefox 4 different times, uninstalled 3 times to no but nothing seems to work.

Asked by yusoff95 2 mhí ó shin

Last reply by cor-el 2 mhí ó shin

Firefox 92 causes cross domain authentication errors

I currently run several environments for Dynamics 365 products. Our clients can choose to use our authentication (ADFS 4.0) or we set up a SSO option for them (normally … (tuilleadh eolais)

I currently run several environments for Dynamics 365 products. Our clients can choose to use our authentication (ADFS 4.0) or we set up a SSO option for them (normally also ADFS of some flavor). The piece that is similar between both is that the domain they authenticate to would not be the same as the application they are necessarily using. For example my clients have a mixture of on premise and cloud deployments but if they are SSO only pull their tokens from one domain.

Anyways the real TLDR as I can determine is as follows:

Has anyone seen a problem with firefox 92 stripping out headers? My scenario is I have an AD FS server that I use for single sign on with a domain name that is different from the application that it federated with. When I attempt to login using Firefox, the traffic flows as: 1. Hit the app url and get 302 redirected to the IDP 2. enter credentials at the IDP and get redirected to the app url 3. the app has an internal and external claims URL, so the internal claims url 302 redirects me to the external url 4. FF brings up the external url, but does NOT pass the MSISAuth and MSISAuth1 cookies from the IDP 5. The app thinks I've not authenticated, so it 302 redirects me back to the IDP 6. The IDP sees the MSISAuth and MSISAuth1 cookies, so it knows it authenticated me and it 302 redirects me back to the app wash, rinse, repeat for 5 times until AD FS realizes that I've done this 5 times, then it throws an error at me to stop the loop. This was working fine in FF 91 and it currently works in Chrome and Edge. The expected flow is almost the same, except that the app get's the cookies presented to it from AD FS. I was thinking this was something to do with Enhanced Tracking Protection. When I selected Custom and unchecked all the options (I think this disables ETP) I still get the cookies stripped from the header. I re-enabled ETP with standard protections and manually added the URLs using the steps outlined at https://bugzilla.mozilla.org/show_bug.cgi?id=1432644#c27. Is this a bug where FF doesn't honor the settings to disable ETP in V92? The reason I was thinking that ETP was to blame is the IDP has a domain of IDP.example and the app has the URL's of internalclaim.app and externalclaim.app.

I feel like I am missing something obviously here but I can't find it. If I create a CRM deployment using the same domain as our ADFS servers it works fine. If I use what our public designation is, it fails. SSO obviously fails. It only started after upgrading to 92 and that is consistent amount all of our clients. I have tried to go through every advance config that was touched with the 92 upgrade and nothing there seems to help. We compared our UAS to a friend of ours who is not having issues since the 92 release and they look the same. If this was a system 92 problem I would expect the internet to be exploding by now but it is not. It makes me think there is something I am missing in our fundamental set up but for the life of me I can't identify a missing update, compatibility issue, known issue blah blah blah. Edge, Chrome, Safari they all still work fine. It is just the Firefox 92 update that all of a sudden killed our authentication.

Asked by christopher.butler.02 2 mhí ó shin

Password Manager

As a developer, I am trying to disable the Password Manager feature in my webapplication across browsers. When I typed some value in input type password mentioned mdn doc… (tuilleadh eolais)

As a developer, I am trying to disable the Password Manager feature in my webapplication across browsers. When I typed some value in input type password mentioned mdn docs and navigsted away it doesnot trigger Save Password. But it is triggering anywhere else like online ide's and all.

I would like to know how it is disabled in MDN docs.

Asked by suraj.panayanchery 3 mhí ó shin

Last reply by cor-el 3 mhí ó shin

How do i noninteractively install firefox on windows?

I need a way to install firefox from command prompt entirely automatically, so that i can include it in a batch script i'm making. I've googled around, but all the tutori… (tuilleadh eolais)

I need a way to install firefox from command prompt entirely automatically, so that i can include it in a batch script i'm making. I've googled around, but all the tutorials are either for Linux or require you to download the file with another browser.

Asked by valkyrie_pilot 3 mhí ó shin

Last reply by cor-el 3 mhí ó shin

  • Réitithe

Website will not allow Firefox to display the page if another site has embedded it

I have a new business website http://affordable-tutors.com/about-our-tutors and I tried to put in my video https://youtu.be/EQxd_cowXPg but it gives me the following erro… (tuilleadh eolais)

I have a new business website http://affordable-tutors.com/about-our-tutors and I tried to put in my video https://youtu.be/EQxd_cowXPg

but it gives me the following error. Website will not allow Firefox to display the page if another site has embedded it

What can I do?

Yes, I own all the rights for that video.

Asked by Markis 3 mhí ó shin

Answered by Markis 3 mhí ó shin

Can someone add my keyboard addon to the list of keyboardss/dictionaries?

Hi, I have just created a keyboard for Firefox, the Bislama Dictionary for Firefox. I was wondering if someone could add it to the list of dictionaries. The local name fo… (tuilleadh eolais)

Hi, I have just created a keyboard for Firefox, the Bislama Dictionary for Firefox. I was wondering if someone could add it to the list of dictionaries. The local name for Bislama is just Bislama. Thanks.

Asked by oliver.palmer5 3 mhí ó shin

Last reply by cor-el 3 mhí ó shin

How to add a exception for SSL certificate error

I am developing my web application locally under the url https://local.focuscura.com:5555. When I am trying to access the url I get a "Secure connection failed - SEC_ERRO… (tuilleadh eolais)

I am developing my web application locally under the url https://local.focuscura.com:5555. When I am trying to access the url I get a "Secure connection failed - SEC_ERROR_INADEQUATE_KEY_USAGE" error which is normal as the SSL certificate is not a valid one. But I would expect to have a "Add exception" button as I can see on Chrome and Edge for the same url. I tried settings the config parameter "network.stricttransportsecurity.preloadlist" to false and delete the SiteSecurityServiceState.txt as found in https://support.mozilla.org/bm/questions/1206414. But it does not work. I still cannot access that url and no "Add Exception" button is shown. I have FF 91 installed on Win 10.

Asked by adrian_shadow 3 mhí ó shin

Last reply by adrian_shadow 3 mhí ó shin

Rendering Glitches in Firefox/Firefox Developer Edition

The First Image is of the URL bar. If you look closely, some of the parts are chipped. The Second Image is of a Button. It's chipped in all sides. The Third Image is a… (tuilleadh eolais)

  1. The First Image is of the URL bar. If you look closely, some of the parts are chipped.
  2. The Second Image is of a Button. It's chipped in all sides.
  3. The Third Image is a string of dots and hyphens that I've selected with my cursor. It's weirdly torn in the middle.

The Issue is on both Firefox Developer Edition and the normal Firefox. Both are the latest versions. Both are installed on my OS.

I'm on Parrot OS 4.11. I've tried changing the window compositor which is Metacity(Marco) but that doesn't solve the issue. Kernel is 5.10.0-6parrot1-amd64. I'm running on integrated graphics. No third-party graphics driver.

I have Ubuntu installed too and the problem isn't there in Ubuntu. So It's in Parrot. I heavily use Firefox for Web Surfing and Development.

All of them are fresh installs from the official website.

Asked by modifieddead24 4 mhí ó shin

Last reply by FredMcD 4 mhí ó shin

Need help in checking the dom node position for different screen resoultions

Hi, We are working on an Open Source Chrome extension: Digital Assistant Client I am recording the domnode by converting into json by domJson and saving into server. We c… (tuilleadh eolais)

Hi,

We are working on an Open Source Chrome extension: Digital Assistant Client

I am recording the domnode by converting into json by domJson and saving into server. We can find the same recordednode by comparing the json attributes and matching to the original node on the page. We have one problem here when we search for the nodes sometimes we get similar nodes via json which has same property names. In that case we are trying to match the node position that we have recorded. When we try to match the node position in different screen resolutions, it gives us the wrong node. How do we solve this. My code is as given below

// calculate distance between selected node and matching node getDistance: function (node1, node2) {

  const x = node1.x - node2.x;
  const y = node1.y - node2.y;
  const dist = Math.abs(Math.sqrt(Math.pow(x, 2) + Math.pow(y, 2)));
  return dist;

},

Asked by yureshwar 4 mhí ó shin

Last reply by FredMcD 4 mhí ó shin

DEAR SIRS, PLEASE HELP How to remove brower hijacked by 'a.horsered.com' on my blog:https://rightwaystechnologies.blogspot.com/

DEAR SIRS, PLEASE HELP How to remove Brower hijacked by 'a.horsered.com' on my blog:https://rightwaystechnologies.blogspot.com/ THANKS RICHARD rightwayspro@gmail.com … (tuilleadh eolais)

DEAR SIRS, PLEASE HELP How to remove Brower hijacked by 'a.horsered.com' on my blog:https://rightwaystechnologies.blogspot.com/

THANKS

RICHARD rightwayspro@gmail.com

Asked by Richard 5 mhí ó shin

Last reply by FredMcD 5 mhí ó shin