Ceisteanna leis an gclib seo á dtaispeáint: Taispeáin gach ceist
  • Réitithe
  • Cartlannaithe

Secure Connection Failed on Firefox 98 (SEC_ERROR_LIBRARY_FAILURE)

Greetings. I can't open most sites I usually visit (even google.com) via my Firefox 98.0a1. This happens since today. All error codes are SEC_ERROR_LIBRARY_FAILURE. Tried… (tuilleadh eolais)

Greetings. I can't open most sites I usually visit (even google.com) via my Firefox 98.0a1. This happens since today. All error codes are SEC_ERROR_LIBRARY_FAILURE.

Tried to:

  • Disable DNS-over-HTTPS.
  • Disable HTTP/3.
  • Disable proxy (never had it enabled anyway).
  • Disable sending info to Firefox developers.
  • Change settings of DNS-over-HTTPS.
  • Restart the browser (after each action).

Nothing helps me... But I still can visit some websites, but most common resources are not working for me. Please help me because I can't use Microsoft Edge without getting mentally ill. :/

Asked by Николай 7 mí ó shin

Answered by Николай 7 mí ó shin

  • Réitithe
  • Cartlannaithe

Video lagging

Hello, I have issues with Firefox developer version for couple months now, when I play videos, like youtube, or other sites they constantly lag. They play for like 1min a… (tuilleadh eolais)

Hello, I have issues with Firefox developer version for couple months now, when I play videos, like youtube, or other sites they constantly lag. They play for like 1min and lag, continue for another 2min then lag etc etc. (even short videos on twitter lag). It was not like that before and I don't have this problem in other browsers. Does anyone know what can be the problem here? Thanks

Asked by nicaya 10 mí ó shin

Answered by Bithiah 10 mí ó shin

  • Réitithe
  • Cartlannaithe

Stop downloading PDFs and making URLs hard to find

Firefox Developer Edition 85.0b4, macOS 10.15 If I Google for a PDF and click a link, I get the Firefox download dialog. If I select "Open with Firefox [Developer Editio… (tuilleadh eolais)

Firefox Developer Edition 85.0b4, macOS 10.15

If I Google for a PDF and click a link, I get the Firefox download dialog. If I select "Open with Firefox [Developer Edition]", the following things happen:

  • The PDF is downloaded to ~/Downloads
  • The PDF is opened in a new tab, with that new tab's location bar holding a file:///... URL to the downloaded PDF

What I would instead like to happen is:

  • The PDF is downloaded to some temporary directory where I won't have to worry about deleting it manually
  • In whatever tab the PDF is displayed in, the location bar contains the URL where the PDF was (temporarily!) downloaded from

How can I achieve this?

Not having the URL where a PDF was opened from is very annoying when, for example, I open a bunch of PDF search results to read and review, and I later want to share links to some of those PDFs. Best I can do to find their URLs to give to others is then to try and remember which tab corresponds to which search result, or do mine the downloads tab.

Contrast this with Chrome: I click a Google result for a PDF and the PDF just opens in the current tab with the URL to the PDF in the location bar. No dialogs, no PDF files hanging around in my home directory, and I can just copy the URL to the PDF the same way I'd copy the URL to any web page.

Thank you!

Asked by Dale 1 bhliain ó shin

Answered by Dale 1 bhliain ó shin

  • Cartlannaithe

Dark Theme

Dark Mode used to work beautifully in Firefox. Today it stopped working. I can choose Dark Mode in the settings page, and the settings page itself then uses Dark Mode. Bu… (tuilleadh eolais)

Dark Mode used to work beautifully in Firefox. Today it stopped working. I can choose Dark Mode in the settings page, and the settings page itself then uses Dark Mode. But Dark Mode does not work in any of the other pages, only the settings page. I think it must be a flaw in an update that was installed automatically today. (September 7, 2021)

Is there a way to uninstall this update and go back to the previous version. Dark Mode used to work beautifully and Firefox was my favorite browser. Can someone help? Thanks.

Asked by cmrus777 11 mí ó shin

Last reply by thegrubernator 11 mí ó shin

  • Cartlannaithe

Copy/Paste

Why can a stupid failing script on a web-page, or even intentionally so programmed script disable the copy (and sometimes paste) functionality? How can this be disabled/f… (tuilleadh eolais)

Why can a stupid failing script on a web-page, or even intentionally so programmed script disable the copy (and sometimes paste) functionality?

How can this be disabled/fixed?

One highlights a text (any text) on some web sites, Edit menu allows Copy, context menu allows Copy, one hits Copy, nothing happens. It's not even a page where someone wanted to "copy protect" some information.

Copy and Paste should work just as advertised since those were invented, how hard can it be to get that right? Even stupid Notepad never fails at it. And no, I don't care what the idiot who programmed a page though would be/should be best for me, I want Copy to be copy, Paste to be paste. This used to work in "original" Firefoxes even when page developers wanted to make it not work.

And yes, while on a given page Copy fails miserably, at the same time in other pages it works.

Asked by Pók 1 bhliain ó shin

Last reply by jscher2000 - Support Volunteer 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Google search page functions broken.

When I go to google.com and do a search the results page has the "tools" button but it does not work. The "people also ask" categories are also broken (they will not expa… (tuilleadh eolais)

When I go to google.com and do a search the results page has the "tools" button but it does not work. The "people also ask" categories are also broken (they will not expand), and, if I click the "images" filter button to view images associated with my search it either shows no images (or only a few images) and a bunch of blank boxes. I have found that if I hold the shift key and click the reload button everything is back and working properly until the next time I do a google.com search, then it is back to the same odd behavior. So, my assumption here is that either a cookie or some site data is corrupting the results page for my search. Running Firefox 92.0 (64-bit) on a Windows 7 Dell machine and everything was working fine until about two months ago. Also, Chrome does not show the same behavior. BTW. I have also done everything I have found that was recommended to fix Firefox issues with Google search. Run Firefox in private mode, run without plugins, changed themes, created new profile, I even completely uninstalled Firefox and did a clean install all with the same results. Any help is appreciated. It is almost got me ready to move back to Chrome.

Asked by b.j.p.5252 11 mí ó shin

Answered by dveditz 11 mí ó shin

  • Réitithe
  • Cartlannaithe

Firefox 86 crashes in Debian Buster x86_64

After updating to Firefox 86 it always crashes at launch: ExceptionHandler::GenerateDump cloned child 14439 ExceptionHandler::SendContinueSignalToChild sent continue sign… (tuilleadh eolais)

After updating to Firefox 86 it always crashes at launch:

ExceptionHandler::GenerateDump cloned child 14439 ExceptionHandler::SendContinueSignalToChild sent continue signal to child ExceptionHandler::WaitForContinueSignal waiting for continue signal...

And Crash Report dialog appears. This is the "Details" dialog content:

AdapterDeviceID: 0x0126 AdapterDriverVendor: mesa/i965 AdapterDriverVersion: 18.3.6.0 AdapterVendorID: 0x8086 AvailablePageFile: 0 AvailablePhysicalMemory: 127062016 AvailableSwapMemory: 4183494656 AvailableVirtualMemory: 2200952832 BuildID: 20210222142601 CrashTime: 1614250267 DesktopEnvironment: unknown EMCheckCompatibility: true FramePoisonBase: 9223372036600930304 FramePoisonSize: 4096 InstallTime: 1614249624 IsWayland: 0 IsWaylandDRM: 0 MozCrashReason: OOB Notes: Debian GNU/Linux 10 (buster)FP(D00-L1000-W00000000-T000) WR? WR- OMTP? OMTP- ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384} ProductName: Firefox ReleaseChannel: release SafeMode: 1 SecondsSinceLastCrash: 641 StartupCrash: 1 StartupTime: 1614250265 ThreadIdNameMapping: 14784:"IPC I/O Parent",14785:"Timer",14786:"Netlink Monitor",14787:"Socket Thread",14788:"Permission",14793:"JS Watchdog",14794:"JS Helper",14795:"JS Helper",14796:"JS Helper",14797:"JS Helper",14799:"Cache2 I/O",14800:"Cookie",14802:"DOM Worker",14803:"IPDL Background",14807:"BackgroundThreadPool #2",14808:"QuotaManager IO",14809:"IndexedDB #1",14811:"StreamTrans #5",14815:"StreamTrans #9",14817:"StreamTrans #11",14819:"StreamTrans #13",14821:"StreamTrans #15",14822:"Worker Launcher",14823:"SoftwareVsyncThread",14824:"Compositor", Throttleable: 1 TotalPageFile: 8249114624 TotalPhysicalMemory: 4046426112 UptimeTS: 1.8864044 Vendor: Mozilla Version: 86.0

Safe mode also crashes. Headless mode is the only way I found to make it not to crash.


Thanks in advance!!

Asked by ociu 1 bhliain ó shin

Answered by ociu 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Can't access apple websites which require a login

Whenever I try to access websites from apple which require a AppleID login like "icloud.com", "appstoreconnect.apple.com" or "developer.apple.com", the websites will be e… (tuilleadh eolais)

Whenever I try to access websites from apple which require a AppleID login like "icloud.com", "appstoreconnect.apple.com" or "developer.apple.com", the websites will be eternally stuck at the loading spinning animation. Here is stacktrace I found in the console: Uncaught TypeError: can't access property "startTime", d[(d.length - 1)] is undefined

   l https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:23
   _ https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:23
   Rt https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:405
   <anonymous> https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:405
   l https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:1
   <anonymous> https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:391
   l https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:1
   t https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:1
   r https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:1
   <anonymous> https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:391

app.js:23:7064

   l https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:23
   _ https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:23
   Rt https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:405
   <anonym> https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:405
   l https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:1
   <anonym> https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:391
   l https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:1
   t https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:1
   r https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:1
   <anonym> https://appleid.cdn-apple.com/appleauth/static/jsj/N143482311/widget/auth/app.js:391

Asked by Butzlabben 1 bhliain ó shin

Answered by Butzlabben 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Logins and passwords not imported in Version 81

To start off, I've never used the sync feature. Not that I think it won't work, I just haven't trusted the cloud enough yet. That being said, I know my logins and pass… (tuilleadh eolais)

To start off, I've never used the sync feature. Not that I think it won't work, I just haven't trusted the cloud enough yet. That being said, I know my logins and passwords are stored in the "profile" in the appdata of mozilla firefox, on this local computer. To my knowledge, this information is stored in the "logins.json" file located in my default profile. Up until now, I have had no issues retrieving the information I need. However, after this morning, when Version 81 was installed, I visited a website where I needed a particular login. I normally have Firefox automatically populate this information, on this particular site. However, since that did not happen this time, I checked my "logins and passwords" page, only to find "No logins found" on the sidebar, and "No synced logins found" in the main space, with instructions on how to sync from other devices or import from other browsers. Since I have not had a login before (for Firefox), I created an account to see if I could import the information from a previous version. However, only other browsers were listed, and I can't sync from another device, as the information is stored on this machine. Creating an account has also allowed me to post here...

I have opened the logins.json file with notepad, and the logins-backup.json file, and both are full of information. Of course it's not plain text, but the information is there. I can also open these files with Firefox, however, it doesn't recognize the file as the "logins and passwords" file, it just displays the encrypted information in a different (html?) format.

Any advice on how I can import these 55+ logins and passwords without re-creating or changing each one of them? Thanks.

Asked by c.kurt 1 bhliain ó shin

Answered by cor-el 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

ESNI Config missing

I am using Developer Edition, 85.0b3 (64-bit) Windows (en-US). Up and until last version, 84.0x, I was able to access the network.security.esni.enabled setting, but now … (tuilleadh eolais)

I am using Developer Edition, 85.0b3 (64-bit) Windows (en-US). Up and until last version, 84.0x, I was able to access the network.security.esni.enabled setting, but now it's missing from about:config I have tried all three versions of 85.0 ( b1 b2 b3 ... so far ), and none of them have this setting. Manually adding the key has no effect.

I have also checked the [notes for 85.0beta] ,but couldn't find any note with regards to this change.

Is this a bug, or has this feature been removed, or moved to a different config page?

Asked by Gliesefire 1 bhliain ó shin

Answered by TyDraniu 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Remove icons from bookmarks toolbar?

I've got a new computer I am setting up from scratch, and though I have set FF to sync settings, I'm still having to customize a lot. My bookmarks toolbar is crowded aga… (tuilleadh eolais)

I've got a new computer I am setting up from scratch, and though I have set FF to sync settings, I'm still having to customize a lot. My bookmarks toolbar is crowded again with icons and I'd like those to go away. I don't mind other icons staying around on the tabs--that does help me navigate faster. I had this set up before, but lost the setting when I refreshed Firefox.

Asked by Foxfree99 10 mí ó shin

Answered by jscher2000 - Support Volunteer 10 mí ó shin

  • Réitithe

YouTube Video GPU Decoding only works in Troubleshooting Mode

I recently upgraded graphics cards from an Nvidia GTX 1080 to an AMD 6900XT. Since then I noticed video stuttering on YouTube while playing 4k videos, especially noticeab… (tuilleadh eolais)

I recently upgraded graphics cards from an Nvidia GTX 1080 to an AMD 6900XT. Since then I noticed video stuttering on YouTube while playing 4k videos, especially noticeable at 4k/60FPS (example video ). Prior to the upgrade, I was not experiencing issues.

I monitored task manager as the video was playing to see CPU usage, which was sitting at 25% (4 core 8 thread CPU). GPU usage was fluctuating from 1-3%.

I tried resetting all the changed configuration options in about:config, removing all add-ons, "Refreshing" Firefox, and ultimately uninstalling and reinstalling. Nothing has worked so far except for "Troubleshooting mode" in about:support. In that mode, I experience no stuttering and GPU usage rises to 25-35% with the video playing, even before I reinstalled.

This most likely isn't a networking issue as the "Stats for nerds" option on the YouTube video shows I have 10-20s of buffer while the video is still stuttering.

I would like to find out what's different about Troubleshooting Mode that is not giving me the same problem while in "Normal Mode". Any advice?

Asked by Jacob 4 mhí ó shin

Answered by Jacob 4 mhí ó shin

  • Réitithe
  • Cartlannaithe

Disably overly insisting updates

When Firefox asks if I want to download an update and I agree, soon after that but not right away it stops working - on every new page it says "we need to restart to fini… (tuilleadh eolais)

When Firefox asks if I want to download an update and I agree, soon after that but not right away it stops working - on every new page it says "we need to restart to finish updating" <- this last bit is VERY annoying. Is there a way to keep FF working in such situation? I usually have 3 FF profiles running, about 10-20 tabs each and when it suddenly does this - I can restart them all but when it is suitable for me.

The only solution I can see so far is disabling updates via group policies (which is not well documented, where do i put this policies.json on fedora? need to google that).

Any other ways to keep updates and FF running until I decide when to restart? Thanks.

Asked by aikbox 1 bhliain ó shin

Answered by Scribe 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

About opening a tab in a new tab (not new window) conveniently

I found when pressing Alt+Enter in the address bar, the link will open in a new tab, which is nice. But if I press Alt+click a link in the page, the link does not open in… (tuilleadh eolais)

I found when pressing Alt+Enter in the address bar, the link will open in a new tab, which is nice. But if I press Alt+click a link in the page, the link does not open in a new tab (while Shift+click can open in a new window as expected). I'm not sure if it's a problem, but I hope Firefox can have this feature so that opening a link in a new tab can be more convenient.

Besides, in some browsers, drag a link to a nearby place will open in a new tab. However, in Firefox, this manner does not work, unless I drag a link to the tabs bar.

Asked by SolidBlock 1 bhliain ó shin

Answered by cor-el 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

New Home page logo - get rid of.

New logo at top of home page. What's the quickest/easiest way to get rid of it ? Rant: Why did someone think it was a good idea to put a massive logo at the top of the ho… (tuilleadh eolais)

New logo at top of home page. What's the quickest/easiest way to get rid of it ?

Rant: Why did someone think it was a good idea to put a massive logo at the top of the home page ? It serves no practical purpose and it forces link icons down so you now have to scroll "!!"!! There's always ******* one isn't there !!? - someone with a crap idea who thinks the world needs to see it. How many hrs worldwide is going to be wasted today by people like me trying to undo this crud ? This isn't the first time some ignorant little ******* has forced their crap on firefox end users.

Asked by Bob 1 bhliain ó shin

Answered by cor-el 1 bhliain ó shin