Firefox reports a secure connection without existing certificate

When i click on the lock icon in the address bar, nothing happens (I would expect to see the encryption and certificate, but no widget opens). When I right-click into the… (tuilleadh eolais)

When i click on the lock icon in the address bar, nothing happens (I would expect to see the encryption and certificate, but no widget opens). When I right-click into the page and select "View Page Info", "Security", "View Certificate", no certificate exists. Only generic info is shown (Servers+Authorities). Also an error is reported in the system log, confirming that no certificate exists: JavaScript error: chrome://browser/content/browser-siteIdentity.js, line 642: TypeError: issuerCert is undefined

Questions:

  • Why does Firefox show the lock icon while no certificate exists?
  • How does Firefox establish a secure connection without having a certificate? (From my understanding a certificate is needed for TLS to work.)

Version used: Firefox 78.12.0esr ('Mozilla/5.0 (X11; FreeBSD amd64; rv:78.0) Gecko/20100101 Firefox/78.0'), no add-ons or plugins.

Asked by pmc1 6 lá ó shin

Last reply by pmc1 9 n-uaire ó shin

I am unable to open a specific website in Firefox. It opens on other browsers and on other PCs.

I'm a D&D player and am attempting to open this website from my primary PC in Firefox. https://tools.goblinist.com/5enc It will open from the same PC in Chrome & … (tuilleadh eolais)

I'm a D&D player and am attempting to open this website from my primary PC in Firefox. https://tools.goblinist.com/5enc

It will open from the same PC in Chrome & Edge. It will open on my phone (safari). It will open on my other PC in Firefox, Chrome & Edge.

I tried everything I could find in this old thread: https://support.mozilla.org/en-US/questions/1290042 -I restarted firefox -I restarted PC -I clicked on forget this site -I have cleared cache, cookies & site data. -I have run the latest update from Malwarebytes (nothing found) -I deleted the cookies.sqlite file (no other cookies files found) -Running in Firefox safe mode made no difference -I have no extensions or addons installed -Theme is the default light theme

Any other suggestions?

Asked by patricksnorton 1 seachtain ó shin

Last reply by patricksnorton 5 lá ó shin

Firefox not loading Facebook images

Hello, I am at a loss to trying to fix a problem after extensive troubleshooting. When I am on Facebook for about five minutes, Firefox stops loading most images. This on… (tuilleadh eolais)

Hello, I am at a loss to trying to fix a problem after extensive troubleshooting. When I am on Facebook for about five minutes, Firefox stops loading most images. This only occurs with Firefox, not Safari or Chrome. And it only occurs with Facebook and Instagram, which is owned and run by Facebook. I have to restart Firefox to get images back and then after five minutes or so, it happens again every time. Can anyone help? This is driving me crazy!

Thank you

Asked by lkutchermusic 3 lá ó shin

Last reply by lkutchermusic 3 lá ó shin

Firefox (default) homepage

So i have noticed a sudden changed in firefox when i open it and been landed over to my homepage instead of where i left before which usually as "about:newtab" page and i… (tuilleadh eolais)

So i have noticed a sudden changed in firefox when i open it and been landed over to my homepage instead of where i left before which usually as "about:newtab" page and in setting there is only option to use firefox default or blank. i would rather preffered to have my home button set with my custom url, as well keeping the option to land on newtab page when ever i start my browser. which was intended as before but not since last update. now there is no option to set newtab page as also a custom url which can be any thing but forced to use the default layout by firefox. that proceed to open a homepage every time when i launch firefox.

Asked by iqbalusmani 5 lá ó shin

Last reply by iqbalusmani 5 lá ó shin

LINKS DO NOT WORK

WHEN I CLICK ON A LING IN A WEB SITE-IT DOES NOT OPEN. I HAVE TO RIGHT CLICK AND THEN CLICK OPEN IN A NEW WINDOW EVEY TIME. IF I CANT FIX, I WILL HAVE TO GO BACK TO USING… (tuilleadh eolais)

WHEN I CLICK ON A LING IN A WEB SITE-IT DOES NOT OPEN. I HAVE TO RIGHT CLICK AND THEN CLICK OPEN IN A NEW WINDOW EVEY TIME. IF I CANT FIX, I WILL HAVE TO GO BACK TO USING GOOGLE

Asked by rod18 1 seachtain ó shin

Last reply by rod18 6 lá ó shin

Tab crashing

Hi guys. I have Windows PC machine running for several years now. No new program updates or installs recently, no restarts. And then yesterday, suddenly Firefox started t… (tuilleadh eolais)

Hi guys. I have Windows PC machine running for several years now. No new program updates or installs recently, no restarts. And then yesterday, suddenly Firefox started to crash all youtube tabs. Not even videos itself, but also www.youtube.com crashes. Any idea how could i find out, what the hell is going on? Microsoft edge is working fine with youtube. I have tried troubleshoot mode, same. Windows 10.

What can possibly cause this? Thank you.

Asked by zarsss 4 lá ó shin

Last reply by zarsss 4 lá ó shin

Changes in Firefox from Version 86 to 90, 92

Apologies for asking this here, but I've done the Google and can't find an answer. Background: I keep 2-3 Firefox versions and profiles on my computer. The software is in… (tuilleadh eolais)

Apologies for asking this here, but I've done the Google and can't find an answer.

Background: I keep 2-3 Firefox versions and profiles on my computer. The software is in, for example, directories FFox82, FFox84, FFox86 The profiles are in, for example, directories Firefox82, Firefox84, Firefox86 (The software and profiles are on different drives.)

When I do an upgrade, I copy the newest software to a new directory and rename it (e.g., FFox92 - so now there are 4 sw directories) Then I copy the newest profile directory and give it a corresponding name (e.g., Firefox92 - so now there are 4 profile directories). I install the new version to its directory and thenlaunch with a -p option. Then I create a new profile and point it to the corresponding folder. Then I launch the new version with the -p option pointing to the new profile directory.

This has worked for decades.

But I just tried it with Firefox 90 and Firefox 92 and NO GO. It acts as if I've never used Firefox before. No apps, no toolbars, no bookmarks, nothing.

What is going on? Am I stuck on Firefox86 for the rest of the century?

And, please, don't tell me how wonderful these new versions are and I should simply accept the change. I have a virtual lifetime invested in the toolbars, extensions and bookmarks on my computer.

I simply want to know if there is a fix and, if so, what it is.

Asked by RemySecor 3 lá ó shin

Last reply by RemySecor 1 lá ó shin

Extension & History is get cleared after every restart

Hi Team, I am facing issue with my browser, whenever i restarted my PC (windows 10) my history from previous session,extension are get removed & browser start as a ne… (tuilleadh eolais)

Hi Team, I am facing issue with my browser, whenever i restarted my PC (windows 10) my history from previous session,extension are get removed & browser start as a newly installed one. I need to add extension again,login again in other accounts every single Time.

Asked by udaykboss 2 lá ó shin

Last reply by udaykboss 1 uair ó shin

Costco.com website will not display store locations or product reviews when using FireFox browser

Costco.com website will not display store locations or product reviews when using FireFox browser. Website works fine when using Chrome browser. This is a recent proble… (tuilleadh eolais)

Costco.com website will not display store locations or product reviews when using FireFox browser. Website works fine when using Chrome browser. This is a recent problem as all info on the Costco website displayed properly with Firefox not that long ago. As an example, when I enter my zip code to find the closest stores, nothing is displayed now when a map and store list used to come up. I've tried changing various settings, but no go. Any advice would be appreciated...

Asked by ME 1 seachtain ó shin

Last reply by ME 6 lá ó shin

Firefox shows blank white page for all tabs, unusable

Referencing these threads: 1281774 1307368 1317055 https://support.mozilla.org/en-US/questions/1333680 (I posted a reply to this thread, but I can't view it and the mod… (tuilleadh eolais)

Referencing these threads: 1281774 1307368 1317055 https://support.mozilla.org/en-US/questions/1333680 (I posted a reply to this thread, but I can't view it and the moderator has apparently closed it thinking this problem has gone away)

We can ascertain that NOTHING seems to help this condition. In fact these threads apply to me as Win 7 / 64 bit apply to me. This started probably about 1.5 years ago.

I too have this problem and yes, it is random. BUT once locked in with this condition, it may "get stuck" for another 5 attempts for the same link. BEST Example, I do surveys every Friday and Saturday night. I use my netscape (AOL) email account. At random, while clicking on the survey link the tab will come up blank and no matter what you do, you CANNOT get this tab to do ANYTHING. No reload, no clicking on a new bookmark, no clicking on home, or typing in the address bar and pressing enter on THAT particular tab. How often does it happen? Maybe 12 times a month (during survey time: maybe every other weekend).

One step further on this. My wife's account on the PC actually does this on a DAILY BASIS REPEATEDLY EVERY DAY when she opens FireFox. In her case, it can ONLY be solved by closing and reopening FireFox after waiting like...say...2 minutes after previously opening it? I have tried opening new tabs etc as mentioned above (including the old right clicky trick and using the "Open in new tab" function). Kinda silly when you have like 27 tabs of blankness. Considering it is her account on the Pc, ok, maybe the "refresh" function might work on her? BZZZT! Nope.

Current version. I can attest that a PC at my 2 jobs that both have Win 7 and at least one, if not both, have 64 bit versions and do NOT display this malady. Also, I did re-install FF about 2 years ago for some other problem. I just ran the troubleshooting more...no go. Per this lead, try https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0... and guess what? No such help . Anyone have have something to kill this bug?

Asked by metalman630 1 mhí ó shin

Last reply by metalman630 4 lá ó shin

Certain bookmarks don't open after 92.0 (64 bit) update

I'm using Firefox version 92.0 (64 bit) on an HP 350 G1 notebook running Windows 10. It seemed that it was after the 92.0 (64 bit) update that I cannot open bookmarks tha… (tuilleadh eolais)

I'm using Firefox version 92.0 (64 bit) on an HP 350 G1 notebook running Windows 10.

It seemed that it was after the 92.0 (64 bit) update that I cannot open bookmarks that are PDFs. The correct URL is present, but nothing loads, it's just a blank black page. I have tried turning off the add-ons and refreshing the page, closing and reopening Firefox with the add-ons manually turned off, restarting Firefox with the add-ons disabled, and restarting in safe mode. All of the attempts were performed without any positive results.

I can copy the URL on Firefox and paste it in Edge, and it opens the correct page. I installed Chrome against my better judgment and pasted the URL, and the correct page opens again. I can copy the URL in either Edge or Chrome, paste it on Firefox, and the same results occur as if I clicked on the link in my bookmarks on Firefox. I can click on the bookmark from either the home page or a page that's already opened, and nothing happens. The URL doesn't change on the existing page, and on the home page, "Search with DuckDuckGo or enter address" in the UL space does not change to the URL that I'm trying to open. Is there something I'm missing?

This is one of the URLs that I am trying to open if you want to try it yourself on Firefox: https://www.att.com/idpassets/images/support/wireless/Devices-Working-on-ATT-Network.pdf

I only ever use Edge when I'm having an issue with Firefox, (usually it's when I'm trying to log on to an account or something and I can't, then I realize that it may be one of my add-ons preventing it. I then disable them one by one until I'm able to achieve what I want.

I don't want to have to switch back and forth between Firefox and Edge just to view three PDFs, so if someone knows what could be the resolution to this, I would appreciate it greatly.

Asked by zx9r170 3 lá ó shin

Last reply by zx9r170 2 lá ó shin

N-th tab in firefox doesn't load

Hiya, I'm having a minor inconvenience with firefox 91.0.2 for a few months now. It's popped up a few months ago and hasn't resolved itself in between updates. I'm guilt… (tuilleadh eolais)

Hiya,


I'm having a minor inconvenience with firefox 91.0.2 for a few months now. It's popped up a few months ago and hasn't resolved itself in between updates.

I'm guilty of having many (well over 20) tabs open at the same time and around the 20th or 30th tab even, usually one of the (newly opened) tabs, simply never loads. If I open the same link in another tab, the link (any url) does load. See the screencap below.

This is on a windows 64 bit machine OS build: 19043.1165 (21H1) Windows Feature Experience Pack 120.2212.3530.0

I'm running Norton 360 Antivirus software.

Will try running in safe mode, to see if it still happens and confirm in a reply to this message.

Hoping you guys might have some suggestions.

BTW: https://support.mozilla.org/en-US/questions/1317506 is probably the same problem, unfortunately the thread has been archived. This one: https://support.mozilla.org/en-US/questions/1285104 also seems similar.

Asked by Mediationpraktijk De Witte Vlag 2 sheachtain ó shin

Last reply by Mediationpraktijk De Witte Vlag 1 lá ó shin

White Bar appears above all firefox windows when Firefox is maximized, need help getting rid of it.

I have a strange white bar that appears above the Firefox window at all times, but it's only visible on one of my other monitors, which is positioned above the monitor Fi… (tuilleadh eolais)

I have a strange white bar that appears above the Firefox window at all times, but it's only visible on one of my other monitors, which is positioned above the monitor Firefox is on. I've tried starting firefox with all my extensions and themes disabled, and all that did was make the bar black instead of white.

This lead me to believe it was the Title bar. However, that's currently disabled. When I enable the title bar, the white bar disappears, but then I'm left with the title bar (which I do not want).

Is there a way I can have the Title bar disabled and not have this bar appear?

Worth noting I'm using the Lepton UI mod (which doesn't seem to be responsible for this) and DisplayFusion (which I thought would have been responsible for this, however I cannot be sure). Running Win 10.

Asked by Shigbeard 1 lá ó shin

Last reply by Shigbeard 1 lá ó shin

Ubuntu Snap problem with Firejail

I read that Firefox will using the Snap version by default on Ubuntu 21.10 and beyond. Will the non-Snap version still be available in lets say Ubuntu 22.04 and beyond? T… (tuilleadh eolais)

I read that Firefox will using the Snap version by default on Ubuntu 21.10 and beyond. Will the non-Snap version still be available in lets say Ubuntu 22.04 and beyond? The reason I ask is because I use Firejail to sandbox Firefox and Firejail doesn't work with Snaps and yes I know that Snaps and Flatpacks both sandbox apps but I prefer Firejail because of the Private Home profile (nothing is saved in this profile settings, bookmarks, add-ons etc) its way more secure than the sandbox offered by a Snap.

Asked by Baldape 1 lá ó shin

Last reply by Baldape 14 uair ó shin

MY site not Working On Mozilla

Hey there! my site is over all good i'm open my site in mozilla but got Error by Mozilla blocked My site Here's site Url > [link hidden] Any Solution or please Gui… (tuilleadh eolais)

Hey there! my site is over all good i'm open my site in mozilla but got Error by Mozilla blocked My site Here's site Url > [link hidden] Any Solution or please Guide me

Asked by zs1558743 3 lá ó shin

Last reply by zs1558743 17 uair ó shin

Blacked out letters on Firefox Bookmarks Toolbar and Window tabs

Sometimes (not always!), the entries on my bookmarks toolbar appear with the lower case a's blacked out, and the leading edge of lower case e's as well. Nowhere else on t… (tuilleadh eolais)

Sometimes (not always!), the entries on my bookmarks toolbar appear with the lower case a's blacked out, and the leading edge of lower case e's as well. Nowhere else on the page does this happen. Anyone else ever seen this? Is there a fix? Thanks

Asked by dtowson 4 lá ó shin

Last reply by dtowson 3 lá ó shin

LINKS DO NOT WORK

LINKS IN THIS SITE DO NOT WORK. THE OWNERS HAVE TESTED IT WITH FIREFOX AND ALL OK WHAT IS WRONG WITH MY PC www.bidorbuy.co.za A SIMPLE NOT TECHNICAL ANSWER PLEASE. … (tuilleadh eolais)

LINKS IN THIS SITE DO NOT WORK. THE OWNERS HAVE TESTED IT WITH FIREFOX AND ALL OK WHAT IS WRONG WITH MY PC

www.bidorbuy.co.za

A SIMPLE NOT TECHNICAL ANSWER PLEASE.

Asked by rod18 3 lá ó shin

Last reply by rod18 3 lá ó shin

Some YouTube videos aren't in sync with the audio

I'm having a problem with a couple videos where the video and audio aren't in sync. For example, the video in the first screenshot is only 2:30, yet when I play it, it se… (tuilleadh eolais)

I'm having a problem with a couple videos where the video and audio aren't in sync. For example, the video in the first screenshot is only 2:30, yet when I play it, it seems to partially mimic the video in the second screenshot; it "extends" to 2:41, and it plays the video from the second video. However, it plays the audio from the first video and the progress bar still only goes to 2:30, yet the video keeps playing for another 11 seconds without any audio until the video from the second video ends. Seeking forward causes the different recommendations to pop up as if the video had ended normally.

I am using a MSI laptop on Windows 10. I have restarted my computer, cleared my cookies and cache, and updated Firefox to the latest version. This problem persists with all of my extensions disabled, and when logged in or out of YouTube (no matter the account) or in incognito mode. At first, I thought it had something to do with the video and/or channel, since the other video with the same problem was also uploaded by AmericanDadVEVO. When I tried watching the video in the first screenshot on Microsoft Edge (which I barely use and have no extensions on), however, it worked normally.

Any help would be appreciated! I really do not want to switch to another browser.

Asked by David_H23 2 sheachtain ó shin

Last reply by David_H23 2 lá ó shin

does firefox require 'warming up' ??

Every single time I load F/F (especially for the first time) it takes So long to start When its started and I click on (example) on a desktop shortcut it takes so long t… (tuilleadh eolais)

Every single time I load F/F (especially for the first time) it takes So long to start When its started and I click on (example) on a desktop shortcut it takes so long to load After about 5 mins of going slow (like warming up) it then starts to go normal speed. I have tried all suggestions on googles...still the same Start FF ...goes so slow, and gets faster as the minutes go by

Asked by malasacoffee@gmail.com 1 seachtain ó shin

Last reply by malasacoffee@gmail.com 6 lá ó shin