Ceisteanna leis an gclib seo á dtaispeáint: Taispeáin gach ceist

How do I dismiss a permission dialog?

Sometimes a box pops up on the screen that asks if I want to block or allow something. Sometimes I have no interest in doing either, and just want the damned dialog out o… (tuilleadh eolais)

Sometimes a box pops up on the screen that asks if I want to block or allow something. Sometimes I have no interest in doing either, and just want the damned dialog out of my face. The page seems to work otherwise, but the stupid browser keeps the dialog over top of things, and clicking outside of it, and hitting Esc, don't make it go away. I think those actions used to work, and I think there, sensibly, used to be a dismiss option, but that seems to be absent now. There's no sense to trying to force me to make a decision I don't want to make, and doesn't even need to be made, and I want this thing to cut it out.

Asked by Sterrence 3 lá ó shin

Last reply by cor-el 1 lá ó shin

The "Triage Manager" for Mozilla Refuses to assign anyone to a seven year old open problem

I need to go over the head of the Mozilla Triage manager who has left https://bugzilla.mozilla.org/show_bug.cgi?id=1406865 open without a resolution for **seven years**. … (tuilleadh eolais)

I need to go over the head of the Mozilla Triage manager who has left https://bugzilla.mozilla.org/show_bug.cgi?id=1406865 open without a resolution for **seven years**. How do I do that? This is a bug reported in Firefox 57 and **still** not fixed in Firefox 125. I cannot find any support category anywhere in the Mozilla website that covers appealing a decision by one of their employees. The last comment from this uncooperative indivisual is "But given we support it on macOS and Windows yeah, it seems not very objectionable." Who is this **clerk** to override the fact that a number of customers very much find this "objectionable". I cannot find anything on https://www.mozilla.org/en-US/contact/ that addresses this issue. I cannot find even a surface mail address for Mozilla. For example my complaint has nothing to do with any of the following:

   I’m having problems with using Firefox
   I want to donate to Mozilla
   I have questions about using Mozilla’s trademarks
   I’d like to report misuse of a Mozilla trademark
   I want to hold an event in a Mozilla space
   I want Mozilla to sponsor my event
   I’d like permission to use a Mozilla logo
   I’m interested in Pocket’s sponsored content on Firefox
   I’m a member of the Press and have a question for Mozilla

Yes I am having a problem with Firefox, but the clerk responsible has, through sitting on this issue for **seven years**, basically told the entire community that he doesn't give a reservoir.

In particular I feel this unacceptable behaviour should be brought to the attention of senior management, but there are no contacts for anybody in senior management.

Asked by jamescobban 4 lá ó shin

Last reply by James 2 lá ó shin

How do I change the default app Firefox uses to open downloaded files?

Currently, when I try and open downloaded .txt files and .log files (that is, when I click on them directly from the download pop-up that appears at the top-right of the … (tuilleadh eolais)

Currently, when I try and open downloaded .txt files and .log files (that is, when I click on them directly from the download pop-up that appears at the top-right of the browser), Firefox inexplicably opens Aegisub on my machine as the app to use. This is in contrast to when I open it directly from within my file browser, where it opens the Kate text editor, as suggested by the default app option in the permissions of the filetype.

How do I change the apps Firefox uses to open downloaded files? I've tried going into my settings and looking at applications, but .txt and .log don't appear, so I'm not quite sure what to do.

I'm on Kubuntu 22.04.3 LTS, using the Firefox deb package.

Asked by domojestic 4 lá ó shin

Last reply by jonzn4SUSE 3 lá ó shin

Firefox does not display background color in option tags

I am trying to use a <select> tag to display a color selector. So each <option> has a background color to match its displayed text: ```<select id="stroke… (tuilleadh eolais)

I am trying to use a <select> tag to display a color selector. So each <option> has a background color to match its displayed text:

```<select id="strokeColor" name="strokeColor" style="width: 10em;">

             <option value="black" style="background: #000000; text: #FFFFFF">
                     black
             </option>

<option value="aqua" style="background: #00FFFF">

                     aqua
             </option>

<option value="blue" style="background: #0000FF">

                     blue
             </option>

<option value="brown" style="background: #A52A2A">

                     brown
             </option>

<option value="gray" style="background: #808080">

                     gray
             </option>

<option value="green" style="background: #00FF00">

                     green
             </option>

<option value="magenta" style="background: #FF00FF">

                     magenta
             </option>

<option value="orange" style="background: #FFA500">

                     orange
             </option>

<option value="purple" style="background: #800080">

                     purple
             </option>

<option value="red" style="background: #FF0000">

                     red
             </option>

<option value="white" style="background: #FFFFFF">

                     white
             </option>

<option value="yellow" style="background: #FFFF00">

                     yellow
             </option>

<option value="#000000" selected="" style="background: #000000">

                     #000000
             </option>
         </select>```

On Chrome this displays as expected:

https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2024-04-18-22-02-25-eebbd5.png

But on Firefox the background colors are ignored:

https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2024-04-18-22-02-35-bd90ee.png

How can I get Firefox to display the background colors?

Asked by jamescobban 4 seachtaine ó shin

Last reply by jscher2000 - Support Volunteer 3 lá ó shin

YouTube gets very laggy after a while - best way to restore performance?

I always keep two Youtube tabs open at all times on my computer. After a while of running, however, the site starts to get increasingly laggy, in a way that simply reload… (tuilleadh eolais)

I always keep two Youtube tabs open at all times on my computer. After a while of running, however, the site starts to get increasingly laggy, in a way that simply reloading the tab does not fix. (I am aware that this is likely a result of one of the extensions I have installed that affects Youtube's behavior, specifically SponsorBlock and Return Youtube Dislike, but I am not willing to uninstall these.) I also know of a "force reload" - pressing ctrl + shift + R instead of just ctrl + R in order to clear the cache or something.

However, whenever Youtube starts getting really slow, I instead like to do something I call "crashing the tab" - I open my system monitor, look for the current most CPU-intensive "Isolated Web Co" process, and end it. This pops up an error message in Firefox that says "Gah - your tab just crashed!" and offering me the option to restore it. After restoring it from this window, the performance is back to normal.

My question is, is this beneficial, or is it functionally identical to a normal force-reload? Is the improvement I see between this method and force-reloading the page just placebo? And if not, is there a simpler way to do it without opening a second program?

Asked by alanwilson772 3 lá ó shin

Last reply by Skgh12 3 lá ó shin

Sound glitches in KDE after visit some sites in Firefox

Steps for reproduce: Turn ON PC Launch Audacious player Launch Firefox Visit to drupal.org And I have sound glitches like on radio tuning. From all software, … (tuilleadh eolais)

Steps for reproduce:

  • Turn ON PC
  • Launch Audacious player
  • Launch Firefox
  • Visit to drupal.org

And I have sound glitches like on radio tuning. From all software, that have sounds: players, browser, messengers. Glitches disappear after restart. I find only 2 sites, that make it: drupal.org and my local bank. With Chrome - no problems.

Without Audacious glitches can be to, but not in 100% of cases.

OS: KDE Neon Plasma 6

Asked by Alexandr Vasilenko 6 lá ó shin

Last reply by jonzn4SUSE 5 lá ó shin

I want to have an automated task that sorts the incoming mail to separate folders

I want to have an automated task that sorts the incoming mail to separate folders. I have done this easily in Outlook, but Firefox's Thunderbird is different and I haven'… (tuilleadh eolais)

I want to have an automated task that sorts the incoming mail to separate folders. I have done this easily in Outlook, but Firefox's Thunderbird is different and I haven't figured it out. Any help would be greatly appreciated.

George

Asked by George 6 lá ó shin

Last reply by jonzn4SUSE 6 lá ó shin

Availability for Ubuntu ARM64 via Orange Pi 5+

I know that there is a generic Linux iteration that can be downloaded, but it does not appear to allow for use on ARM64. Is there a way that I can download, install, and … (tuilleadh eolais)

I know that there is a generic Linux iteration that can be downloaded, but it does not appear to allow for use on ARM64. Is there a way that I can download, install, and access Firefox on my Orange Pi 5 Plus?

Asked by Caleb 1 seachtain ó shin

Last reply by jonzn4SUSE 6 lá ó shin

Firefox DoH fails on Linux Mint XFCE and Fedora Kinoite

Hello, By default, DoH fails on Max Protection in the latest OS versions listed above. The workaround I've discovered is using https://1.1.1.1/dns-query, but I would rath… (tuilleadh eolais)

Hello, By default, DoH fails on Max Protection in the latest OS versions listed above. The workaround I've discovered is using https://1.1.1.1/dns-query, but I would rather use the default settings.

Asked by coreywolfhart 1 seachtain ó shin

Last reply by jonzn4SUSE 1 seachtain ó shin

Browser crashes on opening certain filetypes (notably PDF)

Hi everyone, I'm running Firefox which I compiled with vaapi support because I was trying to use hardware acceleration for videos, so I think this bug may have something… (tuilleadh eolais)

Hi everyone,

I'm running Firefox which I compiled with vaapi support because I was trying to use hardware acceleration for videos, so I think this bug may have something to do with that. Every time I open a pdf file my browser instantly crashes. When I use troubleshoot mode I have no such issue. I then tried with a fresh all-default user profile with no add-ons, nothing, and still I crash when loading a PDF. Any pointers would be appreciated.

Asked by jethro.rosette 1 seachtain ó shin

Last reply by jonzn4SUSE 1 seachtain ó shin

Having more details of the inspected element in the tool-tip

Hi there, thanks for your attention I'm a web developer and new to using firefox. I was using chrome for years and now just because firefox on android let's us install ad… (tuilleadh eolais)

Hi there, thanks for your attention I'm a web developer and new to using firefox. I was using chrome for years and now just because firefox on android let's us install add-on like it's desktop version I'm switching to firefox. as a developer I need to learn about the features firefox offers to developers or ask for any features that are missing right now, so my current issue is about the pictures I will attach. I want to have more information about the element that I'm inspecting right in the tool-tip over it for example it's active font-family or things like that. It took me sometime to figure out how to find the active font of the target element thanks to This post. but in chrome it's showed in the tool-tip.

Asked by Matty 1 seachtain ó shin

Last reply by cor-el 1 seachtain ó shin

launching firefox in safemode just attaches to existing process instead of launching a new instance in safemode

Howdy, Workflow: I have a firefox instance already running. I want to launch a new firefox in safe-mode to test something without disrupting my existing firefox. Probl… (tuilleadh eolais)

Howdy,

Workflow: I have a firefox instance already running. I want to launch a new firefox in safe-mode to test something without disrupting my existing firefox.

Problem: I try to launch a new firefox in safe mode using `firefox --safe-mode`, but firefox just opens a new window NOT in safe mode.

I think it may because firefox in safe-mode requires launching launching from a new instance rather than attaching to existing instance.

`firefox --help` shows a flag I can use:

--new-instance Open new instance, not a new window in running instance. --safe-mode Disables extensions and themes for this session.

So I run `firefox --safe-mode --new-instance`

now I get error popup with message:

"Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile."

Now I think what is the point of the flag "new-instance" if Firefox doesn't support multiple instances?

Regardless, how can I launch firefox in safe-mode without disrupting my existing firefox instance and without relying on creating a profile just for this?

Asked by furkansahin824 1 seachtain ó shin

Last reply by cor-el 1 seachtain ó shin

Firefox takes ~5 minutes to startup (even the Profile Manager and in every possible modes)

Firefox takes about 5 minutes to load every it launches, before working smoothly like it should. This problem occured first time yesterday morning, and I have no idea wha… (tuilleadh eolais)

Firefox takes about 5 minutes to load every it launches, before working smoothly like it should. This problem occured first time yesterday morning, and I have no idea what could have caused it.

It happens :

  • when I launch firefox normally (whatever the profile)
  • when I launch it from the terminal (it provides no output at all)
  • when I tell it to launch the Profile Manager (5 minutes to see the Profile Manager appear, then 5 more minutes to launch firefox using the selected profile)

It does not happen :

  • when I click "New Window" inside an existing firefox process
  • when I call `firefox --help` from the terminal

Here's what I've tried :

  • First, I've seen pretty much every article from Mozilla Support, Reddit or SuperUser (writing this question is kind of my last resort)
  • I've tried removing and then reinstalling Firefox from Flatpak, from the Fedora repos (using `sudo dnf install firefox`) and using the manual install via the archive (v125)
  • I've tried downgrading firefox (when using the package manager install) from v125 to v124
  • I've also tried the Firefox Developer Edition, same problem here
  • I've tried using the "Refresh Firefox" feature and restarting in Troubleshoot Mode (both are also affected by the slow startup, which makes them particularly painful to execute)
  • I've tried manually deleting the `~/.mozilla/` folder (= manually deleting my profiles)

When firefox launches, it does not freezes my OS and does not seem to use many system ressources : CPU usage is normal, RAM as well, and it does not seem to read many things from the disk as well (I've seen some threads where this was the issue).

And here is something interesting that I discovered :

  • loading (including refreshing) `about:profiles` is also slow and this time freezes firefox (OS reports it as not responding, I can't switch tabs and I can't see my mouse). Other about pages seem to work fine (although I did not try them all)

Thanks !

PS : Even if I think it has nothing to do with the issue, I prefer to mention it here : I was messing with virtual machines yesterday when the issue occured for the first time. My disk got full at some point and I don't know but it might have messed with firefox. At this stage, I had not deleted any files that could relate somehow to Firefox, that's why I doubt it would have caused anything harmful to Firefox. (instead, I mounted an empty partition from my disk to get some space)

Asked by Martin Heywang 2 sheachtain ó shin

Last reply by jonzn4SUSE 1 seachtain ó shin

OneDrive workbook problem

So I have an Excel workbook in my onedrive from MS, It was working fine on my firefox browser in my Ubuntu OS, last week it started to delete my cell's information whenev… (tuilleadh eolais)

So I have an Excel workbook in my onedrive from MS, It was working fine on my firefox browser in my Ubuntu OS, last week it started to delete my cell's information whenever I pressed the enter, tab or arrow keys, I contacted the MS support and they get me to opened the same file on a chrome browser and worked fine... I still want to use my firefox browser but this problem is very annoying, please help me sort it out!!!

Asked by ricardocrbb 2 sheachtain ó shin

Last reply by jonzn4SUSE 1 seachtain ó shin

mouse lockup

Firefox Browser 125.0.3, Flatpak Every few minutes, the mouse locks up on Ubuntu 23.10 and it only happens with I have Firefox open. I have have no extension, and history… (tuilleadh eolais)

Firefox Browser 125.0.3, Flatpak Every few minutes, the mouse locks up on Ubuntu 23.10 and it only happens with I have Firefox open. I have have no extension, and history is turned off I have lived with this for months on multiple updates hoping for someone working on Firefox would figure out the issue and fix it.

This issue never happens to me on my windows PCs.

Any solutions? thanks Richard

Asked by Richard Hanson 1 seachtain ó shin

Last reply by jonzn4SUSE 1 seachtain ó shin

Encountered a NS_ERROR_DOM_MEDIA_FATAL_ERR in the MediaDecoderStateMachineBase.cpp process while accessing multiple pdf files.

Opened a directory of pdfs from the command line using ```firefox * &``` and went on with my work. Checked the terminal to see these error messages: ``` [Child 19416… (tuilleadh eolais)

Opened a directory of pdfs from the command line using ```firefox * &``` and went on with my work. Checked the terminal to see these error messages: ``` [Child 19416, MediaDecoderStateMachine #1] WARNING: Decoder=7f6e75431700 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005): file /builddir/build/BUILD/firefox-125.0.2/dom/media/MediaDecoderStateMachineBase.cpp:167 [Child 19416, MediaDecoderStateMachine #1] WARNING: Decoder=7f6e79a87a00 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005): file /builddir/build/BUILD/firefox-125.0.2/dom/media/MediaDecoderStateMachineBase.cpp:167 [Child 19416, MediaDecoderStateMachine #1] WARNING: Decoder=7f6e84e52400 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005): file /builddir/build/BUILD/firefox-125.0.2/dom/media/MediaDecoderStateMachineBase.cpp:167 ``` I tried recreating this error by restarting the entire process and repeating everything, but to no avail. I'll try to recreate the error a few more times, however if I don't post a message it means I was unsuccessful.

Details: Mozilla Firefox 125.0.2

CPU: Architecture: x86_64

 CPU op-mode(s):         32-bit, 64-bit
 Address sizes:          39 bits physical, 48 bits virtual
 Byte Order:             Little Endian

CPU(s): 8

 On-line CPU(s) list:    0-7

Vendor ID: GenuineIntel

 Model name:             Intel(R) Core(TM) i5-8350U CPU @ 1.70GHz
   CPU family:           6
   Model:                142
   Thread(s) per core:   2
   Core(s) per socket:   4
   Socket(s):            1
   Stepping:             10
   CPU(s) scaling MHz:   22%
   CPU max MHz:          3600.0000
   CPU min MHz:          400.0000
   BogoMIPS:             3799.90
   Flags:                fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
                          mca cmov pat pse36 clflush dts acpi mmx fxsr sse ss
                         e2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constan
                         t_tsc art arch_perfmon pebs bts rep_good nopl xtopol
                         ogy nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes6
                         4 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16
                          xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt ts
                         c_deadline_timer aes xsave avx f16c rdrand lahf_lm a
                         bm 3dnowprefetch cpuid_fault epb pti ssbd ibrs ibpb 
                         stibp tpr_shadow flexpriority ept vpid ept_ad fsgsba
                         se tsc_adjust sgx bmi1 avx2 smep bmi2 erms invpcid m
                         px rdseed adx smap clflushopt intel_pt xsaveopt xsav
                         ec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_no
                         tify hwp_act_window hwp_epp vnmi md_clear flush_l1d 
                         arch_capabilities

Virtualization features:

 Virtualization:         VT-x

Caches (sum of all):

 L1d:                    128 KiB (4 instances)
 L1i:                    128 KiB (4 instances)
 L2:                     1 MiB (4 instances)
 L3:                     6 MiB (1 instance)

NUMA:

 NUMA node(s):           1
 NUMA node0 CPU(s):      0-7

Vulnerabilities:

 Gather data sampling:   Mitigation; Microcode
 Itlb multihit:          KVM: Mitigation: VMX disabled
 L1tf:                   Mitigation; PTE Inversion; VMX conditional cache flu
                         shes, SMT vulnerable
 Mds:                    Mitigation; Clear CPU buffers; SMT vulnerable
 Meltdown:               Mitigation; PTI
 Mmio stale data:        Mitigation; Clear CPU buffers; SMT vulnerable
 Reg file data sampling: Not affected
 Retbleed:               Mitigation; IBRS
 Spec rstack overflow:   Not affected
 Spec store bypass:      Mitigation; Speculative Store Bypass disabled via pr
                         ctl
 Spectre v1:             Mitigation; usercopy/swapgs barriers and __user poin
                         ter sanitization
 Spectre v2:             Mitigation; IBRS; IBPB conditional; STIBP conditiona
                         l; RSB filling; PBRSB-eIBRS Not affected; BHI Not af
                         fected
 Srbds:                  Mitigation; Microcode
 Tsx async abort:        Mitigation; TSX disabled

Asked by mustafa.290101 1 seachtain ó shin

Last reply by cor-el 1 seachtain ó shin

Specific CSS rule in my userChrome.css doesn't work.

Hi thanks for clicking. I'm on Linux, Zorin OS, which is Ubuntu based if I'm not mistaken, very new to Linux. Anyway, I've made a userChrome.css and done some changes I… (tuilleadh eolais)

Hi thanks for clicking.

I'm on Linux, Zorin OS, which is Ubuntu based if I'm not mistaken, very new to Linux.

Anyway, I've made a userChrome.css and done some changes I like to Firefox. It has been working fine until I tried to change the tab bar's overflow shadows when there are more tabs than there is space in the bar.

The rest of the css edits I've made in userChrome.css works fine but this overflow shadow reference Firefox just doesn't grab. I can live edit with the Toolbox and then it works fine, but when opening Firefox as default this css definition is as if gone.

Image 1: after live edit with Toolbox Image 2: before live edit with Toolbox Image 3: my userChrome.css

What can I do to fix this?

Thanks / p

Asked by protocol 1 seachtain ó shin

Last reply by cor-el 1 seachtain ó shin

How to disable Firefox's search (Ctrl + F keyboard shortcut) to be used for the website's internal search?

In numerous cases i have found not to be beneficial when website's search function is activated on Ctrl+F keyboard shortcut and where is better to use regular Firefox on-… (tuilleadh eolais)

In numerous cases i have found not to be beneficial when website's search function is activated on Ctrl+F keyboard shortcut and where is better to use regular Firefox on-page search instead. I think that the good site has search button/area visible so i can use it when needed.

So please how to disable Firefox's search (Ctrl + F keyboard shortcut) to activate website's internal search? I want to always use regular Firefox on-page search that i now trigger by left Alt (to show the FF menu), click Edit menu, click Find in page.... (since Ctrl+F is occupied by website's internal search).

Asked by #367259 2 sheachtain ó shin

Last reply by zeroknight 2 sheachtain ó shin