Ceisteanna leis an gclib seo á dtaispeáint: Taispeáin gach ceist
  • Réitithe

policies.json WebsiteFilter does not block website properly

Suppose I have a "policies.json" file in the "distribution" subdirectory of my Firefox installation. And suppose "policies.json" file contains this: { "policies": { … (tuilleadh eolais)

Suppose I have a "policies.json" file in the "distribution" subdirectory of my Firefox installation.

And suppose "policies.json" file contains this:

{

 "policies": {
     "WebsiteFilter": {
         "Block": [
           "youtube.com",
           "www.youtube.com",
           "http://www.youtube.com",
           "https://www.youtube.com",
         ]
     }
 }

}


Now if I type "youtube.com" in the address bar, it shows "Your organisation has blocked access to this page or web site." It means firefox blocks "youtube.com" correctly. Meanwhile the url in the address bar is "https://www.youtube.com/."

But if I remove "https://www." from "https://www.youtube.com/" in the address bar (Not retype), I can actually visit "youtube.com." It means somehow the webfilter is not working properly.

This issue exists in ubuntu and macos with version 92.0(64-bit).

Does anyone have the same problem? Any help would be appreciated.

Asked by purple_sheep 3 mhí ó shin

Answered by jscher2000 3 mhí ó shin

  • Réitithe
  • Cartlannaithe

Firefox ESR master password prompt twice

With recent updates of Firefox ESR I'm seeing two master password prompts in FIPS mode when starting up Firefox. This article: https://support.mozilla.org/bm/questions/12… (tuilleadh eolais)

With recent updates of Firefox ESR I'm seeing two master password prompts in FIPS mode when starting up Firefox. This article: https://support.mozilla.org/bm/questions/1262314 does not solve my particular problem. The problem I'm seeing behaves exactly how this user describes, except for me it only happens in FIPS mode.

My OS is SUSE Linux Enterprise Server in FIPS mode. My Firefox version is 78.6 ESR with no addons installed.

Disabling FIPS mode fixes the problem but I cannot do that as it goes against company policy.

I have attached two screen shots showing the double master password prompt and after entering the password, the remaining prompt still showing.

Any help is greatly appreciated.

Thanks!

Charles Robertson

Asked by cgrobertson 12 mí ó shin

Answered by Mike Kaply 12 mí ó shin

  • Réitithe
  • Cartlannaithe

Firefox packaging and auto update

I am trying to package Firefox, with the browsers auto update disabled (updates are handled by the package manager, not the browser; having Firefox prompt at the user may… (tuilleadh eolais)

I am trying to package Firefox, with the browsers auto update disabled (updates are handled by the package manager, not the browser; having Firefox prompt at the user may cause confusion). However, I haven't been able to Firefox's nagging with recent (77+) versions.

I have tried writing a policies.json file seems to have no effect. In fact, Firefox didn't even look in system directories like /etc and /lib64/firefox. Is this an Enterprise Firefox feature? Is it even possible to share a single installation of Firefox between users (having their personal prefs in their home directories, ofcourse).

Thanks in advance!

Asked by Folkert 1 bhliain ó shin

Answered by Mike Kaply 1 bhliain ó shin

  • Réitithe
  • Cartlannaithe

Install extension locally via policies.json

Greetings I'm trying to deploy firefox in spanish using policies.json and this is the code im using: { "policies": { "Extensions": { "Install": ["/usr/lib64/fir… (tuilleadh eolais)

Greetings

I'm trying to deploy firefox in spanish using policies.json and this is the code im using:

{

 "policies": {
   "Extensions": {
     "Install": ["/usr/lib64/firefox/distribution/extensions/langpack-es-MX@firefox.mozilla.org.xpi"],
     "Uninstall": [],
     "Locked":  []
   }
 }

}

Whenever i launch firefox, the langpack is not installed, the "about:policies" page display the following error:

Download failed - ERROR_NETWORK_FAILURE - file:///usr/lib64/firefox/distribution/extensions/langpack-es-MX@firefox.mozilla.org.xpi

We always put the folder of the language pack in /firefox/browser/extensions/ but after upgrading to firefox 76 is not working, i can install manually the langpack but that's not an option. Is there is something wrong with my code?

Sorry for my broken english.

Asked by sephirod 1 bhliain ó shin

Answered by sephirod 1 bhliain ó shin