Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How to automatically open csv files in Excel on imac

  • 6 fhreagra
  • 2 leis an bhfadhb seo
  • 332 views
  • Freagra is déanaí ó GrandDuke

more options

I am migrating back from Google Chrome to firefox and would like to have the browser automatically open csv files to Excel on my mac desktop. The step to have them saved in the download folder and then go in an open it in Excel adds an unnecessary action. In the earlier versions of Firefox on my windows machine this worked as desired. Any help will be appreciated.

Réiteach roghnaithe

The Yahoo Finance server sends the file with the Content-Type: application/octet-stream header. This is a generic MIME type that doesn't describe the type of file. Therefore you will always see a download prompt, regardless of your download preferences.

To get around this issue, install the Force Content-Type add-on.

In the Add-ons Manager, Extensions category, click the Options button next to Force Content-Type. Create two rules as follows:

  • URL: (.csv)$ Old Content-Type: text/plain New Content-Type: text/csv
  • URL: (.csv)$ Old Content-Type: application/octet-stream New Content-Type: text/csv

You should then be able to select what you want to do with CSV files (i.e. open them directly rather than save), and check the "Do this automatically…" option.

You're welcome.

Read this answer in context 👍 1

All Replies (6)

more options

What is your default download action under Preferences → General?

Under Preferences → Applications, are CSV files set to open in Excel?

more options

Thank you for your response, but unfortunately neither solution solves my problem. When I open the Applications window, CSV is not listed as a content type so I am unable to direct which application opens it. This is one feature of Chrome that worked as desired. The download panel will allow saving the file, but doesn't allow an instruction as to how to pen the file type. Thanks again.

more options

Under Preferences → General, have you selected "Ask me where to save files"?

Despite the above, when you click a CSV link, it's automatically saved to your download folder without displaying a prompt?

Can you post an example of a publicly accessible CSV link that's giving you trouble? Alternatively, what happens when you click the following test link?

more options

Thank you again. 1) Under preferences>general, I can select "ask me where to save files' and direct the csv file to an excel subfolder fine, but that is multiple steps that I wish to avoid. 2) When the csv file is downloaded in FF, I then can go to the FF download arrow and double click which does open the file in Excel, but again multiple steps. 3) the file I frequently download is from yahoo finance, but is not publicly accessible, but you could create one yourself easily for testing purposes. 4) When I click the internic.net csv link, it brings up a web page of text of several hundred lines. I am going to test the csv download in Safari to see how they handle it.

Thank you.

more options

Réiteach Roghnaithe

The Yahoo Finance server sends the file with the Content-Type: application/octet-stream header. This is a generic MIME type that doesn't describe the type of file. Therefore you will always see a download prompt, regardless of your download preferences.

To get around this issue, install the Force Content-Type add-on.

In the Add-ons Manager, Extensions category, click the Options button next to Force Content-Type. Create two rules as follows:

  • URL: (.csv)$ Old Content-Type: text/plain New Content-Type: text/csv
  • URL: (.csv)$ Old Content-Type: application/octet-stream New Content-Type: text/csv

You should then be able to select what you want to do with CSV files (i.e. open them directly rather than save), and check the "Do this automatically…" option.

You're welcome.

more options

This solved my problem perfectly. Thanks again!