Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How do I make new tabs open as my home page, not the old Firefox start up page?

  • 35 freagra
  • 96 leis an bhfadhb seo
  • Freagra is déanaí ó yankeespride

more options

Under Tools > Options > General, my Firefox home page is set to: When I open a new tab, the page opens up to the old Firefox Start/Google home page. The address shows: In the middle of this screen reads, "You're not on the latest version of Firefox. Upgrade today to get the best of the Web!" I have the latest version of Firefox. Why aren't my tabs opening up as my initial home page opens up to: I was looking to add a screenshot of my home page and the tabs home page, but I don't see an option to do that.

Athraithe ag yankeespride ar

All Replies (20)

more options

You can open the about:config page via the location bar and search for prefs that refer to and reset related user set (bold) prefs via the right-click context menu to the default value.

Athraithe ag cor-el ar

more options

I'm not familiar with what you are asking me to check. I did type about:config in the white address bar, and it pulls up a huge list of "Preference Name." I did the search and it pulled up what you were asking me to look for ( I right clicked on it, and navigated to "Reset." Now it shows: Preference Name: browser.newtab.url Status: default Type: string Value: about:newtab So, how do I enable new tabs to open to or any website I choose? When I open a tab after these changes, it's a blank white page. Thank you in advance.

more options

The "" page is no longer maintained by Google and has a hard coded message that you use an outdated Firefox version, so you can disregard the update information on that page.

You can use another page as the home page like "about:home" or "".

  • Tools > Options > General > Startup: Home page

You can set the new tab page by setting the browser.newtab.url pref to the web page that you want to open if you click the button to open a new tab and you want a page other then the about:newtab page with the 3x3 tiles.

See this article about the New Tab page (about:newtab):

more options

Thank you for quickly responding. I looked at that link you provided, but I'm still having trouble setting a new tab to open up as the site of my choice, like my home page opens up to What are you referring to with the 3x3 tiles? I had sites pinned to the website awhile back, but they are gone now. I like that feature too, but I don't know what happened to the tiles. (there can be 9 pinned sites, right?)

more options

Open a new window or tab. In the address bar, type about:config. If a warning screen comes up, press the Be Careful button. This is where Firefox finds information it needs to run. At the top of the screen is a search bar. Enter browser.newtab.url and press enter. browser.newtab.url tells Firefox what to show when a new tab is opened. If you want, right click and select Modify. You can change the setting to;

about:home (Firefox default home page),
about:newtab (shows the sites most visited),
about:blank (a blank page),
or you can enter any web page you want.

The same instructions are used for the new window setting, listed as browser.startup.homepage.

more options

The about:newtab page has the 9 tiles where you can see 9 most recently visited web pages or you can pin a bookmark or history item (i.e. a link) for easy access.

Note that you can set the number of rows and columns via two prefs on the about:config page.

  • browser.newtabpage.columns (3)
  • browser.newtabpage.rows (3)

You can open the about:config page via the location bar and you can accept the warning and click "I'll be careful" to continue.

more options

Thank you, Fred. I was able to set my "New Tab" page to I tried to set it to about:newtab, but when I do that I see 9 blank white tiles. I'm still trying to figure out why my sites most visited don't appear in them.

more options

Thank you, Cor el. As I responded to Fred (which seems to show under your last response), I'm still having trouble being able to see my sites most visited. I will continue to read the article you linked for me, until I hear back from you. I'm just not good at these things...yet.

more options

Are there any URLs showing under the empty tiles or can you drag a bookmark or history item (URL) to one of the tiles?

more options

There are 9 blank white tiles, no URLs under the empty tiles. I can drag a bookmark or history item to the tile. But if these tiles are supposed to keep track of your most visited sites, why aren't they populating with those sites? I didn't think I had to drag a bookmark or history item; instead, the tiles would "learn" the favorite sites for me and I'd see them whenever I opened a new tab. I hope I didn't confuse you.

more options

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history) and that the history is enabled.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

You can also check on the about:cache page if the disk cache is enabled and working.
There should be three sections listed: Memory cache, Disk cache, and Offline cache

more options

I have never used private browsing. Under Tools > Options > Privacy > I already have "Use custom settings for history" checked. "Always use private browsing mode" was always deselected as well.

On the about:cache page, I see two sections: Memory cache, and Offline cache. Is the missing "Disk cache" causing the 9 white tiles to be blank all the time? I'm trying....bear with me here :)

more options

Yes. The thumbnails on the about:newtab page are generated from the cache.

You can check the browser.cache.disk.enable pref on the about:config page and reset this pref if it is user set (bold) via the right-click context menu to the default value.

more options

Looking at browser.cache.disk.enable pref on the about:config page, it is not bold, and the Status is Default. There are six other entries in this list, 5 of which are in bold. What's my next step? Hopefully after I get this figured out, you can explain how these settings were changed or not set to begin with.

The other six entries are:

browser.cache.disk.capacity (in bold) Status: user set browser.cache.disk.smart_size.enabled (in bold) Status: user set browser.cache.disk.smart_size.first_run (in bold) Status: user set browser.cache.disk.smart_size.use_old_max (in bold) Status: user set browser.cache.disk.smart_size_cached_value (in bold) Status: user set browser.cache.disk.max_entry_size (not bold) Status: Default

more options

If you are using "Clear history when Firefox closes" then make sure not to clear the cache as that will disable the disk cache.

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

more options

I unchecked the cache so it won't clear like you said, and then closed the browser and opened up a new one. I went to a few different sites, and then when I opened a new tab, all the tiles were still blank. Am I getting any closer?

more options

Do you at least still have the URLs listed under the tiles after closing and restarting Firefox?

If not then also make sure not o clear the browsing cache.

more options

I did unclear the browsing cache, I thought, the last time I replied to you. Look at my last reply, unless there's a different browsing cache to uncheck. There were never any URLs under the tiles before or after I closed Firefox and restarted. I'm really baffled at this point...very frustrating,

more options

Have you given up on me?:) j/k...I've followed what you said closely, and I see the white tiles when I open a new tab. There's got to be something simple I'm not doing. But this is the same problem I have on my other PC, after going through the steps that you've listed. I always prefer Firefox, but this is just strange.

more options

Are you using "Clear history when Firefox closes" in any way or did you try to disable this feature by removing the tick, so the Setting button in disabled (fainted) and not clickable?

Are there still no URLs under the tiles?

Does it work if you drag a History item on a tile?

You can toggle the History sidebar on/off via "View > Sidebar > History" or "Ctrl+H" (Command+H on Mac) to make this easier.

  1. 1
  2. 2