X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

ctl+C/ctl+V not working on FF 30 (Linux Debian SID, KDE)

Postáilte

Since an upgrade to Firefox 30 copy (ctl+v) is not working. The "Linux-Way" (marking with left mouse button, copy with middle button) works fine. Any solution available or is it a bug?

Many Thanks Anton

Since an upgrade to Firefox 30 copy (ctl+v) is not working. The "Linux-Way" (marking with left mouse button, copy with middle button) works fine. Any solution available or is it a bug? Many Thanks Anton

Réiteach roghnaithe

Note that there is not a single version of 30.0a2 as it is currently on the Aurora development channel and it usually gets checkins each day and therefore a update each of those days. This sometimes means a build one day may have issues that gets fixed in next day.

Read this answer in context 1

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 11.2 r202

Feidhmchlár

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 Iceweasel/30.0a2

Tuilleadh Eolais

user669794 59 réiteach 672 freagra

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes).

(If you're using an added theme, switch to the Default theme.)

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the Restart with Add-ons Disabled... menu item:
FirefoxSafeMode

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes). ''(If you're using an added theme, switch to the Default theme.)'' If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the '''Restart with Add-ons Disabled...''' menu item:<br> [[Image:FirefoxSafeMode|width=520]]<br><br> If Firefox is not running, you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you.

Úinéir na ceiste

Hello Yes, i know the Safe Mode and tried this first before i wrote the posting here. It doesn't solve the problem. I Had a look at about:config, but i found no solution. Many tnx Anton

Hello Yes, i know the Safe Mode and tried this first before i wrote the posting here. It doesn't solve the problem. I Had a look at about:config, but i found no solution. Many tnx Anton
John99 971 réiteach 13138 freagra

Hi Anton

You are not actually using a Mozilla Firefox you are using Debian's Iceweasel. I should be near enough identical to Firefox for practical purposes.

Copy and paste works ok for me in Ubuntu 12.04 Canonical Firefox 30.0a2 (2014-04-02)

  • Does this only happen on some sites ?
    • Are you able to use Ctrl+C on this site for instance.
    • Please give a couple of example of public sites where it does not work.

There is a possibility that changed prefs may be affecting this. Safe mode does not reset prefs. The Firefox reset may be used.

A slightly more advanced method would be better if you wish to try it. Temporarily rename the file prefs.js call it something like prefs.js.old1 That forces Firefox to recreate the file and in doing so resets all the prefs to default. To reverse the change the files names are changed over again. The changes need making whilst Firefox is closed. But finding your profile location is easiest before closing down Firefox.

The easy way. Read and follow these instructions. Note you may wish to bookmark the home webpages of any Firefox extensions before resetting because you will need to reinstall them


By the way what locale and language are you using ?
( Some locales may use different key combinations, although I would not expect Ctrl+C to be affected. )


You are probably more knowledgeable than me about debian and Iceweasel support but potentially useful sites include

Hi Anton You are not actually using a Mozilla Firefox you are using Debian's Iceweasel. I should be near enough identical to Firefox for practical purposes. Copy and paste works ok for me in Ubuntu 12.04 Canonical Firefox 30.0a2 (2014-04-02) *Does this only happen on some sites ? **Are you able to use Ctrl+C on this site for instance. ** Please give a couple of example of public sites where it does not work. There is a possibility that changed prefs may be affecting this. Safe mode does not reset prefs. The Firefox reset may be used. A slightly more advanced method would be better if you wish to try it. Temporarily rename the file ''prefs.js'' call it something like ''prefs.js.old1'' That forces Firefox to recreate the file and in doing so resets all the prefs to default. To reverse the change the files names are changed over again. The changes need making whilst Firefox is closed. But finding your profile location is easiest before closing down Firefox. * [[Reset Firefox preferences to troubleshoot and fix problems#w_solution-2-delete-firefox-preference-files]]''_solution-2-delete-firefox-preference-files'' The easy way. Read and follow these instructions. Note you may wish to bookmark the home webpages of any Firefox extensions before resetting because you will need to reinstall them * [[Reset Firefox – easily fix most problems]] -------- By the way what locale and language are you using ? <br /> ( Some locales may use different key combinations, although I would not expect Ctrl+C to be affected. ) ----- You are probably more knowledgeable than me about debian and Iceweasel support but potentially useful sites include * http://www.debian.org/support * http://www.linuxquestions.org * http://www.debianhelp.org/ * http://www.debianhelp.co.uk
cor-el
  • Top 10 Contributor
  • Moderator
17571 réiteach 158915 freagra

Freagra Cabhrach

Do other Ctrl shortcuts work?

Do Ctrl+Insert and Shift+Insert work?

  • Copy: Ctrl+C or Ctrl+Insert (Mac: Command + C)
  • Paste: Ctrl+V or Shift+Insert (Mac: Command + V)
  • Cut: Ctrl+X or Shift+Delete (Mac: Command + X)
Do other Ctrl shortcuts work? Do Ctrl+Insert and Shift+Insert work? *Copy: Ctrl+C or Ctrl+Insert (Mac: Command + C) *Paste: Ctrl+V or Shift+Insert (Mac: Command + V) *Cut: Ctrl+X or Shift+Delete (Mac: Command + X)

Úinéir na ceiste

Hello cor-el, John, Debapriyo Bhattacharya

Ctrl+Insert, Shift+Insert, Shift+Delete working perfect.

Many Thanks Anton

@John I have/had no problems with other progs,only with FF 30 (FF 29 worked fine) I use Linux since Redhat 4 and this is a very long time :-)

Hello cor-el, John, Debapriyo Bhattacharya Ctrl+Insert, Shift+Insert, Shift+Delete working perfect. Many Thanks Anton @John I have/had no problems with other progs,only with FF 30 (FF 29 worked fine) I use Linux since Redhat 4 and this is a very long time :-)

Athraithe ag Anton Steiner ar

James
  • Top 25 Contributor
  • Moderator
1601 réiteach 11324 freagra

Réiteach Roghnaithe

Note that there is not a single version of 30.0a2 as it is currently on the Aurora development channel and it usually gets checkins each day and therefore a update each of those days. This sometimes means a build one day may have issues that gets fixed in next day.

Note that there is not a single version of 30.0a2 as it is currently on the Aurora development channel and it usually gets checkins each day and therefore a update each of those days. This sometimes means a build one day may have issues that gets fixed in next day.