X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Automatically restore session on next start when "Save and Quit" is selected on quitting firefox

Postáilte

Hi all,

I'm submitting this question/report because I'm used to some specific behavior on Firefox that doesn't seem to exist anymore and I want to make it happen. As some pre-problem information I know that the showquitwarning setting hasn't been enabled by default for a while but that's always something I've enabled when first installing firefox. I also don't like the option to "Show my windows and tabs from last time", as sometimes I just want to close the tabs and not necessarily always save them.

So what's different now is that in the past I toggled showquitwarning to true and you'd be prompted to see if you want to save your tabs for next time. If you closed the browser using the red X or doing File->Exit your tabs would just pop up the next time you started Firefox. This is the behavior I want, but it's not the behavior I can get. Currently, there's a few things that happen depending on what else you have set (keep in mind all of this is with ShowQuitWarning set to true):

-As I hinted at before, if you set "General -> When Firefox Starts: Show my windows and tabs from last time", your tabs are always saved on quitting and pop up when you start up Firefox again, you get no choice in the matter (and you'll get the Confirm Close popup instead of an option to Save and Close)

Homepage set to Mozilla Firefox Start Page: -If you exit using the red X and "Save and Quit" and startup Firefox again, you get the Mozilla Firefox Start Page and a "Restore Previous Session" is showing at the bottom of the page which when clicked will restore your saved tabs.

-If you use File->Exit and "Save and Quit" and startup Firefox again, your saved tabs from the previous session pop right up

Homepage set to some other page/blank: -If you exit using the red X (and hit "Save and Quit"), on starting up Firefox it goes to your homepage, you are not given an option to restore previous session (but you can select it from History->Restore Previous Session)

-If you use File->Exit and "Save and Quit" and startup Firefox again, your saved tabs from the previous session pop right up

I'd like for the latter behavior in these cases to happen all the time...not sure what changed for Firefox 28 when hitting X instead of File->Exit. I've tested this on 27.0.1 and sessions pop right up any way you exit after hitting Save and Quit. This is preferred to me mostly because I'm so used to it and the behavior just isn't consistent. Having to hit Restore Previous Session from the History Menu or from the Firefox start page (if you even have that start page enabled) is a pain since you already told Firefox you want to save your tabs for next time. What ends up happening is that I forget it's saved when I don't see them pop up and then proceed to think it failed to restore the previous session.

Thanks in advance,

Hi all, I'm submitting this question/report because I'm used to some specific behavior on Firefox that doesn't seem to exist anymore and I want to make it happen. As some pre-problem information I know that the showquitwarning setting hasn't been enabled by default for a while but that's always something I've enabled when first installing firefox. I also don't like the option to "Show my windows and tabs from last time", as sometimes I just want to close the tabs and not necessarily always save them. So what's different now is that in the past I toggled showquitwarning to true and you'd be prompted to see if you want to save your tabs for next time. If you closed the browser using the red X or doing File->Exit your tabs would just pop up the next time you started Firefox. This is the behavior I want, but it's not the behavior I can get. Currently, there's a few things that happen depending on what else you have set (keep in mind all of this is with ShowQuitWarning set to true): -As I hinted at before, if you set "General -> When Firefox Starts: Show my windows and tabs from last time", your tabs are always saved on quitting and pop up when you start up Firefox again, you get no choice in the matter (and you'll get the Confirm Close popup instead of an option to Save and Close) Homepage set to Mozilla Firefox Start Page: -If you exit using the red X and "Save and Quit" and startup Firefox again, you get the Mozilla Firefox Start Page and a "Restore Previous Session" is showing at the bottom of the page which when clicked will restore your saved tabs. -If you use File->Exit and "Save and Quit" and startup Firefox again, your saved tabs from the previous session pop right up Homepage set to some other page/blank: -If you exit using the red X (and hit "Save and Quit"), on starting up Firefox it goes to your homepage, you are not given an option to restore previous session (but you can select it from History->Restore Previous Session) -If you use File->Exit and "Save and Quit" and startup Firefox again, your saved tabs from the previous session pop right up I'd like for the latter behavior in these cases to happen all the time...not sure what changed for Firefox 28 when hitting X instead of File->Exit. I've tested this on 27.0.1 and sessions pop right up any way you exit after hitting Save and Quit. This is preferred to me mostly because I'm so used to it and the behavior just isn't consistent. Having to hit Restore Previous Session from the History Menu or from the Firefox start page (if you even have that start page enabled) is a pain since you already told Firefox you want to save your tabs for next time. What ends up happening is that I forget it's saved when I don't see them pop up and then proceed to think it failed to restore the previous session. Thanks in advance,

Athraithe ag blizzak ar

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 12.0 r0

Feidhmchlár

  • Firefox 28.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; rv:28.0) Gecko/20100101 Firefox/28.0
  • URL Tacaíochta: https://support.mozilla.org/1/firefox/28.0/WINNT/en-US/

Eisínteachtaí

  • Adblock Plus 2.4.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.1 (adblockpopups@jessehakanen.net)
  • LastPass 3.1.0 (support@lastpass.com)
  • OpenDownload² 3.5.1 ({210249CE-F888-11DD-B868-4CB456D89593})
  • Tab Mix Plus 0.4.1.3.1 ({dc572301-7619-498c-a57d-39143191b318})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

JavaScript

  • incrementalGCEnabled: True

Grafaic

  • adapterDescription: Mobile Intel(R) 945 Express Chipset Family (Microsoft Corporation - WDDM 1.0)
  • adapterDescription2:
  • adapterDeviceID: 0x27ae
  • adapterDeviceID2:
  • adapterDrivers: igdumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 10-1-2012
  • driverDate2:
  • driverVersion: 8.15.10.2697
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 945 Express Chipset Family (Microsoft Corporation - WDDM 1.0) Direct3D9Ex vs_0_0 ps_2_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Sainroghanna Athraithe

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 6
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140218122424
  • browser.startup.homepage: www.google.ca
  • browser.startup.homepage_override.buildID: 20140218122424
  • browser.startup.homepage_override.mstone: 28.0
  • browser.tabs.onTop: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 28.0
  • font.internaluseonly.changed: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1393344066
  • places.history.expiration.transient_current_max_pages: 53457
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1392148035

Éagsúil

  • User JS: No
  • Inrochtaineacht: Níl
guigs 1072 réiteach 11697 freagra

Hi blizzak,

This may have nbeen affected by the change in the setting where when a user had restore my tabs from last time and hitting the X that the tabs would not show up.

Restoring my tabs from last time in beta, version 28 is greyed out on XP but not Windows 8, like your computer.

I tested it as well File > Exit is consistently restoring tabs from last time. I am confused.

There is an add on that does this as well: It is called Session Manager, and it loads the previous, regardless of how you close it? https://addons.mozilla.org/en-US/fire.../session-manager/

Hi blizzak, This may have nbeen affected by the change in the setting where when a user had restore my tabs from last time and hitting the X that the tabs would not show up. Restoring my tabs from last time in beta, version 28 is greyed out on XP but not Windows 8, like your computer. I tested it as well File > Exit is consistently restoring tabs from last time. I am confused. There is an add on that does this as well: It is called Session Manager, and it loads the previous, regardless of how you close it? [https://addons.mozilla.org/en-US/firefox/addon/session-manager/]
Grampsx2 0 réiteach 10 freagra

Freagra Cabhrach

I've noticed on FF29 that the "Save and Quit" "Quit" "Cancel" Option has disappeared. The normal changing of preferences in Firefox about:config below won't work.

    Type about:config into the address bar and press enter
   Accept the warning message that appears, you will be taken to a list of preferences
   Locate the preference  browser.tabs.warnOnClose  , if its value is set to false, double-click on it to change its value to true
   Repeat this for these 3 preferences  browser.warnOnQuit, browser.warnOnRestart and 'browser.showQuitWarning  

To get the Save and Quit warning box back you have to Type about:config into the address bar and press enter Accept the warning message that appears, you will be taken to a list of preferences Right click on an open space in the preferences settings field and select a new Boolean and enter browser.showQuitWarning and click on OK, then make sure that it's set to true

I've noticed on FF29 that the "Save and Quit" "Quit" "Cancel" Option has disappeared. The normal changing of preferences in Firefox about:config below won't work. Type about:config into the address bar and press enter Accept the warning message that appears, you will be taken to a list of preferences Locate the preference browser.tabs.warnOnClose , if its value is set to false, double-click on it to change its value to true Repeat this for these 3 preferences ''browser.warnOnQuit'', ''browser.warnOnRestart'' and '''browser.showQuitWarning'' To get the Save and Quit warning box back you have to Type about:config into the address bar and press enter Accept the warning message that appears, you will be taken to a list of preferences Right click on an open space in the preferences settings field and select a new Boolean and enter ''browser.showQuitWarning'' and click on OK, then make sure that it's set to true