Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Severe slowness in loading web pages with Firefox 26

  • 16 freagra
  • 84 leis an bhfadhb seo
  • 5853 views
  • Freagra is déanaí ó dtaBSe

more options

Hi to all!

I installed the latest version of Firefox and my browsing started being very slow and a lot of error connections and loading troubles occured. I have already tried the "Restart with Add-ons Disabled" mode and also the "Troubleshooting information" resetting Firefox to its default setting. I had this issue when I updated FF to its latest version 26.0 . With the previous version I had no troubles, and I could solve the few ones I had. I unistalled it and tried to install a new fresh copy but it didn't help. I tried also the Firefox 27.0b2 version and I had the same problem.

When I sign-in my Gmail account, the page loads very slowly and the message "Some Gmail features have failed to load due to an internet connectivity problem" appears.

I can't surf the net on Google because the search takes a lot of time and for all the time the sign in the tab "Connecting..." still remains until the page doesn't load the search, I have to reload the current page to return to Google and try again.

YouTube is very slow and videos don't start at the play button.

I have this severe slowness only with Google, YouTube and also with the addons.mozilla.org site . All other sites load with no problems like webmail pages and others.

I have FF 26 installed on my laptop and using the same connection at my home, I have no problems. It only occurs on my desktop.

More details: I always use the private browsing mode and the only extensions I use are "Adblock Plus 2.4", "Adblock Plus Pop-up Addon", "Anti-Porn Pro" and "FireShot". I modified some about:config setting my I had never had any problems with all the previous versions.

I hope saying all about my problem and you could tell me how to solve it.

EDIT: More info about my FF setting and my system information of my desktop are in the "Question details" -> "More system details" where I posted the "Troubleshooting information" (It's in italian language, but it's very easy to understand).

I restored a system point before the installation of the latest version of FF coming back to the 25.0.1 previous version and like expected I have no troubles. But the problem still remain because I can't use this version for all the time, I'll have to update FF sooner or later.

Athraithe ag Infected23z ar

All Replies (16)

more options

Hello,

Thank you for the detailed explanation and also that you have tried most of the steps to check the connectivity being slow. Before we move ahead, can you please confirm if the connectivity issue is not being observed on another browser on your machine (say Internet Explorer).

The reason I am requesting for this information is because there aren't any regression changes in FF 26.0 that could have caused this slowness you are seeing. I am using Firefox 26.0 on a Windows 7 machine and am not seeing this issue, hence want to rule out any connectivity issues with your ISP before proceeding further.

Thank you

more options

Does this affect both regular HTTP and secure HTTPS sites equally, or do you notice it only on secure HTTPS sites?


Any special connection setting?

orange Firefox button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

Try "No Proxy" (sorry, I don't know the correct translation)


As a diagnostic, could you switch the Flash Player plugin to "click-to-play"?

Open the Add-ons page using either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins. Then change the setting for Shockwave Flash from "Always Activate" to "Ask to Activate".

When sites want to use Flash, a notification icon will appear in the address bar, or in the player rectangle. After seeing whether load time is better, you can go ahead and approve Flash and see how that changes things.

Does Flash seem to be an issue?

more options

Perhaps you have tried this already but, if not...

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on www.google.com:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove your Google cookies individually.

Then try reloading the page. Does that help? (Repeat as needed with other sites.)

more options

I looked up this error message on Google's support forums, and one common reason for this a few years ago were "Labs" features you may have opted into. To start Gmail with the Labs features disabled, you can use this URL:

http://mail.google.com/mail/?labs=0

More info on managing Labs features: Labs - Gmail Help

I don't know whether this is applicable to the Add-ons site, but if you log in using the "Persona" system with your Gmail address, some Google-stuff may be loading in the background.

more options

It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

more options

First of all, thank you for your fast reply. I tried different web browsers such IE and Google Chrome and I confirm the issue occurs only with FF. I'm using Window 7 too. More info about my FF setting and my system information of my desktop are in the "Question details" -> "More system details" where I posted the "Troubleshooting information" (It's in italian language, but it's very easy to understand).

Thank you again and I hope you could help me anyway.

more options

jscher2000

First of all thank you for the fast reply too. I'm sorry but I sincerely have no idea about the difference between regular HTTP and secure HTTPS sites, any examples?

What could happen if I had to change the setting to "No proxy"? Could you explain that in poor words?

The Shockwave Flash plug-in has never caused me any problems, my problem was about the slowness of the video loading, I tried to install again the plug-in downloading from the official web site and I'm quite sure it's not the "trigger" of the problem.

Thank you again and I hope you could help me anyway.

more options

jscher2000

Thank you for this other answer but I always use the private browsing mode, no cookies (no third part cookies), internet history and cache, saved information, site preferences are not saved by default or are recovered and eased when I close FF. I use cleaning programs at the end of the day to clean up them, FF is "always" clear. I have never had problems about.

more options

jscher2000

I looked up this error too and I found the same solution for that, it helped, Gmail is a bit faster than before, thank you.

I don't use any Personas, only the default FF theme.

more options

cor-el

Thank you for your reply. I use Avast! and I changed manually all its features and setting to suit to my tastes and there are no security settings which are in conflict with FF or block it without my permission. I added an exclusion rule to all the FF services/processes.

Thank you anyway for your reply.

more options

On your question about the proxy, by default, Firefox will use the same settings as Internet Explorer to connect to the internet ("Use system proxy settings") but some users may have security software or services such as TOR or private VPN that change their connection setting. Using "No proxy" would bypass any custom settings in Firefox to see whether any of those is a factor.

more options

jscher2000, cor-el

I'm now quite sure what caused the problem. Before updating to the latest FF version 26.0 , I also updated my Avast! antivirus to latest version 2014.9.0.2011 . When I restored to a system point which was created by Avast before the updating, I came back to the 25.0.1 FF version and also Avast came back to the previous version. I updated FF to the 26.0 version and I had no problems, I had a try restoring again and I updated Avast and then FF and I had the same problem for what I asked for help.

I had a research and a lot of people who use Avast had the same problem and solved it disabling the Avast add-on / plug-in for FF which I don't use, so the problem still remain but it's not caused by FF but by the new Avast updates.

The main issue is the lag/delay when searching through Google and sometimes FF stop responding and I have to kill the process.

cor-el

I re-checked the Avast exclusion list like you suggested and it didn't help, the problem still remain but I think I'll find a solution in the Avast support forum.

Thank you all for the replies.

more options

Hi Infected23z, that's great detective work. I hope you get a good answer. In the release notes for the 17 December update, I see:

"Fully rewritten WebShield so that it now doesn't work as a "transparent proxy" anymore, which should result in an overall improvement in stability and performance."

http://www.avast.com/en-us/release-history

Perhaps it isn't living up to its promise...

more options

I couldn't resist looking it up. Apparently there is a configuration change you can make in a hidden file to change the WebShield behavior back to the pre-upgrade behavior as a temporary workaround.

more options

Hi, if its any help what worked for me was uninstalling an extension called "disconnect.me/search" as soon as I removed it my searches were fast again. I put it back and the problem returned. The difference was dramatic. Could be an add on?

more options

SOLUTION - FIREFOX and Chrome SLOW & UNRESPONSIVE

This Really Works!!

- open Internet Explorer

- go to Tools > Internet Options

- go to "Connections" tab

- click on "LAN settings" button

- uncheck "Automatically detect settings"

Athraithe ag dtaBSe ar