Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Can't play YouTube HTML5 videos in Firefox 26

  • 5 fhreagra
  • 130 leis an bhfadhb seo
  • Freagra is déanaí ó WhereIsMyMindAt

more options

I'm using Firefox 26 in Windows 7 x64 SP1.Since yesterday I can't play Youtube HTML5 videos. I have the HTML5 player activated in and when I try to play a compatible video, like this one: I get a big 'loading' animation and nothing happens.That same video is playing without a problem in Internet Explorer 11.

Thanks for your help.

All Replies (5)

more options


Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.


Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Thanks for your answer. I tried Safe Mode and the issue still remains, only now the loading animation is smaller, yet nothing happens. I don't think this is an extension or plugin-related problem, since I don't have anything installed related to HTML5 or YouTube.

more options

I had the same problem with Firefox and found out that the thing causing the problem was the Cooliris add-on. As soon as I deactivated it, videos started to play just fine at You Tube.

more options

In safe mode, after quite a long time to load, the vid does start playing - but won't play continuously. Takes a long time to buffer a little bit, plays that bit, then another long time of the loading animation. Really sucks.

Athraithe ag DeepPeace ar

more options


Check your "Plugins"

Of course HTML5 bypasses/does not need plugins to work (Uses the container) . However could be causing problems trying to take precident over HTML5 (just a rectal extraction guess on that one) *grin* ________________________________________________

You can either disable the plugin or "Bypass Scanning" for the Plugins.

To Bypass Scanning for the plugins, see this Mozilla Help Article

________________________________________________ You didn't mention the OS. Will assume Microsoft. (about:config)= Seach for: plugin.scan.plid.all (change to FALSE) this overrides even windows registry.

See rest of article for further tweaks (with individual renders __________________________________________________

To disable Plugins type about:addons

(opens the traditional addons screen).

Click PLugins. Disable what you wish.

Restart browser. This should work. Let us know.


If you prefer, (before changing anything)--you can do a "Plugin Diagnostic" instructions located here

Standard diagnostic - Firefox

Athraithe ag WhereIsMyMindAt ar