Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Google Services/Sites only sometimes work on Firefox

  • 8 bhfreagra
  • 16 leis an bhfadhb seo
  • 845 views
  • Freagra is déanaí ó jscher2000

more options

I also have been experiencing the same problem as the OP. Google services including Google Search, GMail, and YouTube are all intermittently inaccessible through the most recent version of firefox on my MacBook Pro running OS X 10.6.8. Additionally, sites that use Google APIs also hang (sometimes) when they try to load.

This is frustrating to me because I depend on these services for much of what I do on the web. It is especially frustrating because Firefox has been a dependable and useful browser for me for years. I have had to start using chrome as a workaround but would really prefer to stick with Firefox.

I have identified this problem as specific to firefox, as I have no issues with the Google services in Chrome or Safari. I am also always able to get normal pings to https://www.google.com and https://www.gmail.com through Network Utility on my Mac.

I have tried all of the above solutions including - clearing the cache and cookies (like a zillion times by now) - disabling and deleting all add-ons - starting firefox in safe mode - deleting firefox and reinstalling from a freshly downloaded dmg - manually deleting the user profile for firefox from Library - Changing the manual proxy setting to NO PROXY in firefox preferences - removing all trusted add-ons from firefox preferences - Pushing RESET in the about:config dialog - Resetting my modem/router

I tried to adjust the keyword setting in about:config but when i searched for it it was not present. I wonder if this is part of the problem.

Additionally I have removed the Auto-update files that google software like google earth use to call home to check for updates.

None of these have resolved the issue. I still can only sometimes access Google services using firefox. If I am logged in to GMail using Firefox, i will at some point lose connection and be unable to reestablish the connection for an indeterminate period of time.

This problem has been going on longer than a week or two, maybe a month. I don't know what to do to resolve the issue.

I believe there must be something broken in the way Firefox handles requests for google sites that I have not yet been able to reset or change.

Please, if anyone has found an actual, permanent solution, respond to this thread.

Thanks!

(this seems to be similar to the problem described in another Mozilla support thread: https://support.mozilla.org/en-US/questions/963648 )

All Replies (8)

more options
more options

as an update, I wanted to add that when firefox gets stuck, in the status bar at the bottom, it will usually say that it is trying to load ajax.googleapis.com (or something like that).

I have also started opening the console in firefox (cmd+opt+k) to watch the behavior of sites when they load. Under the network tab in console, google type sites will take 76000+ ms to load. i am only beginning to use the console and don't know exactly what to do with it yet, so i will be experimenting and updating as i learn more.

if i experience a loading hang with a google site in firefox, clearing the cache/history does not work. however, it seems like if i quit and restart firefox, the google site will then load. i am unsure whether this "clears" something in the browser or just gives the connection enough time to fix whatever is causing the hang.

other possibilities: in console it seemed like one of the delayed site attributes was a javascript from google (a .js file) - it took 70000+ ms to load. perhaps there is a problem with javascript?

more options

iamjay: thank you for your suggestion.

i have tried the profile deletion/creation steps and they did not solve the problem.
more options

You can try to disable IPv6, see this article for more suggestions that you can try:

more options

update:

another google site that will not load on firefox: oauth.googleusercontent.com

more options

cor-el: i tried disabling ipv6 as you suggested and so far have not had google connection issues for several hours now.

more options

While disabling IPv6 is all good and well for confirming that it is indeed related to IPv6 only, it is nowhere near helpful in fixing the problem.

I'm having the same problem and performed many of the same troubleshooting steps. I've tried using Wireshark to see what is happening, but since most of the troublesome traffic is HTTPS based it is not very easy.

Are there any non-HTTPS based sites that exhibit this problem?

-- Andreas

more options

Hi ramdyne, I'm not clear what you mean by the first sentence of your reply. Are you saying that disabling IPv6 solves the problem for you, but that you would prefer to make it work with IPv6 enabled?