Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Suddenly, *only with Firefox* all computers in the house show (Error code: ssl_error_rx_record_too_long) when trying to access any Google product.

  • 121 freagra
  • 312 leis an bhfadhb seo
  • 3095 views
  • Freagra is déanaí ó shawssl2

more options

Today, all laptops in the house (latest ver of FF) began throwing the error:

(Error code: ssl_error_rx_record_too_long)

When trying to access any Google products: gmail, Google+, analytics, Google website, etc

Réiteach roghnaithe

Make sure to reset the security.tls.version.max pref to 1 if you have previously changed this pref to 0 to disable TLS 1.0

Read this answer in context 👍 6

All Replies (20)

more options

Hi maylard, a significant change between Firefox 12 and Firefox 13+ is that SPDY was enabled by default starting in Firefox 13. This probably explains why lines 85-87 only appear for the later version of Firefox:

            Extension: next_protocol_negotiation
                Type: next_protocol_negotiation (0x3374)
                Length: 0

Can someone test disabling SPDY?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste spdy and pause while the list is filtered

You can double-click to toggle these preferences between true (their default value) and false. I'm not sure what the different versions indicate.

  • network.http.spdy.enabled
  • network.http.spdy.enabled.v2
  • network.http.spdy.enabled.v3

I don't know whether a restart is required for that to take effect.

more options

I just disabled SPDY and restarted Firefox and nothing changed for me.

more options

I can't get into google or facebook & Shaw now has an automated message directing people to use Chrome or Explorer.

more options

Same problem with me I'm with Shaw in Surrey. I have solved the facebook and google problems by switching to Chrome, but I still can't watch videos from live streaming sites such as Twitch.tv...

Athraithe ag GD12 ar

more options

this problem isn't exclusive to FireFox. a number of other users have said that both FireFox and Chrome can't use streaming sites (ustream, twitch, justinTV)

more options

Thunderbird has the same problem going to Google. How is TLS disabled for it?

more options

hello glenbiagioni, in thunderbird you can reach about:config via Options -> Advanced -> General -> Config Editor. please remember to turn back the security settings though once the problem gets resolved...

more options

I am also in South Surrey, on Shaw and have the same problem. I can access some https sites such as my bank and webmail but can't access either FB or Google on either of my desktops using Firefox. I can access them on Firefox via Wifi on my phone and on my desktops using Internet Explorer.

more options

Hi, I also live in Surrey and have been having this same problem since yesterday (Nov 5th).

I just tried once again to log into my gmail account and it seems to be working again!

Try it for yourselves, hopefully we can all get access via Firefox now to the sites that we have been blocked access too.

more options

Just tried some more sites I couldn't previously access and YEP...

FIREFOX IS WORKING AGAIN!!!

more options

In Surrey .........I can now access Facebook via Firefox! Thank you to whoever fixed the problem!!  :)

more options

I'm east of Maple Ridge and mine is working now too! Yay

more options

Working again in White Rock!

more options

So? Was it Firebox's problem? Shaw's problem? Google's problem? Or all of the above?

more options

hello Happi4gramma, nothing has changed in firefox - a shaw representative on the help section of their homepage stated that they have managed to fix the issue on their part.

more options

Yep... all is good again in Mission, too.

Thank you - whoever you are - for getting this sorted out.

)
more options

Thanks Philipp :)

Good to know because I've been very pleased since I switched to Firefox!! Thanks for your part in solving the puzzle :)

more options

yep! its fixed (in surrey)

more options
more options

Réiteach Roghnaithe

Make sure to reset the security.tls.version.max pref to 1 if you have previously changed this pref to 0 to disable TLS 1.0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7