Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox on Mac 10.9 hangs periodically when connected to Comcast Xfinity Internet service, works fine with other ISPs. Google Chrome works fine with all ISPs.

  • 5 fhreagra
  • 1 leis an bhfadhb seo
  • 27 views
  • Freagra is déanaí ó kroqben

more options

I have been using Firefox for Mac for years without a problem. About 3 weeks ago I started experiencing what appears to be network outtages when connecting to the Internet via my Comcast Xfinity service. It will work fine for awhile and then randomly act like there is no Internet connection for minutes at a time. Then it will start working fine again. I tried every solution I could think of to no avail. Other browsers (Google Chrome, Safari) work fine without any interruptions in service. Firefox works fine with other ISPs (ie. AT&T DSL) but not Comcast/Xfinity. Any help is appreciated.

I have been using Firefox for Mac for years without a problem. About 3 weeks ago I started experiencing what appears to be network outtages when connecting to the Internet via my Comcast Xfinity service. It will work fine for awhile and then randomly act like there is no Internet connection for minutes at a time. Then it will start working fine again. I tried every solution I could think of to no avail. Other browsers (Google Chrome, Safari) work fine without any interruptions in service. Firefox works fine with other ISPs (ie. AT&T DSL) but not Comcast/Xfinity. Any help is appreciated.

All Replies (5)

more options

What is the connection speed compared to the other ISP's?
Are connected, via WiFi or direct connection?


Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back soon.

more options

There is no orange Firefox button nor is there a tools > options menu item. I am running on a Mac.

I did notice that my Cuda driver was not current so I updated that and rebooted. This did not help, FF still hangs like it lost it's Internet connection.

My Comcast / Xfinity service is pretty fast. I routinely get 28+ Mbps down and 5+ Mbps up. I tried both wireless through an Apple AirPort and wired to the cable MODEM directly. Neither fixed the problem.

Are there any debug tools that I can use to gain some insight?

Thanks.

more options

I figured out how to disable hardware acceleration for FF on a Mac. I also cleared the cache. FF still hangs as if it lost it's I'net connection.  :(

more options

Please try updating to Firefox 25.0.


Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back soon.

more options

Hi please check out my thread - it sounds like we may be experiencing similar issues.

https://support.mozilla.org/en-US/questions/980366

I also am using xfinity (I'm in CA). are your problems with all websites? i only have problems with google websites like gmail, google, youtube etc.