Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Java/Vuze error only on Firefox

  • 6 fhreagra
  • 2 leis an bhfadhb seo
  • 260 views
  • Freagra is déanaí ó JLSR

more options

I tried to download a torrent through a magnet link using the Vuze application (I'm using the latest version of Firefox), but what I got instead was the following error:

java.lang.ClassNotFoundException: org.gudy.azureus2.ui.swt.Main at java.net.URLClassLoader$1.run(Unknown Source) at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at com.exe4j.runtime.LauncherEngine.launch(Unknown Source) at com.exe4j.runtime.WinLauncher.main(Unknown Source)

I tried uninstalling and reinstalling the latest versions of both Java and Vuze but to no avail, I used Internet Explorer 9 to download through the same magnet link and it worked, the aforementioned Java error didn't appear and started downloading. And something strange is when I downloaded a file with .torrent extension and double clicked it on the Transfer window of Firefox it worked, it didn't give the Java error. I immediately assumed this is something to do with Firefox.

On my Options > Application tab, the 'magnet' option is set to open with 'Azureus.exe', and I'm using Windows 7 x86, I hope this data helps.

All Replies (6)

more options

Potentially unsafe versions of the Java plugin are "Click to Play" blocked, meaning that you have to click to activate Java for each site. See the How to allow Java on trusted sites article for more information.

Note: To make sure that your Java plugin is working, you can visit the test pages listed in the article, Use the Java plugin to view interactive content on websites. If an "Activate Java" message box appears, click inside the box to activate the Java plugin.

When you see the "Activate Java" message box, simply click it to load the Java content normally.

Fx24-JavaActivate

If there is no visible area to activate Java content in the page, click the red plugin icon in the address bar. In the message panel that opens, choose "Allow Now" to enable Java content temporarily.

Fx24-JavaAllowNow

The next time you visit the site or any other that uses Java you will see this message again.

If you want to always activate Java for a particular site, you can use the "Allow and Remember" option shown above.

After activating Java, you may also see a "Security Warning" dialog box, asking you to confirm that you want to run Java. This warning comes from Java itself, not from Firefox.

Does this solve your problem? Let us know.

more options

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back soon.

more options

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back soon.

more options

ComputerWhiz, I tried using Firefox Safe Mode and the other two solutions you suggested, but none of them worked, unfortunately. I'm still getting the same error.

more options

Try to navigate from the home page of the website (domain) if you currently use a specific (possibly bookmarked) link or go back in the file path to see if that works.

more options

@cor-el: Umm, how should I proceed to do that? (Sorry about sounding too much like a noob for asking this)