Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How do I remove Softonic search engine from Firefox?

  • 9 bhfreagra
  • 23 leis an bhfadhb seo
  • 4785 views
  • Freagra is déanaí ó cor-el

more options

When entering a partial name in the URL box of Firefox, I get a search results page from Softonic. How do I get rid of Softonic?

I have read the top four results (see URL list below) from a Google search and none of them begin to answer by question. (1) There is NO program listed as "Softonic" in the Windows 7, TaskManager, Processes tab. (2) There is no "Softonic" program listed in the Windows 7-Start-ControlPanel-Programs-UninstallPrograms. (3) There is no Softonic program listed in Firefox Extensions; Plugins; nor Services. (4) Softronic is not my Firefox home page. (5) When I type an incomplete URL into the URL box (upper left box, below the tabs) an hit return, I get a Softonic search results page that NEVER has anything I want to go to. It all looks like scam pages to me.

I want to get rid of Softonic. Clearly this is hard because I do not find any real solution on the web. Most of what I find are patronizing answers saying "Read the previous answer" but I have done that and they helped not at all.

Any new information or instructions would be gratefully appreciated.

Please bear in mind that I do not know how to do this, and this is a computer, which means it will do nothing unless I give it exact instructions. If you think you can help me and want to, be sure to give detailed complete instructions.

Thanks so much.

http://answers.yahoo.com/question/index?qid=20100929065743AAmaNkp http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_programs/how-to-remove-softonic-downloader-from-computer/c026cd7c-7a43-e011-9577-d485645a8348?msgId=626c1263-bcc6-47c7-9cd2-ad896d6ffb66 https://support.mozilla.org/en-US/questions/751719 https://support.mozilla.org/en-US/questions/745146

All Replies (9)

more options

hello Gymlea, please just update firefox to the latest version - in firefox 23 the search from the address bar will always be conducted at the same place than the search engine selected in the search bar.

more options
more options

You need to disable it from the add-ons, and then it will most likley be on the home and new tab pages as well, so you will need to change those. How to change home page: Go to options in the Firefox menu, and then go to the general tab. There will be options to change your home page.

How to change your new tab: In the address bar, type in about:config, and accept the warning if it's there. Then in that address bar, type in browser.newtab.url, and then it'll show up in the list. Double click it, and then I diolog box will show up to change your new tab.

more options

Could you describe what you're entering into the address bar? If you enter a single word in the bar and press Enter or click the Go button, Firefox will do a DNS lookup with your ISP (or other DNS provider) to see whether it is a valid domain. Some DNS providers will, instead of honestly reporting that it doesn't exist, redirect Firefox to a search page. This problem only occurs with one-word searches.

more options

By the way, Firefox 23 has changed how address bar search works. It now uses the search engine set on your Search Bar, which makes it harder for third party software to hijack your address bar searches. You can update using:

Help > About Firefox > Check for Updates

Edit: philipp already said that...

Athraithe ag jscher2000 ar

more options

Remove softonic, then go to about:config in address bar type softonic to delete it.

more options

You are enterning about: config in the address bar, as I've already stated.

more options

By the way, I make a mistake in the URL. There is no space after the :.

more options

Your System Details List shows a keyword.URL pref that sets the search engine used for the location bar in Firefox 22.

As posted above, if you update to Firefox 23 then this pref is no longer supported and searching will use the search engine selected in the search bar on the Navigation Toolbar.

You can use the SearchReset extension to reset some preferences to the default values including keyword.URL.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).


If this problem return after a restart then start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) is causing the problem.

  • Do NOT click the Reset button on the Safe Mode start window.

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)