X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

After the update of firefox 23, whenever I click back button doesn't reload the page.

Postáilte

Before the update everything was working fine, but yesterday after the update I noticed that whenever I open a page and after that I hit back button, it doesn't reload the page like before. It's annoying, because I use forum and sometimes is confusing when I open a thread and after that it still says that "new thing", the only way to remove it is to reload the page from the refresh button.

Before the update everything was working fine, but yesterday after the update I noticed that whenever I open a page and after that I hit back button, it doesn't reload the page like before. It's annoying, because I use forum and sometimes is confusing when I open a thread and after that it still says that "new thing", the only way to remove it is to reload the page from the refresh button.

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Google Update
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Next Generation Java Plug-in 1.6.0_33 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VLC media player Web Plugin 2.0.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 4.1.10329.0
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.732
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Windows Multimedia Services DRM Store Plug-In

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:23.0) Gecko/20100101 Firefox/23.0

Tuilleadh Eolais

Vicki10 1 réiteach 11 freagra

It's working!!!!

Thank you SO MUCH jscher2000 for all your help in getting this working for me! Now I can read my Forums without having to hit the Reload button all the time. It is a little "choppy", but I can deal with it!

THANKS again and again! Vicki

'''It's working!!!!''' Thank you SO MUCH jscher2000 for all your help in getting this working for me! Now I can read my Forums without having to hit the Reload button all the time. It is a little "choppy", but I can deal with it! THANKS again and again! Vicki
jscher2000
  • Top 10 Contributor
8774 réiteach 71729 freagra

Hi Vicki, thank you for providing the URL to test on. That made it easier to get to a "solution."

Hi Vicki, thank you for providing the URL to test on. That made it easier to get to a "solution."
MesaSounder 0 réiteach 3 freagra

My Browser has been doing it on all pages every since the upgrade. I have to refresh to see the page. It gets annoying. I ran firefox in safe mode and it still did the same thing

My Browser has been doing it on all pages every since the upgrade. I have to refresh to see the page. It gets annoying. I ran firefox in safe mode and it still did the same thing
jscher2000
  • Top 10 Contributor
8774 réiteach 71729 freagra

Hi MesaSounder, is it the problem where the page doesn't refresh when you go back, or is it the problem that pages do not appear completely styled when you first visit them so you have to reload to get them to appear correctly?

For the second problem, try completely clearing your Firefox cache.

(WIN) orange Firefox button (or Tools menu) > Options > Advanced
(MAC) Firefox menu > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

Hopefully that will help most sites and only leave a few with an issue.

Hi MesaSounder, is it the problem where the page doesn't refresh when you go back, or is it the problem that pages do not appear completely styled when you first visit them so you have to reload to get them to appear correctly? For the second problem, try completely clearing your Firefox cache. (WIN) orange Firefox button (or Tools menu) > Options > Advanced<br> (MAC) Firefox menu > Preferences > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. Hopefully that will help most sites and only leave a few with an issue.
MesaSounder 0 réiteach 3 freagra

The problem is when I hit the back button I go back to a page that shows for a split second then goes blank. If I select reload it comes right up but I always have to reload the page to get it to come up.

The problem is when I hit the back button I go back to a page that shows for a split second then goes blank. If I select reload it comes right up but I always have to reload the page to get it to come up.
jscher2000
  • Top 10 Contributor
8774 réiteach 71729 freagra

Hi MesaSounder, if the problem page is Google search results, there is a separate thread on that. The combination of "instant prediction" results + higher zoom level is, for reasons not yet known, causing this problem. There are some temporary workarounds here: When I go back to Google search results page, it takes me to a blank Google screen.

If it's a different page, do you want to post the URL for volunteers to test?

Hi MesaSounder, if the problem page is Google search results, there is a separate thread on that. The combination of "instant prediction" results + higher zoom level is, for reasons not yet known, causing this problem. There are some temporary workarounds here: [https://support.mozilla.org/en-US/questions/970863 When I go back to Google search results page, it takes me to a blank Google screen]. If it's a different page, do you want to post the URL for volunteers to test?
Vicki10 1 réiteach 11 freagra

I can't seem to get back to the original post, so posting again here.

I did a reboot after having everything working, and now it's NOT working again. I tried re-installing GreaseMonkey and the script you'd written for me and it still won't work PLUS a lot of other windows keep popping up now that I'm pretty sure I didn't install myself are showing up.

I've now removed GreaseMonkey and everything else that were showing up in hopes that will end. If not, I'll do a restoration.

Any idea on when FireFox itself will have this option?

Thanks again for all your help! Vicki

I can't seem to get back to the original post, so posting again here. I did a reboot after having everything working, and now it's NOT working again. I tried re-installing GreaseMonkey and the script you'd written for me and it still won't work PLUS a lot of other windows keep popping up now that I'm pretty sure I didn't install myself are showing up. I've now removed GreaseMonkey and everything else that were showing up in hopes that will end. If not, I'll do a restoration. Any idea on when FireFox itself will have this option? Thanks again for all your help! Vicki
jscher2000
  • Top 10 Contributor
8774 réiteach 71729 freagra

Hi Vicki10, I'm sorry to hear about the other windows. Could you check whether you have any unexpected extensions, or whether any you use regularly (e.g., ad blockers) have become disabled?

orange Firefox button (or Tools menu) > Add-ons > Extensions category

I'm not sure why Firefox seems to be more aggressively holding on to cached pages than before. I'm assuming it was an intentional change, but it's also possible that it's a bug. (I might have researched that before but I can't remember now...)

Hi Vicki10, I'm sorry to hear about the other windows. Could you check whether you have any unexpected extensions, or whether any you use regularly (e.g., ad blockers) have become disabled? orange Firefox button (or Tools menu) > Add-ons > Extensions category I'm not sure why Firefox seems to be more aggressively holding on to cached pages than before. I'm assuming it was an intentional change, but it's also possible that it's a bug. (I might have researched that before but I can't remember now...)
Vicki10 1 réiteach 11 freagra

Wow!!! You're right on top of everything! I really do appreciate you too!

I just checked the extensions and there are three which are all disabled: Bing Bar Default Manager 2.2 Search Helper 1.0

and it's says they're disabled because of security or stability issues (which is just fine with me).

I have removed everything pertaining to GreaseMonkey though. I haven't rebooted the computer again though as that's such a pain!

Vicki

Wow!!! You're right on top of everything! I really do appreciate you too! I just checked the extensions and there are three which are all disabled: Bing Bar Default Manager 2.2 Search Helper 1.0 and it's says they're disabled because of security or stability issues (which is just fine with me). I have removed everything pertaining to GreaseMonkey though. I haven't rebooted the computer again though as that's such a pain! Vicki
RICKMAN235 0 réiteach 1 freagra

I have the same problem but it is also not restricted to forums. ANYTHING I am searching within Firefox via Google causes what I believe is the same problem everyone else is having, HOWEVER, I have found that if I hit the back button TWICE and then go forward one page, there is the page that normally would show with a one time click of the back button. Can anyone else confirm this, and, does anyone know how I can fix this. Totally annoying. Thanks.

Rick

I have the same problem but it is also not restricted to forums. ANYTHING I am searching within Firefox via Google causes what I believe is the same problem everyone else is having, HOWEVER, I have found that if I hit the back button TWICE and then go forward one page, there is the page that normally would show with a one time click of the back button. Can anyone else confirm this, and, does anyone know how I can fix this. Totally annoying. Thanks. Rick
jscher2000
  • Top 10 Contributor
8774 réiteach 71729 freagra

Hi RICKMAN235, if you go Back to Google and get either the wrong results or a blank page, please see the workarounds in this thread: When I go back to Google search results page, it takes me to a blank Google screen.

Hi RICKMAN235, if you go Back to Google and get either the wrong results or a blank page, please see the workarounds in this thread: [https://support.mozilla.org/en-US/questions/970863 When I go back to Google search results page, it takes me to a blank Google screen].
MesaSounder 0 réiteach 3 freagra

That seemed to fix it. Cleared my cache and now its working great. Not sure why that happens but yo are correct. Clearing the cache seems to fix the problem

That seemed to fix it. Cleared my cache and now its working great. Not sure why that happens but yo are correct. Clearing the cache seems to fix the problem
ferrario 0 réiteach 3 freagra

I am having this problem with the New York Times digital edition. Read and article and have to click "go back" up to four times to get back to the "front page". Apple OSx, but the same problem on PC Windows 7. No problem with IE and Safari. Previously "solved" the no return to search results in Google so it is not that one.

I am having this problem with the New York Times digital edition. Read and article and have to click "go back" up to four times to get back to the "front page". Apple OSx, but the same problem on PC Windows 7. No problem with IE and Safari. Previously "solved" the no return to search results in Google so it is not that one.
jscher2000
  • Top 10 Contributor
8774 réiteach 71729 freagra

Hi ferrario, if you right-click the Back button, do you see multiple entries for the same page between where you are and the home page? Does it get worse and worse as you scroll down the page? That could be similar to this thread: scrolling down an nbc news article causes back history to fill up. No solution was found for that, however.

Hi ferrario, if you right-click the Back button, do you see multiple entries for the same page between where you are and the home page? Does it get worse and worse as you scroll down the page? That could be similar to this thread: [https://support.mozilla.org/en-US/questions/976169 scrolling down an nbc news article causes back history to fill up]. No solution was found for that, however.
ferrario 0 réiteach 3 freagra

I am suspicious in that I see this only on the New York Times site, and the Times just revamped their presentation. Correlation?

Somehow my last post got lost.

In answer to your question, the history does fill up and it gets worse after scrolling. It fills up only with the page I want to leave and not other pages as described in the NBC reference you cite.

Tested this on a PC and a Mac; same result. Tested on IE; no problem. This is all pointing to Firefox and not the NYT.

I am suspicious in that I see this only on the New York Times site, and the Times just revamped their presentation. Correlation? Somehow my last post got lost. In answer to your question, the history does fill up and it gets worse after scrolling. It fills up only with the page I want to leave and not other pages as described in the NBC reference you cite. Tested this on a PC and a Mac; same result. Tested on IE; no problem. This is all pointing to Firefox and not the NYT.

Athraithe ag ferrario ar

jscher2000
  • Top 10 Contributor
8774 réiteach 71729 freagra

Hi ferrario, I'm not sure why other browsers do not record the URL changes as new history entries and Firefox does. I don't have time to investigate that today, but perhaps I can look at it over the weekend. Meanwhile, if you have an NYTimes login, could you submit a question to their web support? Maybe they can spot the issue quickly and figure out a fix.

Meanwhile, I think the workaround would be to use the right-click list to back-navigate on that site, or use the in-page navigation links to return to the home page or section where you were before. That's all that comes to mind at the moment.

Hi ferrario, I'm not sure why other browsers do not record the URL changes as new history entries and Firefox does. I don't have time to investigate that today, but perhaps I can look at it over the weekend. Meanwhile, if you have an NYTimes login, could you submit a question to their web support? Maybe they can spot the issue quickly and figure out a fix. Meanwhile, I think the workaround would be to use the right-click list to back-navigate on that site, or use the in-page navigation links to return to the home page or section where you were before. That's all that comes to mind at the moment.
ferrario 0 réiteach 3 freagra

Yea, I put in a note to the NYT, and I'm right-clicking to go back for now. Is it my imagination or are more and more truly basic functions getting screwed-up while the exotica gets more an more exotic? How simple is "go back where you just came from"? Cheers!

Yea, I put in a note to the NYT, and I'm right-clicking to go back for now. Is it my imagination or are more and more truly basic functions getting screwed-up while the exotica gets more an more exotic? How simple is "go back where you just came from"? Cheers!
jscher2000
  • Top 10 Contributor
8774 réiteach 71729 freagra

Hi ferrario, I don't know where you are seeing this problem in NYT, but on the NBC site, a script in the page was intentionally changing the URL as you scrolled down, perhaps to make individual stories easy to bookmark. This seems like a rather modern page design and someone might need to file a new bug to kick off a discussion of how Firefox should handle it.

Hi ferrario, I don't know where you are seeing this problem in NYT, but on the NBC site, a script in the page was intentionally changing the URL as you scrolled down, perhaps to make individual stories easy to bookmark. This seems like a rather modern page design and someone might need to file a new bug to kick off a discussion of how Firefox should handle it.
wakingcrow 0 réiteach 1 freagra

I had the problem that my back button and right click menu, and reload button were all grayed out and inactive, and the display url's were all wrong.

I fixed it by disabling Gorilla Price helper extension, shown as GPControl 1.0, which was surprising. I had not only disabled it before but went thru the registry and deleted everything to do with it, and thought it was completely removed from my computer.

I had the problem that my back button and right click menu, and reload button were all grayed out and inactive, and the display url's were all wrong. I fixed it by disabling Gorilla Price helper extension, shown as GPControl 1.0, which was surprising. I had not only disabled it before but went thru the registry and deleted everything to do with it, and thought it was completely removed from my computer.
kram160 0 réiteach 7 freagra

I'm having the exact same issue with the New York Times (nytimes.com). I have to click the Back button twice to return to the previous page. The problem cropped up when they launched their re-design. I can't seem to find any solution posted on this forum. Is there one? (I cleared my cache, but it didn't fix anything. No such problem with Chrome or IE.) I sent a message to the Times, but received only a "canned" reply.

I'm having the exact same issue with the New York Times (nytimes.com). I have to click the Back button twice to return to the previous page. The problem cropped up when they launched their re-design. I can't seem to find any solution posted on this forum. Is there one? (I cleared my cache, but it didn't fix anything. No such problem with Chrome or IE.) I sent a message to the Times, but received only a "canned" reply.

Athraithe ag kram160 ar