Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

recently closed tabs isn't working

  • 9 bhfreagra
  • 61 leis an bhfadhb seo
  • 4816 views
  • Freagra is déanaí ó jhep3304

more options

I had to remove Qvo6 from my computer this morning, and after that recently closed tabs stopped working at all, it's done that before but opening new window fixed that problem. Tried removing firefox but that didn't work. Closed windows works fine.

Ideas how to get it back to work?

All Replies (9)

more options

Is the problem that the History menu no longer displays the Recently Closed Tabs list (the list is empty), or that choosing a Recently Closed tab doesn't actually open it?

To quickly check whether an add-on might be at fault, could you try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

Instead of resetting your whole browser, try opening a new tab, type "about:config" w/o the quotes and hit enter. Then under search near the top, type: sessionstore and right click->reset anything that is bolded, particularly browser.sessionstore.max_tabs_undo and browser.sessionstore.max_windows_undo. It did the trick for me.

more options

My "Recently Closed Tabs" was grayed out and inoperative. As of Dec 2nd this "fix" still works. Thanks for posting it.

more options

Why doesn't the fix stick? What's going on to change it ?

more options

Odds are there is some form of malware running in firefox. Go to Firefox->Add Ons, then select Extensions. I would disable anything that looks suspicious (or one by one), restart, then do my fix, and restart again and see if the changes stuck.

Usually things that cause this are unwanted virus scanners and other search toolbar helpers (that you probably didn't install). I don't remember what caused my issue as it was so long ago.

more options

I'll keep an eye on it then. Right now, all Extensions, toolbars, etc. are disabled, but I've recently run malware protections that (I think) included a Firefox reset. Thanks for your feedback.

more options

I also had the problem reoccur after the first fix. Following munky's suggestion, I deleted the only recent extension (Ads Removal 1.0.0) restarted, reapplied the fix and restarted again. Everything worked. I then ran a rootkit scan with PC Tools ThreatFire since this is the only antivirus tool that I've recently run. I then did a "cold" reboot, started Firefox, opened and closed some tabs and everything seems to be working properly. Evidently my case involved the Ads Removal 1.0.0 extension. Thanks for your help, I'll continue to monitor and and advise of any further changes.

more options

It appears that Ad Removal 1.0.0 was not the problem after all. I just ran Glary Utilities and if the "Temporary Files Cleaner" box is checked then the cleanup interfers with the Firefox "Recently Closed Tabs" function. As long as the Glary Utilities "Temporary Files Cleaner" box is left unchecked, then everything works as it should.

more options

After experiencing the problem with Glary Utilites Temp file cleaner mentioned above - I also ran Wise Disk Cleaner (Common Cleaner and Advanced Cleaner) and Advanced System Care as well as Microsoft Disk Cleaner on both the Operating Drive and the Data Drive. I also manually deleted Temp files via "run %temp%" and also navigating to: "C:\users\<name>\appdata\local\microsoft\windows\temporary files" and manually delteting the entries. I did a "hot boot" after each routine and Firefox "Recently Closed Tabs" remained intact in each instance. It seems that "Glary Utilities 4 Temporary Files Cleaner option" is the culprit in my situation. Deep apologies to "Ads Removal 1.0.0" castigated unfairly in my previous post and Thanks again to "munky" for the very helpful post.