Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Why is Windows 7 freezing when using Firefox?

  • 11 freagra
  • 143 leis an bhfadhb seo
  • 39441 views
  • Freagra is déanaí ó Bittu

more options

-Has been happening for months now with many attempts to pinpoint cause. Have come to the conclusion that it is Firefox but don't understand why. -When using Firefox, my entire PC, not just Firefox, will freeze. Sometimes it happens within the first 5min of using Firefox, other times it could happen an hour into a session. A hard restart is the only way to get back to my desktop as I have waited an hour before after a freeze and nothing happens. Mouse pointer won't move, nothing. -Initially thought it was a hardware issue or an anti-virus issue. -Reinstalled windows on three different hard drives that all pass the disk check. Still happens -Installed windows 8 to see if that would fix the problem. Nope, does the same thing on Windows 8. -Ran Memtest 86+ for 14 hours one night to see if it was my memory. Nope, zero memory errors found -To be sure I even tried only using one stick of ram in my PC at a time to see if any of the sticks were bad. Nope, it froze with every stick -Tried changing my anti-virus. It froze with every single one, AVG Free, Avast Free, Microsoft Security Essentials. -I figured out that my PC only freezes when I am browsing the web in firefox. If I use chrome or Internet explorer, it doesn't happen. These total PC freezes only happen when I am using firefox. -My only add on/plug in that I am using is Adblock plus besides the default ones that come with Firefox. -My firefox is up to date, I have reset it and reinstalled it [while only adding Ad Block +] and this still does not fix the problem -In the windows event log the only thing that happens every time my PC freezes is the Error "Session "Microsoft Security Client OOBE" stopped due to the following error: 0xC000000D", why this would only affect Firefox, I don't know. -I would like to figure out the cause of this because I would really like to use Firefox again.

Réiteach roghnaithe

I have finally figured out that Firefox is not the issue with this problem but it is in fact the Nvidia drivers. This is a shame as Nvidia pushes driver updates hard.The drivers that eliminate this problem are 314.22. After uninstalling the most current drivers and replacing them with 314.22 I have not had the problem at all in any program including Firefox.

Here is an Nvidia thread on the issue.

https://forums.geforce.com/default/topic/596642/geforce-drivers/please-help-event-id-14-from-source-nvlddmkm-cannot-be-found/2/

I had to replace a bunch of my hardware before I figured out it was the Nvidia drivers as I did not get the correct error message on my old set up that pointed me in the direction of the video card.

So anyone with this problem I highly recommend downgrading to driver version 314.22 if you have an Nvida GPU in your system.

I am very disappointed with Nvidia for not resolving this issue after 15+ driver updates since 314.22.

Read this answer in context 👍 4

All Replies (11)

more options

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

-I am happy to report that my Firefox no longer freezes since I unchecked the "Use hardware acceleration when available" box. Thank you so much. -Interestingly Firefox still plays 1080p YouTube videos with about 15% less CPU usage when compared to Chrome, which is one of the main reasons I use it. Yay Firefox. Hardware acceleration or not, its efficient. -Thanks again

more options

Hello. Just to let you know that this is still an issue. For a few days I have had problems with my computer freezing while using Firefox. Just before it started, I had an issue with a saved file in PhotoShop, that resulted in a warning about the GPU. So I updated my Nvidia driver which forced me to use the GeForce experience ... meh. Then the first freeze. I then upgraded to FF 25.0, and still experienced the computer freezing, only while using FF, either browsing or while replying to emails. Have tried your advised solution. Looking forward to it working. By freezing, I mean only a hard restart will allow access to my computer again, then it is normal for awhile.

more options

I started having this problem just after having the latest version of Firefox pushed to me which also coincided with a driver update to my Nvidia graphics card. I uninstalled Firefox and the Nvidia drivers, rebooted, Win7-64 installed the latest Nvidia drivers, I re-installed the latest Firefox and still had problems with the OS freezing up. I finally just re-installed the last Nvidia driver that I had been using and havent had a problem since. It does not appear to be just Firefox that is causing this but the interaction of Firefox with the Nvidia driver so the hardware acceleration suggestion makes sense. I had problems with both the 331 and 320 drivers for Win7-64. I had no problems running IE (except that it is a pig) or Chrome.

more options

Réiteach Roghnaithe

I have finally figured out that Firefox is not the issue with this problem but it is in fact the Nvidia drivers. This is a shame as Nvidia pushes driver updates hard.The drivers that eliminate this problem are 314.22. After uninstalling the most current drivers and replacing them with 314.22 I have not had the problem at all in any program including Firefox.

Here is an Nvidia thread on the issue.

https://forums.geforce.com/default/topic/596642/geforce-drivers/please-help-event-id-14-from-source-nvlddmkm-cannot-be-found/2/

I had to replace a bunch of my hardware before I figured out it was the Nvidia drivers as I did not get the correct error message on my old set up that pointed me in the direction of the video card.

So anyone with this problem I highly recommend downgrading to driver version 314.22 if you have an Nvida GPU in your system.

I am very disappointed with Nvidia for not resolving this issue after 15+ driver updates since 314.22.

more options

This may not work for some systems but it seems to be the fix for most. Also avoid installing Nvidias unnecessary software "GeForce Experience" and set up windows to not automatically install drivers from windows update otherwise it will install the bad drivers on its own and the problem will re-occur.

Athraithe ag Nedloh ar

more options

Nedloh, Thanks for updating this and for linking to the related nVidia GeForce Drivers thread on the issue. I marked your first post from today (about replacing your video drivers with v.314.22) as the solution.

more options

It was the 314.22 drivers that I re-installed as well and had no more problems BUT: I later followed wocka's suggestion of disabling acceleration in Firefox, installed the latest Nvidia drivers and also have not seen a re-occurrence of the issue in about 4 days so far. I think either solution might work depending on your system.

more options

Disabling hardware acceleration in Firefox didn't totally resolve the issue for my previous system set up. I will try it in the new system to see if it makes a difference. Installing the 314.22 drivers has still been the best cure for both my particular systems.

In my old system disabling hardware acceleration made the freezing less frequent but did not get rid of the freezing all together.

more options

Nedloh, i did experience the same problems. Now i use nvidia 320.49 with hardware acceleration disabled. No troubles so far. 1 day of usage.

Brand new win7 install ( because i have this issue until the all system failed beyond repair and i did not suspect firefox. I did experienced frequent BSOD-s after nvidia updates but the help related to that codes was leading to hardware issues, memory, hdd, loooong story to find out that was my favorite browser)

more options

Check it by Disabling your Firewalls prtections or remove them totally... or install a older version of Firefox or wait for a new version..

Athraithe ag Bittu ar