Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Memory usage high (350-500MB) with fresh install, blank profile, no extensions, & minimal tabs.

  • 10 bhfreagra
  • 60 leis an bhfadhb seo
  • 4770 views
  • Freagra is déanaí ó Firewall117

more options

Firefox has been slowing down, and using a high amount of Memory. I have tried all of the steps described in the various main support articles about too much memory.

I am running V 22 on Windows 7. Both Firefox & the OS are completely up to date. I have NO extensions & NO plug ins enabled now. I disabled all that are installed. I have never used themes. I have cleared my cache, and then created a completely new blank profile. I have restarted into Safe Mode (Add ons disabled) and seen the same behavior. I tried both a clean install (deleted the install folder) & an uninstall followed by a reboot & fresh install. I have turned off my Ad Blocker, and checked my firewall & antivirus (MS Forefront) to ensure everything is clean & unblocked.

Even is safe mode, or under my empty profile, if I open Firefox and 4 total tabs. They are not uncommon ones; Gmail, Google Plus, Facebook, and Twitter. Memory use, under the best case, hovers between 350-500 MB, with 400-450 being most typical. Firefox has now become the slowest browser on my computer.

I don't feel like it should require this much effort to just work well. I've used several threads & diagnostics on the site, and am comfortable following instructions. None of them have gotten me closer to a solution.

All Replies (10)

more options

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!

Thank you.

more options

I followed your instructions for disabling Hardware Acceleration. That seems to have helped a little bit, but not much. With the same tabs open, I'm hovering between 300-375 MB instead of 350-500. However, it's still high, and can still peak into the 400 range if I open another tab or two.

The additional tab is to my manufacturer website. I'm running an update on the graphics driver now. I'll update with another reply once that finishes.

Nice screen name. Are you the rapper? A fan of the rapper? A TK show 'Little'? Whichever is fine- just funny.

more options

No just a fan of Waka Flocka.

more options
more options

Update- no success.

I have the latest video drivers on my computer. Tested with hardware acceleration on & off. It's off right now. Created a brand new empty profile, with my old profiles backed up & removed, just in case. Zero plugins. Zero Extensions. The same four tabs open - Facebook, Twitter, Gmail, and Google Plus. Memory floats between 350-400.

Any other ideas? At this point, if performance doesn't improve, I'm tempted to switch default browsers, and just export my saved settings. Hoping not to do it, but running out of options.

more options

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

more options

Just did a reset. Performance is the same. In fact, I'm back at 400+ MB of memory. It even climbs using a different set of 4-5 sites open. I even tried them with sites that are more static, and have less media, like the front pages of amazon, google, yahoo, and cnet.

more options

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.


Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

Dude, consider yourself lucky. For me, Firefox is using up to 3GB of RAM.

more options

I suspect saying this may get my reply deleted by an admin as people simply do not like the truth, but i personally feel the Mozilla Firefox team is simply too proud of their achievement to even acknowledge the possibility that that this issue is inherent in their program.

I for one feel they simply have chosen to smokescreen the whole issue and cover it up with a band-aid by posting a fancy guide on how to fix the issue where most of the suggestions do not even remotely help. Instead they find any reason whatsoever to lay blame on 3rd party vendors and various other possibilities and they do this exceedingly often.

The fact that this problem exists on even clean installs tells me they are simply in major denial. I recommend people use an alternative browser... there are tons out there such as Chrome, Opera, Etc.