Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

When trying to click on menus on USAA, it shows "javascript:;" in the bottom left hand corner and the menu won't work in FF 21. But the menus work in IE 10.

  • 18 freagra
  • 9 leis an bhfadhb seo
  • Freagra is déanaí ó puffindragon5

more options

whenever I go to on firefox, I can't click on any of the drop down menus. Instead, a box in the bottom left corner (where a link address would usually show) pops up with "javascript:;". If I use IE10, the site works perfectly. I prefer Firefox so it drives me a little nuts that I have to switch browsers for one site. I've removed all my cookies, cleared the cache, reset Firefox, and run Firefox in safe mode. The website still refuses to play nice. All the regular links on the site work but the drop down menus won't.

Réiteach roghnaithe

FINALLY! Thanks Cor-el!!!

I put dom.w3c_touch_events.enabled as 0 and it fixed it. I didn't change dom.w3c_touch_events.expose.

Crazy little issue but I'm so glad it's fixed now. Thanks to everyone!

Read this answer in context 👍 3

All Replies (18)

more options

Another user posted a similar report a few months ago, but didn't confirm whether it was resolved for him/her: Drop-down menus not working.

The "URL" you're seeing is normal, that's the way they've set it up since a script is intercepting the click and opening that big fancy menu.

I assume JavaScript works normally on other sites?

When you load, is your Firefox properly redirected to or are there issues with redirects or site loading? (I suppose if you have a cookie from a previous login, you might go to a different page.)

more options

By the way, even in Safe Mode, your plugins run. You might want to try disabling any nonessential plugins here:

orange Firefox button (or Tools menu) > Add-ons > Plugins category

My Firefox has a glitch where it only disables one plugin at a time no matter how many I click, so I click a Disable button, switch to the Appearance category, switch back to the Plugins category, then click the next Disable button. Etc. You might try it once just to make sure your changes are being saved.

more options

I haven't run into any issues on other sites. And yes, my Firefox is redirecting to

I can access my bank account information but I can't use the drop down menus to look at the other tools on the site. Such as the pay my bills tool.

And I haven't downloaded any plugins aside from the ones that comes with FF when you install it.

more options

It may appear that plugins come with Firefox, but actually Firefox usually discovers them in the Windows registry, or a software installer drops them in a shared location. As a result, we all tend to have different plugins.

More thoughts:

(1) Private Browsing?

I assume this is a regular window not a private window? If the problem is occurring in a private window, can you try in a regular window?

(2) Site Permissions?

Firefox allows you to set various permissions and exceptions, for example, whether a site is allowed to use pop-ups or set cookies. To try to clear any site-specific settings for, you could try the following:

  • When viewing a page on the site, right-click the page > View Page Info > Permissions tab, and make sure nothing is blocked
  • Alternately, you can type or paste about:permissions in the address bar and then use the search box on the left to find and adjust permissions -- this might be a slightly different set of items
  • You can erase the site history, bookmarks to the site, and all cookies and permissions for the site using the "Forget about this site" feature. There's a button on the about:permissions page (faster) or you can right-click an entry for the site in history (slower).

(3) Zoom Breaking Layout?

To reset zoom on the site, you can use Ctrl+0 (that's a zero).

Some sites do not work well if you use the "Zoom Text Only" option on the View menu.

tap the Alt key > View menu > Zoom > uncheck Zoom Text Only

(4) Malware?

In case some kind of malware is interfering with use of the page, you may want to run some supplemental scans. These three tools are highly regarded (and free):

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

You can try to reset (power off/on) the router.

more options

I tried all of the above and none of it worked.

Also, I checked my home computer and the site works fine at home (same Firefox and settings). The only difference is my home computer is Windows 7 and this laptop is Windows 8. Could it be an odd interaction with Firefox and Windows 8?

more options

Windows 8 may have some differences from Windows 7, but I haven't seen any specific documentation on it. And most likely those get fixed in the ordinary course.

Could you check Firefox's error console?

(1) Reload the page

(2) Open the error console use Ctrl+Shift+j and click the Clear button

(3) Click the menu button and then check the console for any errors (you can right-click to copy and then paste it here if you find one)

more options

It doesn't show any errors when I try to click the button. I've attached a screenshot of what shows up in the bottom left hand corner whenever I have the mouse over the drop down menu. Clicking the menu button is supposed to have a big window pop up like in the second image (using IE 10).

more options

If you right-click Advice Center and choose Inspect Element (Q), the inspector pane should open with a span element (<span...) selected. A couple elements down is a div element (<div...) with a long list of class names, the last of which is "hidden". See first screen shot. If you then click the Advice Center menu link normally, the script is supposed to remove "hidden". See second screen shot. Is that happening when you click the menu?

Athraithe ag jscher2000 ar

more options

It doesn't matter how many times I click the button, it still shows the same thing in the inspect element.

more options

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

Download a fresh Firefox copy and save the file to the desktop.

Uninstall your current Firefox version, if possible, to cleanup the Windows registry and settings in security software.

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you will lose all personal data like bookmarks and passwords from profiles of other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.

If you keep having problems then also create a new profile.

more options

So freaking weird. I've been trying everything and then read something where they said the buttons work on Windows 8 but only if you tap your touch screen. The menu opens if I tap my screen with my finger.

Is this a weird Firefox and Windows 8 interaction that you can't click certain javascript, you have to tap?

more options

Hi TrinityFire, thank you for the update. It seems wrong that a site could limit you to using one method of "clicking". I wonder whether there is a Firefox setting to always ensure that mouse clicking will work even if your device has a touchscreen?

Could you check these two preferences and see whether they make any difference:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste touch and pause while the list is filtered

(3) Try double-clicking the following to toggle them to false:

dom.w3c_touch_events.enabled = true (default) See Note
dom.w3c_touch_events.expose = true (default)

You might need to restart after changing these settings before they take effect.

Does this switch the site from touch to mouse click? Or make it stop working altogether?

Note: dom.w3c_touch_events.enabled requires a numeric setting, see cor-el's post below.

Athraithe ag jscher2000 ar

more options

It made it stop working all together...

more options

Thank you for testing that.

Maybe the upcoming Windows 8.1 release will address some of these things. Meanwhile, if you like the touch features, I think we might be stuck. If you don't like them, perhaps you can turn them off in a Windows control panel to restore mouseability?

It's probably worth searching on to see whether this is a known problem, or filing a new bug. Sites shouldn't ignore mouse input just because touch is an option.

more options

dom.w3c_touch_events.enabled is an Integer pref and isn't a Boolean pref.

The dom.w3c_touch_events.enabled tri-state preference can be used to disable (0), enable (1) and auto-detect(2) support for standard touch events; by default, they're on auto-detect(2). After changing the preference, you must restart the browser for the changes to take effect.
more options

Réiteach Roghnaithe

FINALLY! Thanks Cor-el!!!

I put dom.w3c_touch_events.enabled as 0 and it fixed it. I didn't change dom.w3c_touch_events.expose.

Crazy little issue but I'm so glad it's fixed now. Thanks to everyone!

more options

Had the same problem, but with Firefox v22.0 on a 2013 laptop build with Win 7 Pro 64-bit SP1. Thanks to @TrinityFire for posting the problem and to @jscher2000 and @cor-el for procedures and the fix! Being a neophyte on fixing any Firefox or other code, I hope I didn't damage any other programming on my system.  ;-)

Again, thanks!