Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How can I prevent Firefox from going back to the previous window, as soon as I open a new window?

  • 19 freagra
  • 13 leis an bhfadhb seo
  • 8930 views
  • Freagra is déanaí ó pan-firefox

more options

In recent versions of Firefox, every time I open a new window, as soon as the window opens, Firefox goes back to the previous window, the one that was on screen before I opened the new window. This is very irritating, and didn't happen in older versions of Firefox.

Any suggestions how to fix this? Thanks!

Réiteach roghnaithe

FYI, this is not a threaded forum, so all replies appear at the bottom...

dom.disable_window_flip is a true/false preference that determines whether a script in a web page is allowed to change focus between Firefox windows (typically, bring itself to the front, or pop-under by bringing the window from which it was opened to the front).

By default, this preference is set to true to disable websites from moving windows around, but it's possible that setting was changed. To view/change this preference, you can use the about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter search box that appears above the list, type or paste flip and pause while the list is filtered

(3) Double-click dom.disable_window_flip to switch it between true and false.

Edit: Corrected per the post below.

Read this answer in context 👍 3

All Replies (19)

more options

There's a good chance this is related to a bug that kicks in when you do not have Flash running in any tab and you open a new window to a page that does use Flash. The details and known workarounds are in this thread: Opening New Windows and Shockwave Flash.

more options

Try Firefox Options > Tabs.> When I Open........ While this says tabs, maybe this can help. When I call for a new window, I get moved to the new window.

more options

I've determined that it's Schockwave Flash that's causing this on my computer. As long as I disable that plugin, when I launch a new window, it doesn't revert to the original window.

But then, of course, I can't watch most videos online. C'mon Adobe and Mozilla. Get it together and fix this problem!

more options

And it happens when opening windows to most pages (almost always, not not every single time), not just ones that use Flash.

more options

Does this pref (about:config) have any effect: dom.disable_window_flip ?

more options

Thanks for the suggestions. I don't want to try it, but I'd be really interested in hearing from others who've tried the dom.disable_window_flip method of dealing with this enervating problem.

more options

Meant to insert a comment regarding flash suggestion, but put it here by mistake.

Athraithe ag sage1 ar

more options

I have no idea what you are referring to or how to impliment what you are mentioning. If you can explain how to try it for a non-techie, I'd certainly be interested and grateful.

more options

Same with me, flash solution does not solve the problem.

more options

Réiteach Roghnaithe

FYI, this is not a threaded forum, so all replies appear at the bottom...

dom.disable_window_flip is a true/false preference that determines whether a script in a web page is allowed to change focus between Firefox windows (typically, bring itself to the front, or pop-under by bringing the window from which it was opened to the front).

By default, this preference is set to true to disable websites from moving windows around, but it's possible that setting was changed. To view/change this preference, you can use the about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter search box that appears above the list, type or paste flip and pause while the list is filtered

(3) Double-click dom.disable_window_flip to switch it between true and false.

Edit: Corrected per the post below.

Athraithe ag jscher2000 ar

more options

Jscher

Your solution worked, thanks! I had some difficulty deciphering what you meant me to do, but figured it out.

For anyone else who wants to use your solution, in step 2, "the filter box" is the place near the top of the screen where you search for a term you want to find in the long list below.

more options

I've further determined that Facebook has something to do with this mess, surprise, surprise. Altering the flip config did the trick (thank you, jscher2000) for all but Facebook links. Hmm. More mystery.

more options

dom.disable_window_flip change didn't work for me. Also I have the latest versions of java, Schockwave, Flash installed. I use the Firefox 24 on a Windows 8.1 OS.

more options

Update: I have just updated to Firefox 25. Same problem: Firefox is going back to the previous window, as soon as I click on a link to open a new window. The new window still opens but the focus is turned to the previous one. This is just frustrating. So Mozilla has done nothing to resolve this problem so far. Note that I don't use tabs. I have chosen to open links in new browser windows instead.

Athraithe ag pan-firefox ar

more options

Hi pan-firefox, did you just update to Windows 8.1? How is that going in general?

The change of window focus could be a problem with the protected mode of the Flash Player plugin. Could you check the following thread and see whether that helps: Opening New Windows and Shockwave Flash.

more options

Sadly, I tried the keeping-a-Shockwave-page-open method awhile ago, but it didn't work. I'll try disabling Shockwave. Thanks for the suggestions!

more options

Disabling Shockwave's protected mode did the trick. Apparently, my system's security is a bit lessened, but the flipping between windows was making me about ready to smash my computer, so my laptop is actually safer.

more options

Hahahaha

more options

I disabled flash protected mode and the problem seems to have been solved. Please hackers don't attack my PC now, OK?

PS. Windows 8.1 upgrade from 8.0 went smoothly. I didn't notice any difference from the previous version though. I also had a minor problem with the desktop wallpaper which was lost after the update.