Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox freezes entire system then everything resumes running again

  • 59 freagra
  • 46 leis an bhfadhb seo
  • 63 views
  • Freagra is déanaí ó drakaran

more options

As above.Started occurring since v20 came out.Seems like many people have this error.

Reverted to v19.Problems occurs as well.

Tried everything ( starting FF in safe mode , creating a new profile, resetting FF, uninstalling and a fresh install, booting in safe mode Windows). Nothing seems to work.

It freezes again and again only to resume normal service only to freeze again. On and on and on. Really frustrating.

Can someone point to me if this FF's problem or is there a problem with my system itself?

My system doesn't seem to freeze when FF isn't running though.

Réiteach roghnaithe

Hi all.Thought I'd share my revelations on my problem

For my case, it was a result of my system not running 8 cpu processors,basically causing FF to run like a snail. FF runs fine now in general, still a little sluggish sometimes but by and large the freezes have stopped.

On a more serious note, I need to figure out what or why my system was running on 1 processor. Could be a malware or virus of sum sort. Need to suss it out more. I've never ever changed my cores ever on my system. Took me a while to get around this possibility though. I guess it's something worth looking at from another angle.

Cheers

Read this answer in context 👍 0

All Replies (19)

more options

I changed procesor, graphic card and RAM in my computer, reinstaled windows to Win 7- 64 and I have same problem with my FF. At first after starts FF, my computer starts BSOD. I am reinstall FONTs in my computer and everything seems OK, but after 1 hour testing, PC frozen. I don´t know where is the problem. Thanks everybody in advance for help. Sorry for my engish :-(

more options

Hi rsuchan, do you still get the blue screen crash? If so, as the first step, please start in Firefox Safe Mode and disable Firefox's use of hardware acceleration for graphics.

  • Hold the Shift key when starting Firefox to start in Safe Mode. Or if Firefox is already running, use Help > Restart with Add-ons Disabled. In the dialog, click "Start in Safe Mode" (not Reset).
  • To disable hardware acceleration: orange Firefox button (or Tools menu) > Options > Advanced > "General" mini-tab > uncheck the box for "Use hardware acceleration when available". Then restart Firefox.
more options

Hi Jscher2000. I am reinstall FONTs in windows and now I dont get BSOD. But I try your settings on afternoon. Thank you for your answer.

more options

@StevenCee : I apologize, I removed it after I read it because I realized I came across wrong. I wrote what I said in the heat of the moment. So once I calmed down I re-edited my statement. I figured I might as well keep it simple and to the point.

EDIT UPDATE 1 : I found out that my logitech mouse might be interfering with firefox. I'm going to try another mouse and see what becomes of this.

EDIT UPDATE 2 : Well, this is interesting. Not sure why.. but everything is fine when I swapped mice. Why or how Firefox interferes with my Logitech mouse I am not sure. But, so far, my HP USB Mouse is working fine. I am going to see if this has to do with drivers. But, this brings me to another point.. Why firefox ? What is it in FF that disrupts the mouse ? I still am trying to solve this.

EDIT UPDATE 3 : Sure enough, its the logitech optical mouse. Again, I do not understand what Firefox has to do with this. But I only got the freezes when I installed firefox. I tested for 24 hours without firefox and never once froze up. ( NOTE : This was a test a couple weeks ago. I didn't put two and two together until now. ) Anyhow, since I have updated my logitech with it's newest drivers instead of using the default Microsoft mouse drivers, we will see if this works. In 24 hours I'll try to post an update. What's interesting is my HP USB mouse worked with no lock ups. So fingers crossed on the logitech.

EDIT UPDATE - Final Entry : Well that logitech mouse driver vs firfox was the issue. I updated the mouse drivers yesterday and ever since then, my computer has ran pretty smooth with no lock ups. Go figure... a mouse driver. Anyhow, hope this helps someone else whom might be in the same boat as I was in.

Athraithe ag JackDawson69 ar

more options

This turned out to be my problem as well (the Logitech driver), and fortunately updating the mouse driver worked here. Windows 8 64 Logitech g400 mouse.

Thanks so much for noodling this out. I was starting to miss FF.

Athraithe ag drakaran ar

more options

Glad it was helpful to you. Yea I have not had a problem ever since I updated from the MS drivers, to the real logitech drivers. Still not sure why FireFox vs the MS drivers was the issue, but it works.

Cheers

more options

I actually was using the Logitech drivers already, but when I updated to the latest version it fixed the problem.

Good question as to why. It doesn't make any sense to me. I'm just glad FF is okay again.

more options

Just wanted to say that I updated my Logitech trackball M570 drivers to the Logitech Setpoint software, instead of relying on the Windows 7 universal driver and now I'm not getting the freezing issue. Also - before that, I noticed I was getting usage of around 800k in memory for 4-5 tabs being open, now it's dropped to 500k (less).

Windows 7 64bit Home Premium, Mozilla Firefox 23.0.1 8GB ram Logitech Setpoint trackball drivers for M570.

more options

Ok, so the problem is still there. The browser still locked up today, but only a few times. The bigger issue is that there is now a stuttering delay effect when typing anything into Firefox - browser bar or even a web-embedded text box (like a forum or any web page; including submitting this post here!).

This stuttering issue isn't present at all when using the laptop's native keyboard and trackpad, but when using my wireless keyboard and trackball it's annoyingly present.

Getting very frustrated and looking at Chrome more and more because none of these issues are evident with Chrome, even when browsing the same exact websites.

more options

I think it was the last update to FF (23.01) that did it because my FF was stable for a while, and then suddenly was at it again. So..... back to Chrome *ugh*

more options

@drakaran - I believe you're right. I think FF23 has a memory bug in it as well that inflates when it encounters non-native input devices. I don't know enough about debugging to really help though.

Don't want to use Chrome either as I love all my FF extensions and plug ins... but...

more options

Historically, Firefox wasn't aware of what mouse you used and relied on the driver to either send the traditional 2-button 1-wheel inputs or if there were extra buttons, keystrokes that triggered the functions of those buttons (e.g., forward and back). This led to lots of complaints about lack of device-specific support.

Recently, Firefox has started supporting touch and gestures. I wonder whether this problem is related to that? You could disable some of that and see whether it makes a difference. I have no idea, but you wouldn't be losing anything if you don't have a touchscreen.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste touch and pause while the list is filtered

(3) Double-click dom.w3c_touch_events.expose to switch its value from true to false.

(4) If ui.touch.radius.enabled is true, double-click it to switch its value to false.

more options

So I tried doing a few other things today. I have a shielded HDMI cable that is right by the Logitech unifying receiver on my laptop - I moved that receiver to a USB port on the opposite side of the computer, and hey presto, the stuttering went away.

I had also found that copying and pasting was impossible and even in Chrome I was experiencing useability issues.

Looks like so far, after a solid 3 hours of working, that the culprit wasn't the browser or the wireless devices but the proximity of the receiver to the HDMI cable.

WEIRD.

more options

I have a wired g400 logitech mouse, so that's not my problem, but thanks for the input.

more options

I know this sounds way too easy, but whenever FF freezes or 'checks email' too slowly, my Display number is to high (like ALL). Set it down 40 and give it another try.

more options

What do you mean by your "Display number"? Set what down 40?

more options

I tried your suggestion with the about:config but there is a number there... "2". I'm betting the "false" response is "0" so I'll try that.

more options

Hi drakaran, yes, there are two similar-sounding touch preferences in about:config:

  • dom.w3c_touch_events.enabled => 0=disable, 1=enable, 2=auto-detect (default)
  • dom.w3c_touch_events.expose => true (default), false

If you experiment with either, both, or different combinations, it would be really useful to get your feedback on whether they have any effect for you.

more options

jscher2000: no, I only have dom.w3c_touch_events.enabled. The other one is not in my config file. I did a search and also just scrolled down, just in case.

I am using FF 23.0.1 for Windows (Windows 8 64 bit OS.. if that makes a difference).

It hasn't frozen so far after changing that setting so far. I'll find out with time. I'm sure.

  1. 1
  2. 2
  3. 3