Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox constantly crashing...

  • 13 freagra
  • 8 leis an bhfadhb seo
  • 3438 views
  • Freagra is déanaí ó cccarter69

more options

Hi,

I've been using Firefox for man years, on all my devices.

But since yesterday, on my main PC, Firefox crashes constantly.

It appears to be random, on various sites, at various times (ie 10 seconds after restarting, or 10 minutes after restarting).

I have tried:

- Resetting Firefox. - Reinstalling Firefox. - Disabling/re-enabling extensions or plugins (though I don't believe I updates any since yesterday when the crashing started).

It's really annoying, and I've had to use Chrome (gulp) today. :-(

Réiteach roghnaithe

Thank you.

I updated it, but it was still crashing.

I've now removed it and Firefox no longer crashes.

Read this answer in context 👍 0

All Replies (13)

more options

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.


Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

Would malware be picked up Comodo Internet Security?

Because I ran a full scan as soon as this started happening, but it found nothing.

Thank you.

more options

you can once try above mentioned programs and let us know that worked or not.

more options

Hi,

I have:

'No Malicious Items were detected'.

more options

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!

Thank you.

more options

Unfortunately that hasn't worked.

I first disabled hardware acceleration...but still got crashes.

Then updated my display drivers (they were out of date), but still got crashes.

This is what appears in the Mozilla crash report:

AdapterDeviceID: 0x6738 AdapterVendorID: 0x1002 Add-ons: %7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:20.0.1 AvailablePageFile: 14274547712 AvailablePhysicalMemory: 6446030848 AvailableVirtualMemory: 3850579968 BuildID: 20130409194949 CrashTime: 1367411368 EMCheckCompatibility: true FramePoisonBase: 00000000f0de0000 FramePoisonSize: 65536 InstallTime: 1367408644 Notes: AdapterVendorID: 0x1002, AdapterDeviceID: 0x6738, AdapterSubsysID: 03ae1043, AdapterDriverVersion: 12.104.0.0

ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384} ProductName: Firefox ReleaseChannel: release SecondsSinceLastCrash: 614 StartupTime: 1367411116 SystemMemoryUsePercentage: 24 Theme: classic/1.0 Throttleable: 1 TotalVirtualMemory: 4294836224 URL: http://www.hotukdeals.com/ Vendor: Mozilla Version: 20.0.1 Winsock_LSP: MSAFD Tcpip [TCP/IP] : 2 : 1 :

MSAFD Tcpip [UDP/IP] : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
MSAFD Tcpip [RAW/IP] : 2 : 3 :  
MSAFD Tcpip [TCP/IPv6] : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
MSAFD Tcpip [UDP/IPv6] : 2 : 2 :  
MSAFD Tcpip [RAW/IPv6] : 2 : 3 : %SystemRoot%\system32\mswsock.dll 
RSVP TCPv6 Service Provider : 2 : 1 :  
RSVP TCP Service Provider : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
RSVP UDPv6 Service Provider : 2 : 2 :  
RSVP UDP Service Provider : 2 : 2 : %SystemRoot%\system32\mswsock.dll

This report also contains technical information about the state of the application when it crashed.

more options

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash ID's to help us learn more about your crash.

  1. Enter about:crashes in the address bar (that's where you enter your website URL) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the 5 most recent crash ID's that you see in the crash report window and paste them into your response here.

Thank you for your cooperation!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

more options

I only have two at the moment, due to not submitting, here they are:

bp-86695739-b3e8-4213-878c-c0d1b2130501

bp-827ff31c-16dc-4112-85a3-ac05f2130501

I will post the next 3 when I get them.

Thank you for your help. It is very frustrating for me as I love Firefox but obviously can't really use it at the moment.

more options

The next 3:

bp-74a8a45c-3007-4ba5-a04e-7033f2130501

bp-5d9a632f-a4ba-419e-af62-e4a002130501

bp-e44540ed-193d-4e9e-b9a9-fa21b2130501

more options

you are using a old version of trustier(3.5.1208.34 or later) please update it and if it is not being updated uninstall it.

more options

That is a problem with Trusteer Rapport

Try to update or uninstall and reinstall Trusteer Rapport and if that doesn't help then disable/stop the program for now.

Start Menu > Programs > Trusteer Rapport > Stop Rapport

more options

Réiteach Roghnaithe

Thank you.

I updated it, but it was still crashing.

I've now removed it and Firefox no longer crashes.

more options

I have also had this problem for about 2-3 weeks and it crashes up to 5+ times a day. It is really frustrating. I have sent the report in every time, but I never get a reply. I have also sent emails and those remain unanswered as well. I have tried all the different solutions, but they haven't worked. I am running Firefox 21. I have noticed as well that it is having issues since the last upgrade. How do I switch it back to a previous version?? Please help, I hate using IE or Chrome.