Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox asks too many questions when opening download docs from court websites, won't let me select a preferred program, and questions document certificate.

  • 8 bhfreagra
  • 2 leis an bhfadhb seo
  • 590 views
  • Freagra is déanaí ó litterbug

more options

I'm a lawyer and routinely download case documents from legal databases and many other websites with no problem.

Up until recently I would click on a document link and Firefox would open the document up. At worst, Firefox would not recognize the file type, but once I told it to use the selected program for that file type, it had no problems. In particular, the court databases save scanned or converted PDF documents as a type called "File", which means I've had to save the program preferences.

Sometime in the past month or so, Firefox stopped cooperating. I admit that I downloaded some add-ons and tweaked some settings, but I've now uninstalled or disabled everything but the most trustworthy add-ons, and nothing looks weird in my settings. Nevertheless, the following now happens when I click on a link to an electronic document:

1. The document is downloaded. 2. I click on the download arrow and double-click on the document 3. A window comes up asking "do you want to open this file?", says it's an unknown file type, and "While files from the Internet can be useful, some files can potentially harm your computer..." and shows a checked box saying "Always ask before opening this file." 4. I either hit OK to open it or uncheck the box and hit OK. 5. Then the "Open with" window comes up. However, the box to always use the selected program is greyed out no matter what program I choose, so each time I do this I have to go through this window. 6. If didn't uncheck the box in step 2, another window comes up asking me again if I really want to open the file. 7. Finally, the document opens but across the top it says "the validity of the document certification is UNKNOWN. The author could not be verified.

All of these files save as type "File," all are PDFs, and all open straight away in Chrome and Explorer. I love Firefox, but I access these databases all the time and need to avoid these hassles with downloads.

Réiteach roghnaithe

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


You can delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.


Current Firefox versions have enabled a built-in PDF Viewer that doesn't have all features that other PDF readers like the Adobe Reader have or may not function properly otherwise.

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications".

Read this answer in context 👍 1

All Replies (8)

more options

Sorry, meant to say that this only happens with court databases. As far as I can tell, I can download from other sites with no trouble.

more options

Instead of opening from the Download Panel, could you click the icon at the far end of the entry to Open Containing Folder and launch the PDF from there? Does that bypass the warnings or do you still get them?

more options

That doesn't get me past the warnings. I've tried right-clicking on the icon, too. Sorry!

more options

Hi litterbug, Firefox can embed source information into a file so that it is opened in compliance with your Windows OS security policy. To prevent Firefox from embedding that information, you can turn off integrated virus scanning. (I know, they sound completely unrelated, but that's how it works.) To do that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) Double-click browser.download.manager.scanWhenDone to switch it from true to false. Note that this does not affect your real-time antivirus protection, it only stops Firefox from manually submitting the file for scanning and marking the file as downloaded from the internet.

On your next download, do you get fewer warnings when trying to open the file?

more options

Thanks, jscher! That gets me two less clicks, and they were the most annoying ones. I still have to go to the download and manually open it, it doesn't let me set Adobe as the default application for that file type, and opens the document up with the notice at the top of the screen that it doesn't have a valid certificate, but I can live with that. It was having to click to download, double-click on the download, click to uncheck the box, click open, then click to approve Adobe to open it that was driving me crazy.

Chrome, in contrast, opens the document in a window called CaseSearchServlet with one click in the court's popup window called CaseSearchServlet, and a "save as" pulls up Adobe as the default application. My guess is that Chrome isn't as security-conscious as Adobe. I should be grateful, right? But the court systems are quite secure, so I'm not worried about the PDFs I download there. I might check with our IT guy to see if there's a setting I can change that will give me my one-click document views back in Firefox, but if I get really annoyed I can always use Chrome instead.

If you think of a way to get rid of any other steps be sure to let me know.

more options

The immediate solution would be for the website to fix the way it is naming downloaded files... but I'm not holding my breath.

I'm not sure why this behavior would have changed for you recently. If you have IT download a portable version of Firefox 19.0.2 -- it's an unofficial stand-alone installation you run from the download folder after installation; doesn't run simultaneously with your main install -- do the same downloads work in that version? PortableApps.com: Mozilla Firefox, Portable Edition 19.0.2 at SourceForge.net

more options

Réiteach Roghnaithe

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


You can delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.


Current Firefox versions have enabled a built-in PDF Viewer that doesn't have all features that other PDF readers like the Adobe Reader have or may not function properly otherwise.

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications".

more options

Hey, cor-el's solution fixed the rest of the issues! I changed the PDF action settings from opening the PDF in Firefox to opening it in Reader, and now I'm back to opening linked docs with one click. Thanks to you and jscher my days are just a tad less irritating.