Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

I'm unable to change my homepage, i have tried resetting firefox , also re-installed it ,and also edited 'user.js' file. Still the problem continues.

  • 9 bhfreagra
  • 13 leis an bhfadhb seo
  • 7923 views
  • Freagra is déanaí ó cor-el

more options

OS  : windows 7 firefox current version : 20.0.1


and homepage is getting set to : http://india4you.info/

Athraithe ag akshaysp ar

Réiteach roghnaithe

thank you guys for your suggestions.

finally i got rid of that problem.

I emptied the 'user.js' file ,and changed it to 'Read Only' and also made 'prefer.js' file to 'Read Only'. And used 'Reset Firefox' option.

Read this answer in context 👍 0

All Replies (9)

more options

hello akshaysp, please try to totally delete the user.js file, since it isn't present normally & shouldn't be unless you personally added the file.

How to fix preferences that won't save

afterwards you can install the search reset addon - it will revert the most common customizations those adware programs do in firefox back to the default: https://addons.mozilla.org/firefox/addon/searchreset/

more options

thanks Philipp for immediate response and solution :)

'search reset' worked successfully .

more options

hi again,

my problem again reverted..... and recently,i haven't installed any new soft-wares also.

what to do???

more options

Do you have a new user.js file?

Can you think of any other software you installed before this problem started, especially free software? Windows software can reach into your Firefox settings and make changes.

more options

you also might want to run a full scan of your system with the security software already in place and different other tools like the free version of malwarebytes & adwcleaner.

more options

Try to create a user.js file and set this file to read-only if you have this file again in the Firefox profile folder.
Make sure that it is a .js file and doesn't get a hidden .txt file extension.

more options

Réiteach Roghnaithe

thank you guys for your suggestions.

finally i got rid of that problem.

I emptied the 'user.js' file ,and changed it to 'Read Only' and also made 'prefer.js' file to 'Read Only'. And used 'Reset Firefox' option.

more options

Please be aware that making prefs.js read-only may block you from saving some changes you make through Firefox's UI.

more options

You will likely end up with a lot of numbered prefs-##.js temp files if you make prefs.js read-only, so you should at least reconsider making this file read-only as well.
Also the prefs.js file stores time stamps, so Firefox knows when a check has been done and a next check is needed (e.g. places cleanup).