Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

"@font-face" problem only with firefox. I have attached a style sheet while i was embedding my personal fonts into a website, but Firefox won't load them. Why?

  • 3 fhreagra
  • 129 leis an bhfadhb seo
  • Freagra is déanaí ó AinStain

more options

I was hand coding my new website. This time i was trying to embed some personal fonts into my website, so i used a style sheet to embed which is coded like "@font-face { font-family:Sofia; src:url(../fonts/Sofia-Regular.otf); }

All the font work fine in the root folder of my site. But whenever i am creating dreamweaver templates and using them on pages which are in different folders but in the same root directory, the fonts are set back to default font. This problem is only with Firefox. Chrome, IE, Opera etc. works fine. Please Help!

All Replies (3)

more options

You can check the "Web Developer > Web Console" (Ctrl+Shift+K) or Error Console for errors.
You need to do a hard reload (Ctrl+F5) to see if there are security issues with downloading the font.

more options

I think this is a security restriction in Firefox.

If you have a page at file:///<somewhere>/pages/mypage.html, then you can only load fonts located in file:///<somewhere>/pages or below. So, for example, if the fonts are in file:///<somewhere>/fonts, they won't load, but if they are in file:///<somewhere>pages/fonts, then they should work. At least, that's how it seems to work for me.

more options

i run into the same problem the last days. using bootstrap and the fontawesome iconfonts. everythings fine with chrome an ie, but no fonticons with firefox... found alot of solutions, but none of them worked. then, using the webdeveloper console (i used firebug all the time before) i see the error why the webfont was not loaded:

[14:18:36.161] GET [HTTP/1.1 401 Authorization Required 21ms]

yes, the site is behind a htaccess login. first load after login is => everything ok! after following an internal link => no webfonts!

after disabeling the htaccess login, everything works fine! but that can only be a workaround! why firefox didnt recognize the login/authorization like chrome does?!

what todo if you have your site behind htaccess and want to use webfonts?!

Athraithe ag AinStain ar