Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Whenever I try play a .swf file from my computer in Firefox it brings up the download option (ie Open or Save) won't play the file. How do I fix this?

  • 4 fhreagra
  • 28 leis an bhfadhb seo
  • 17359 views
  • Freagra is déanaí ó Spiral_One

more options

As above, no matter what I choose I can't play .swf files in Firefox reliably.

Some of them seem to sometimes work but in general it doesn't work.

All Replies (4)

more options

Firefox uses Flash Player which is is a browser plugin. It's not designed to work as a standalone app for opening FLV or SWF. If you want to play them you should first download them.

more options

What happens with this swf file?

For me, on Windows 7 in Firefox 19 it displays the swf animation in a Firefox browser tab. If it doesn't wok for you, go to Firefox (button) -> Options -> Applications and search through the list of content types (see Change what Firefox does when you click on or download a file for detailed help).

Do you see anything set for SWF files, Shockwave Flash or application/x-shockwave-flash ? You shouldn't but if you do, you may need to reset your Firefox download actions by deleting or renaming the mimeTypes.rdf file in the Firefox profile folder (or by resetting Firefox). Ref:

Athraithe ag AliceWyman ar

more options

Note that your system details list is showing two Flash plugins.

  1. Shockwave Flash 11.6 r602
  2. Shockwave Flash 11.2 r202

You should remove the older 11.2 r202 version.

See also "Manually uninstalling a plugin":

more options

I'm on a Mac 10.8.3 and here's what I had to do in Firefox 20:

  • Goto Firefox 'Preferences'
  • Click on 'Applications' on top tool bar
  • Scroll Down to 'Media Files' [mine was default to 'Always Ask'] on the right hand side.
  • On the Right side click on the menu and SELECT 'Use Shockwave Flash (in Firefox)'

Don't know IF you have to but I Restarted Firefox and now the SWF files worked in a tab. Good luck....