Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox 17.1 hangs up on every use of the flash player

  • 4 fhreagra
  • 9 leis an bhfadhb seo
  • Freagra is déanaí ó muggle2

more options

I have activated 'click to play' for plugins at the moment (by about:config). Whenever i click on a flash area in a website, my browser hangs up.

My browser is Firefox 17.0.1 (don't know, if the problem existed even with version 17.0). Firefox 16.0.2 is working properly with the same Flash plugin (current release by 26th, December, 2012).

My browser version is the official version, which is downloadable from the Firefox website at any time (and not the repository version from Ubuntu 12.04) and the flash plugin is saved in the 'plugins' subdirectory, as usual. (Firefox also hangs up with deactivated add-ons in safe mode, as plugins aren't deactivated in this mode)

Athraithe ag FirefoxUser2971 ar

All Replies (4)

more options

Does this still happen if the Flash plugin is disabled as a test?
Does toggling click-to-play has any effect?

Note that Safe mode disables extension, but doesn't disble plugins.
Also note that click-to-play is still not fully implemented in the current Firefox release, so enable and use it at your own risk.

Are the crash reports related to the Flash plugin or plugin-container process?

If you have submitted crash reports then please post the IDs of one or more crash reports that have this format:

  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

You can find the IDs of the submitted crash reports on the about:crashes page.

  • You can open the about:crashes page via the location bar, like you open a website.


more options

If I disable Flash completely, I can't 'click to play' on a Flash area and thus no hang-up happens of course. If i switch off 'click to play' in the settings, Firefox hangs up whenever a Flash application is activated, i.e. on every start in my case (i have app tabs with Flash, which are reloaded every time). There are no crash reports stored related to those hang-ups.

I just realized that my browser uses the flash plugin from my operating system, not that one, which I provided Firefox. Is there any way to change that (without uninstalling the existing one) ?

edit: With the 'official' version of the Flash player, which I provided, Firefox is working properly with 'click to play' and Flash, as before. (I just uninstalled the repo version)

Thanks a lot!

Athraithe ag FirefoxUser2971 ar

more options

You can create a plugins folder in the Firefox Profile Folder and copy the Flash plugin or a symlink to the file in that folder and enable that Flash plugin and disable other Flash plugins (Tools > Add-ons > Plugins).

Other possible locations are a plugin folder in the .mozilla folder (/home/<user>/.mozilla/plugins)

more options

As always.. CREATE A RESTORE POINT ..! and BackUp Firefox First..!

Adobe itself recommends disabling Protected Mode until a fix comes,to resolve the issue. (YEEAAhh ....RRrrriiggghtt!)

To disable Protected Mode: You need to edit the mms.cfg file located in one of the two directories:

   Windows 32bit: C:\windows\system32\macromed\flash
   Windows 64bit: C:\windows\syswow64\macromed\flash

Just open the file with a text editor [notepad] and add the following line = to the mms.cfg file:

ProtectedMode = 0

If the file does not exist [mms.cfg], create it first.using any standard text editor (e.g.. notepad)

Please: note that Protected Mode has only been enabled on Vista or newer versions of Windows.

Disable plugin-container.exe \ in Firefox.... Adobe Flash, Apple QuickTime (Windows) and Microsoft Silverlight (Windows).

These plugins are specified in a separate dom.ipc.plugins.enabled.<filename> preference by default is set to true. Disable them by changing their value to false.

about:config [dom.ipc] =false dom.ipc.plugins.enabled =false

IF: dom.ipc.plugins.flash.subprocess.crashreporter.enabled which is set at "true". toggled the value to "false". dom.ipc.plugins.flash.subprocess.crashreporter.enabled = false

Disable Plugin-Container in Windows (A&B)::: GoTo:::

Control Panel..>>

..System ..>>

.. Advance ..>> .. Enviormental Variables ..>>[Bottom-Button]

..System variables (User variables\Panel) ..>> 


Add..>>...A...& ...B variables...

A.) ..NEW.. Variable Name: MOZ_DISABLE_OOP_PLUGINS Variable Value: 1

B.)..NEW... Variable Name: MOZ_CRASHREPORTER_DISABLE Variable Value: 1

Restart windows...

Note: Some videos will still buffer slow.. Quick fix .. Scroll (Continuously) mouse pointer on time line.... to improve that particular video's buffering..

BTW:.. Firefox is not the problem...

Microsoft, Google and Adobe (Flash Player) have made surfing the Free Internet a Nightmare with very intrusive programs and cookies for advertising profits..., which are the main culprits of troubles with Internet usage and create backdoors for spyware...  

Keep Firefox Clean & Healthy & Fast..!!

Add:ON = Favorites..

Memory Restart \1.11 ( A must have)

RAMBack \ 1.0

Flashblock \

Ghostery \ 2.9.3

RefreshBlocker \ 0.8