Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Enabling custom cookie handling kills facebook dropdowns

  • 5 fhreagra
  • 3 leis an bhfadhb seo
  • 243 views
  • Freagra is déanaí ó Legacy2000

more options

Hi,

I'm using firefox for several years, but recently i discovered a weird effect on one of my computers, which was consistent across many FF versions (up to the recent version 17 now). All drop down menus on facebook were not working for me. On one pc I can click on the red globe, and a menu opens - while on the other pc nothing happened. Now I was able to reproduce it.

As soon as I activate the "ask how long cookies are stored" option in the privacy settings, the drop down menus wont work/show. Choosing the default "Keep them as long as they are valid" reenables the drop down menus.

I really like the cookie storage time option so i can decide which website will remember me.

Réiteach roghnaithe

You can remove a possible cookie exception for www.facebook.com and create an exception for facebook.com instead to include all facebook domains.

Read this answer in context 👍 2

All Replies (5)

more options

Réiteach Roghnaithe

You can remove a possible cookie exception for www.facebook.com and create an exception for facebook.com instead to include all facebook domains.

more options

This works. I had www.facebook.com and pixel.facebook.com allowed and no other request appeared. I would guess that pixel and www wanted to access the same cookies but the cookie handling in FF blocked that "cross url" cookie access.

more options

I have been having this same problem too. I've tried disabling all my add-ons/plugins, but it hasn't helped. I added back just Java, but that did not help. I have also added an exception for facebook and pixel.facebook.com, no dice. It does work correctly in my IE.

I have also run malware scans (GMER), nothing shows up. If I set it back to remember history, removing the custom options, it works.

Any other suggestions?

Thanks in advance!

more options

@txkttn77 Remove you exception for "www.facebook.com" and "pixel.facebook.com" and manually add one for "facebook.com" (without subdomains).

more options

cor-el, a million thanks.

I just wish I had found this thread earlier - I just spent a day trying to figure this out (including resetting and re-installing Firefox) only to find that it worked for a few minutes and then broke again. Doh.

Occam's razor wins again.