Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Personas no longer showing up when i hover over them.

  • 8 bhfreagra
  • 6 leis an bhfadhb seo
  • Freagra is déanaí ó ybodon

more options

So they used to work, when i went to change my persona it'd preview it on my window when i hovered over it, I recently updated firefox and now it wont preview the personas when i hover over them. I made sure cookies are allowed but even when i click on "wear this" it asks permission with an 'allow' button. How do i fix this, i cant find it.

All Replies (8)

more options

Previewing a persona only works on sites that are white-listed via an allow exception, so make sure to have an allow exception for the domain.

You can see the permissions for the domain in the current tab via the about:permissions page or one of these:

  • Tools > Page Info > Permissions > [X] Install Extensions or Themes
  • Tools > Options > Security : "Warn me when sites try to install add-ons": Exceptions
  • Press the F10 key or tap the Alt key to bring up the "Menu Bar" temporarily if the menu bar is hidden.
  • Use "Firefox > Options" instead of "Tools > Options" if the menu bar is hidden.

Make sure that you do not use Clear Recent History to clear the "Site Preferences".

more options

I tried

 Tools > Options > Security : "Warn me when sites try to install add-ons": Exceptions  ;

And its still not working. And i dont clear recent history. Any other options?

more options

Try to set an exception for the main domain.

You can reset these prefs on the about:config page to restore the default software exceptions for installing extensions and personas.

xpinstall.whitelist.add  (
xpinstall.whitelist.add.36 (

If these prefs do not exist or are an empty string if you open the exception window then the corresponding default entry is recreated.

Athraithe ag cor-el ar

more options

Well i already did the getpersonas one. And i just tried the other one and its still not working. and this is in the Tools > Options > Security : "Warn me when sites try to install add-ons": Exceptions  ; ____________________

more options

Try to rename or remove the permissions.sqlite file that stores the exceptions in case there is a problem with the file.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

You will have to redo all exceptions if you do this.

more options

Yo! Non-idiot here so don't treat me like one please.

I've done all of these things(multiple times) and none of them worked. I have every single mozilla url in my exception list including exceptions with wild-cards added for any sub-domain.(example: *

Yes I disabled clearing of site preferences. Yes I added the exceptions. (Some for URLs probably not needed.) Yes I deleted permissions.sqlite Yes I did everything over again after deleting permissions.sqlite Yes, I actually did do everything!

Other issues I ran into while attempting to fix this issue!: I've also had to add so many security certificate exceptions for the mozilla website(s) just so that the styles(.css files) would load so I could attempt to browse your sites for an answer. Trying to create an account and login also resulted in me having to add a few security certificate exceptions. I've basically disabled all security features of your browser now because if I can't browse your websites without problems when they're enabled I can't imagine how frustrating browsing the rest of the net will be.

The build I'm using is whatever is on the getfirefox page today; I had to switch from Chrome back to Firefox today due2 overwhelming issues with their browser(an odd Explorer.exe dependency) only to find that there are now overwhelming issues with Firefox!

I attempted to login and reply to this question using Firefox to let you know that none of these "fixes" work...only to be logged out of my mozilla account whenever I clicked any links on the page that follows logging in. I was also logged out if I copy/pasted the URL to this question into the address bar and hitting enter after logging in. If you're not following along this means I did this: Logged in->Came here and noticed I was logged out->tried again->same outcome->rinse & repeat until supremely frustrated.

I'm typing this reply on Opera, a browser I never thought I'd end up using. 'bout ready to resign from the entire internet.

I apologize if you feel this is overly harsh but I'm usually pretty good about fixing issues by myself and so I'm extremely frustrated with all of this.

I hope PDXnative83 did not end up as red in the face as I am.

Good luck, or whatever, mozilla devs.

more options

When you are on that website then you can click the Site Identity Button (globe/padlock) on the location bar and proceed via More Information to the Permissions tab of Page Info.
Then you can verify if that site is allowed to install software.

Note the the Personas have been transferred to the Add-ons site that already host extension and (complete) themes.
So you likely need an exception for the domain.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
more options

Neat I can actually reply on here now that I've disabled ALL available security functions. Problem NOW is that I can't disable the whole "OMG THIS IS HURR DURR AN UNTRUSTED CONNECTION" bullcrap at all. Which is hilarious since I was trying to access another domain when it happened.

None of your "fixes" helped cor-el. I respect you trying to help, I really do...but nope. I don't blame you.

Honestly Mozilla your developers are either confused as hell or just complete garbage right now, I don't know what is going on but it's completely backwards and, if you'll excuse political correctness and actually take to heart the definition of the word, it's retarded.

I've found an alternative browser. Good luck fixing your bantha fodder browser where EVERY SSL CONNECTION(including your own domains) are untrusted.

P.S. my clock is 100% accurate and up to date, if you try to use that as an excuse I will be so angry.

Athraithe ag ybodon ar