Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How to prevent the change of Home page everytime I start Firefox? Claro search starts everytime I start firefox even when I change the default Home page

  • 3 fhreagra
  • 15 leis an bhfadhb seo
  • 8 views
  • Freagra is déanaí ó cor-el

more options

http://www.claro-search.com/?affID=116677&tt=4612_6&babsrc=HP_ss&mntrId=c66222c1000000000000bc773772d22a

This link becomes my homepage whenever I launch firefox. Even if I change the homepage to one of my bookmarks, on restart it is automatically changed to the above link.

All Replies (3)

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

if your manual changes don't 'stick' after a restart of the browser, please look out for any suspicious extensions (like 3rd-party-toolbars or things you have not installed intentionally) presently installed under firefox/tools > addons > extensions or the programs section of the windows control panel and remove those entries.

afterwards install the search reset addon, it will revert the most common settings that got modified by adware back to the default ones: https://addons.mozilla.org/firefox/addon/searchreset/

in case this doesn't solve the issue please try this: go to firefox > help > troubleshooting information > profile folder - "show folder", then a new window will open up. in this window look out for a file named user.js (it might be used to overwrite your custom settings). in case it is present , delete or rename this file and restart firefox afterwards.

Remove a toolbar that has taken over your Firefox search or home page

How to fix preferences that won't save

more options

See also: